.titleBar { margin-bottom: 5px!important; }

IVR funzt nicht...

Dieses Thema im Forum "Asterisk Rufnummernplan" wurde erstellt von mime71, 20 Mai 2005.

  1. mime71

    mime71 Neuer User

    Registriert seit:
    18 Mai 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi @all,
    ich habe meinen * soweit am laufen, und wollte nun dass der Anrufer nach einer kurzen Ansage (drücken sie 1 für snom, 2 für softphone, 3 für Voicemail) auf die entsprechende Nebenstelle verbunden wird.
    Leider ignoriert * die Eingaben völlig und bringt mir nach der Ansage einen Timeout.
    Ausserdem erhalte ich auf der Console folgende Meldung: Timeout, but no rule 't' in Context 'default'.
    Kann mir jemand einen Tip geben woran das liegen könnte.
     

    Anhänge:

  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Woher kommt denn der Anruf der ins IVR geleitet wird? Ich vermute mal, dass der ueber sip kommt und dass du da einfach den falschen dtmfmode gewaehlt hast.
     
  3. mime71

    mime71 Neuer User

    Registriert seit:
    18 Mai 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So ich habe jetzt nochmal bischen rumgetestet.
    Der Stand ist folgender:
    1.)Wenn ich von einem Festnetztelefon aus anrufe funktioniert das IVR nicht.
    Auf der Console wird die Nachwahl(extension) auch nicht ausgegeben.

    2.)Wenn ich aber von einem SIP Softphone aus anrufe klappt alles wunderbar.In der Console kann man das auch schön sehen.

    Nun liegt natürlich die Erkenntniss nahe dass das DTMF Signal vom Sipgate Festnetzgateway nicht richtig oder gar nicht übermittelt wird.

    Oder kann ich doch noch irgendwas im Asterisk verbiegen damit geht??
     
  4. MassiveBlue

    MassiveBlue Neuer User

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    stell in der sip.conf mal folgendes für sipgate ein:

    dtmfmode=info