.titleBar { margin-bottom: 5px!important; }

Kann mich nicht im asterisk mit kphone anmelden!!!

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von maximus, 11 Apr. 2005.

  1. maximus

    maximus Neuer User

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo Leute , bin echt verzweifelt und auf eure Hilfe angewiesen!

    Also folgendes, habe asterisk bei mir am laufen, wenn ich aber versuche mich mit user und paß mit kphone anzumelden ,bekomme ich zwar einen Aufforderungfenster um meinen paß anzugeben, was ich auch mache , aber leider kann mich trotzdem nicht anmelden!!!

    hier ist einen Auszug aus meinen debug

    Sip read:
    REGISTER sip:192.168.0.3 SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.3:5062;branch=z9hG4bK596EDA56
    CSeq: 4698 REGISTER
    To: "momad" <sip:12@192.168.0.3>
    Authorization: Digest username="12", realm="asterisk", nonce="6881d5e3", uri="sip:192.168.0.3", cnonce="abcdefghi", nc=00000001, response="853559a87565392403741d2c47a92c53", opaque="", algorithm="MD5"
    Expires: 900
    From: "momad" <sip:12@192.168.0.3>
    Call-ID: 2121427491@192.168.0.3
    Content-Length: 0
    User-Agent: kphone/4.1.0
    Event: registration
    Allow-Events: presence
    Contact: "momad" <sip:12@192.168.0.3:5062;transport=udp>;methods="INVITE, MESSAGE, INFO, SUBSCRIBE, OPTIONS, BYE, CANCEL, NOTIFY, ACK, REFER"


    13 headers, 0 lines
    Using latest request as basis request
    Sending to 192.168.0.3 : 5062 (non-NAT)
    Transmitting (no NAT):
    SIP/2.0 100 Trying
    Via: SIP/2.0/UDP 192.168.0.3:5062;branch=z9hG4bK596EDA56
    From: "momad" <sip:12@192.168.0.3>
    To: "momad" <sip:12@192.168.0.3>;tag=as37cd3c4b
    Call-ID: 2121427491@192.168.0.3
    CSeq: 4698 REGISTER
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:12@192.168.0.3>
    Content-Length: 0


    to 192.168.0.3:5062
    Transmitting (no NAT):
    SIP/2.0 403 Forbidden
    Via: SIP/2.0/UDP 192.168.0.3:5062;branch=z9hG4bK596EDA56
    From: "momad" <sip:12@192.168.0.3>
    To: "momad" <sip:12@192.168.0.3>;tag=as37cd3c4b
    Call-ID: 2121427491@192.168.0.3
    CSeq: 4698 REGISTER
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:12@192.168.0.3>
    Content-Length: 0


    to 192.168.0.3:5062
    Apr 11 13:50:11 NOTICE[4193]: chan_sip.c:7708 handle_request: Registration from '"momad" <sip:12@192.168.0.3>' failed for '192.168.0.3'
    Scheduling destruction of call '2121427491@192.168.0.3' in 15000 ms
    Destroying call '2121427491@192.168.0.3'


    und aus Kphone


    SipCall: Incoming response
    SipTransaction: Incoming Response
    SipClient: Receiving message...

    SipClient: Received: 14:01:50.593
    ---------------------------------
    SIP/2.0 100 Trying
    Via: SIP/2.0/UDP 192.168.0.3:5062;branch=z9hG4bK124347E0
    From: "momad" <sip:12@192.168.0.3>
    To: "momad" <sip:12@192.168.0.3>;tag=as56c5b79a
    Call-ID: 2098492735@192.168.0.3
    CSeq: 833 REGISTER
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:12@192.168.0.3>
    Content-Length: 0


    SipCall: Incoming response
    SipTransaction: Incoming Response
    SipClient: Receiving message...

    SipClient: Received: 14:01:50.615
    ---------------------------------
    SIP/2.0 403 Forbidden
    Via: SIP/2.0/UDP 192.168.0.3:5062;branch=z9hG4bK124347E0
    From: "momad" <sip:12@192.168.0.3>
    To: "momad" <sip:12@192.168.0.3>;tag=as56c5b79a
    Call-ID: 2098492735@192.168.0.3
    CSeq: 833 REGISTER
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:12@192.168.0.3>
    Content-Length: 0


    SipCall: Incoming response
    SipTransaction: Incoming Response



    meine SIP.CONF

    [general]
    port =5060
    bindaddr=192.168.0.3
    tos=reliability
    srvlookup=yes
    nat=yes
    maxexpirey=1200
    defaultexpirey=1200
    context=default

    [10]
    type=friend
    username=10
    secret=10
    host=dynamic
    callerid="momad"
    canreinvite=no
    ;qualify=1200

    [11]
    type=friend
    username=11
    secret=11
    host=dynamic
    canreinvite=no
    ;qualify=1200

    [12]


    type=friend
    username=12
    secret=12
    host=dynamic
    canreinvite=no
    ;qualify=1200
     
  2. TinTin

    TinTin Aktives Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    1,864
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Scheint so als ob Du versuchst über Port 5062 mit kphone zu Asterisk zu connecten, im Asterisk hast Du aber port=5060 angegeben.

    Gruß,
    Tin
     
  3. maximus

    maximus Neuer User

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo
    danke für die schnelle Antwort.
    Habe es auch eben gemerkt , aber ich habe im kphone nicht eingestellt damit er über 5062 verbindet, wie kann ich so ein problem verhindern , das problem habe ich nur auf der Rechner auf meine Arbeitpaltz !! zuhause und auf meinen Laptop läuft alles einwandfrei.
    Danke
    Gruß
    maximus
     
  4. TinTin

    TinTin Aktives Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    1,864
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Auf dem Arbeitsplatz... hmm... vielleicht eine Firewall oder NAT die Dich behindert, mal mit dem Netzwerk-Administrator sprechen, falls Du das nicht bist ;) Im kphone muß sich der Port doch einstellen lassen? Kenne kphone leider nicht, sorry...

    Wo läuft denn Dein Asterisk? zu Hause hinter einem Router? Und jetzt versuchst Du das erste Mal von ausserhalb des eigenen internen Netzes dorthin zu connecten?

    Gruß,
    Tin
     
  5. maximus

    maximus Neuer User

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo

    Im kphone habe ich gekuckt , ich finde aber nirgendswo so eine einstellung über ports .
    Ich versuche erstmal mich in der Selbe Machine wo asterisk läuft mich anzumelden mit kphone, dann wollte ich von innerhalb meinen Netzwerk das alles testen!
    Gruß
    Maximus
     
  6. TinTin

    TinTin Aktives Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    1,864
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ahso, na, sowas hab' ich noch nie probiert... kphone läuft also auf dem selben Rechner wie Dein Asterisk... Da hab' ich Zweifel, ob das überhaupt geht, nimm lieber einen anderen Rechner im internen Netzwerk (mit anderer IP) zum testen, sonst haben Server (Asterisk) und Client (kphone) ja die gleiche IP, in Deinem Fall 192.168.0.3.. und das hört sich nicht gesund an *g*

    [Edit]
    Grad mal ein wenig gegoogled zu dem Thema, also kphone (oder auch andere softphones) auf dem gleichen Rechner wie Asterisk laufen zu lassen dürfte nichts werden, es sei denn man hat irgendwo noch einen weiteren Rechner mit einem SIP Proxy wie SER laufen. Also, wie schon gesagt, kphone auf einem anderen Rechner installieren.

    Gruß,
    Tin
     
  7. maximus

    maximus Neuer User

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo
    Danke erstmal für deine Hilfe , aber ich kann dir mit 100% Sicherheit daß es geht , weil bei mir zuhause und auf meinen Laptop , laufen Asterisk server und kPhone auf der selbe Machine , und das alles einwandfrei , kann von einen kphone zu den anderen kphone anklingen und verbinden , die 2 kphone und asterisk auf dem selben Rechner.
    Vielleicht ist das einen Zufall , weiß nicht.
    Gruß
    Maximus
     
  8. TinTin

    TinTin Aktives Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    1,864
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sorry, dass ich da falsch lag, ein anderer Tipp, hab' grad gelesen, dass es zu Problemen mit der Portbindung kommen kann, wenn kphone zuerst gestartet wird. Also mal rebooten und sichergehen, dass Du Asterisk =zuerst= startest, dann erst kphone.

    http://www.voip-info.org/wiki-Asterisk+phone+Kphone

    Gruß,
    Tin