.titleBar { margin-bottom: 5px!important; }

Kann nicht NT-Modus aktievieren

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von lukas, 5 Okt. 2004.

  1. lukas

    lukas Neuer User

    Registriert seit:
    11 Juni 2004
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Leute,
    ich bin leider kein Profi in Sachen Linux möchte aber Asterisk nutzen.
    Ausgangslage: suse linux 9.1, Kernel 2.6.5-7.108, HFC-Karte von Conrad
    Habe heute die ganze Nacht damit verbracht um den Asterisk mit bri-stuff zu installieren. Habe im Internet eine Anleitung von Christophers Blog gefunden und auch alles so Schritt für Schritt gemacht. Zunächst meldete er mir einen Fehler wo er nach einem CVS-Befehl suchte, dann habe ich alles installiert was mit CVS zu tun hat (also einfach nach cvs gesucht). Danach klappte Installation von Asterisk wunderbar, jetzt stehe ich beim Punkt "make loadNT" und komme leider nicht weiter. Der Fehler war zunächst im fehlendem Kernel-link (der hat nach einem Kernel 2.6 gesucht). Ich habe mich hier im Forum umgeschaut und fand diesen Tread http://www.ip-phone-forum.de/forum/viewtopic.php?t=4389
    habe auch folgendes gemacht:
    ln -s /usr/src/linux-2.6.4-52 /usr/src/linux-2.6
    ls -l /usr/src
    ls -l /usr/src/linux-2.6/
    cd /usr/src/linux-2.6; make
    dann hat er etwas sehr lange installiert und beim "make loadNT" meldet er jetzt
    linux:~/bin/bri-stuff.0.1.0-RC4a/zaphfc # make loadNT
    make -C /usr/src/linux-2.6 SUBDIRS=/root/bin/bri-stuff.0.1.0-RC4a/zaphfc modules
    make[1]: Entering directory `/usr/src/linux-2.6.5-7.108'
    Building modules, stage 2.
    MODPOST
    *** Warning: "zt_register" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_unregister" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_transmit" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_receive" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_ec_chunk" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    make[1]: Leaving directory `/usr/src/linux-2.6.5-7.108'
    modprobe zaptel
    insmod ./zaphfc.ko modes=1
    insmod: error inserting './zaphfc.ko': -1 File exists
    make: *** [loadlinux26NT] Error 1
    linux:~/bin/bri-stuff.0.1.0-RC4a/zaphfc #

    Die Datei zapfc.ko liegt doch im /root/bin/bri-stuff.0.1.0-RC4a/zaphfc/
    was will er denn? :(
    Ach ja, ich will ein ISDN-Telefon direkt an Asterisk anschliessen.
    Bitte um eure Hilfe
     
  2. lukas

    lukas Neuer User

    Registriert seit:
    11 Juni 2004
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also bitte, kann mir jemand helfen
    warum ist dieses Warning: "zt_register" [/root/bin/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] und efined!
    vielleicht hat er die HFC-Karte nicht richtig erkannt, kann das sein?
    bitte
    bin sehr dankbar für jede Hilfe
    :(
     
  3. Pirx

    Pirx Neuer User

    Registriert seit:
    26 Mai 2004
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo, profi bin ich auch nicht, aber wer ist das schon.
    mir fallen zwei sachen ein. zum einen schau' mal bitte, ob das zaphfc-modul nicht schon geladen ist, das insmod beschwert sich anscheinend über ein schon geladenes modul. zum anderen, die warnings: ging das compilieren des zaptel eigentlich glatt oder anderes gefragt, hast du den link auf deinen 2.6er kernel vor dem zaptel-compilieren gesetzt oder erst nachher? im letzteren fall == das compilieren von zaptel ging schief solltest du das zaptel nochmal neu installieren (ein "make clean" vorher schadet sicher nicht) und dann das zaphfc nochmal in angriff nehmen.
    bye
     
  4. lukas

    lukas Neuer User

    Registriert seit:
    11 Juni 2004
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich werde verrückt..........
    habe heute wieder einen Tag damit verbracht ohne Erfolg
    habe wieder Linux neu installiert und zwar komplett (alles angekreuzt etwa 5 Gb)
    update auf kernel 2.6.5-7.108 durchgeführt
    dann den link gesetzt: ln -s linux-2.6.5-7.108 /usr/src/linux-2.6
    überprüft: ls -l /usr/src
    ls -l /usr/src/linux-2.6/
    beim compilieren des zaptel macht er folgende warnings:




    Code:
    ****************************************************
             Downloading and patching finished.
    ****************************************************
    rm -f torisatool makefw tor2fw.h
    rm -f zttool
    rm -f *.o ztcfg tzdriver sethdlc sethdlc-new
    rm -f zonedata.lo tonezone.lo libtonezone.so.1.0 *.lo
    rm -f *.ko *.mod.c .*o.cmd
    rm -f gendigits tones.h
    rm -f libtonezone*
    rm -f tor2ee
    rm -f core
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_B                                            RI_DCHANS   -c -o gendigits.o gendigits.c
    cc -o gendigits gendigits.o -lm
    ./gendigits
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_B                                            RI_DCHANS    makefw.c   -o makefw
    ./makefw tormenta2.rbt tor2fw > tor2fw.h
    Loaded 69900 bytes from file
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_B                                            RI_DCHANS   -c -o ztcfg.o ztcfg.c
    cc -c -fPIC -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS -DBUILDING_TONEZONE -o zonedata.lo zonedata.c
    cc -c -fPIC -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS -DBUILDING_TONEZONE -o tonezone.lo tonezone.c
    ar rcs libtonezone.a zonedata.lo tonezone.lo
    cc -o ztcfg ztcfg.o -lm -L. libtonezone.a
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS   -c -o torisatool.o torisatool.c
    cc -o torisatool torisatool.o
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS   -c -o ztmonitor.o ztmonitor.c
    cc -o ztmonitor ztmonitor.o
    cc -c ztspeed.c
    cc -o ztspeed ztspeed.o
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS   -c -o zttool.o zttool.c
    cc -o zttool zttool.o -lnewt
    cc -I. -O4 -g -Wall -DBUILDING_TONEZONE    -DSTANDALONE_ZAPATA -DCONFIG_ZAPATA_BRI_DCHANS    zttest.c   -o zttest
    make -C /usr/src/linux-2.6 SUBDIRS=/root/bin/bri-stuff.0.1.0-RC4a/zaptel modules
    make[1]: Entering directory `/usr/src/linux-2.6.5-7.108'
    
    WARNING: Symbol version dump /usr/src/linux-2.6.5-7.108/Module.symvers is  missing, modules will have CONFIG_MODVERSIONS disabled.
    
      CC [M]  /root/bin/bri-stuff.0.1.0-RC4a/zaptel/zaptel.o
    /bin/sh: line 1: scripts/genksyms/genksyms: No such file or directory
    make[2]: *** [/root/bin/bri-stuff.0.1.0-RC4a/zaptel/zaptel.o] Error 1
    make[1]: *** [_module_/root/bin/bri-stuff.0.1.0-RC4a/zaptel] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.5-7.108'
    make: *** [linux26] Error 2
    make -C /usr/src/linux-2.6 SUBDIRS=/root/bin/bri-stuff.0.1.0-RC4a/zaptel modules
    make[1]: Entering directory `/usr/src/linux-2.6.5-7.108'
    
    WARNING: Symbol version dump /usr/src/linux-2.6.5-7.108/Module.symvers is  missing, modules will have CONFIG_MODVERSIONS disabled.
    
      CC [M]  /root/bin/bri-stuff.0.1.0-RC4a/zaptel/zaptel.o
    /bin/sh: line 1: scripts/genksyms/genksyms: No such file or directory
    make[2]: *** [/root/bin/bri-stuff.0.1.0-RC4a/zaptel/zaptel.o] Error 1
    make[1]: *** [_module_/root/bin/bri-stuff.0.1.0-RC4a/zaptel] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.5-7.108'
    make: *** [linux26] Error 2
    ****************************************************
    ZAPTEL installed.
    
    ich habe bestimmt was übersehen
    kann nicht ruhig schlafen
    wäre sehr dankbar für jede Hilfe
     
  5. Holg

    Holg Neuer User

    Registriert seit:
    17 Sep. 2004
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi lukas

    das kenn ich :wink:

    Vorab:
    Um asterisk richtig zum Laufen zu bringen brauchst du die Kernel-Sources deines installierten Kernels, libncurses5-dev und libssl-dev.

    Wenn du den Kernel ändern willst ZUERST den Kernel konfigrieren und kompilieren und in dein System einbinden, neu starten und schauen, daß alles funktioniert.

    Wenn du das hast, dann erst bri-stuff "installieren".

    Wenn du Die zwei Schritte vertauschst, versucht dein "make loadNT", dass bspw. mit Version 2.4.xx kompiliert wurde, sich als Modul eines Kernel 2.6.x einzubinden, das klappt nicht.

    Wie gesagt:
    Zuerst Kernel, dann bri-stuff

    Wie man den 2.6er Kernel zum Laufen bringt, siehst du unter dem Link Kernel kompilieren. Aber ich glaube google liefert da auch genug Hinweise.
    Ich würde dir auch empfehlen dich da ein wenig rein zu arbeiten, zumindest für die Ansprüche an deinem PC. Und wenn du sicher bist das der Kernel läuft, kommt asterisk :wink:

    Hier noch ein paar Links

    asterisk allgemein
    asterisk und HFC
    Kernel kompilieren

    Mach das bloß nicht, da du dir dein System nur zu müllst.
    Ich empfehle dir minimal anzufange und nach und nach nachzuinstallieren. Hat den Vorteil, du mußt dich mit dem Thema Software Installation auseinandersetzen und tauchst ein wenig in die Linux Welt ein.

    Wenn der PC nur für asterisk läuft , dann würde ich noch nicht mal X11 installieren (also kein KDE oder Gnome oder sonst was...)

    Hoffe ein paar Anregungen gegeben zu haben...

    holg