.titleBar { margin-bottom: 5px!important; }

Karte überprüfen ?

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von achim22, 27 Dez. 2005.

  1. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!
    Wie kann ich testen, ob die HFC Karte im NT Modus ist?
    Ich habe das Problem das die Telefonanlage, die an der HFC Karte hängt, so tut als ob kein ISDN Signal zur Verfügung steht (sie blinkt).Also auch kein Freizeichen.

    Die Karte müsste aber ok sein. Hatte bis vor kurzem noch Fli4 mit Asterisk am laufen, und da blinkte sie nicht und es gab auch ein Freizeichen.

    Habe Asterisk laut Anleitung http://www.asterisk.li/ aufgesetzt.

    Gruß
    Achim
     
  2. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @achim22

    nachdem Du das Modul lädtst bekommt man ein Info:
    "zaphfc: Card 0 configured for NT mode"
    am besten mit dmesg nachschauen.

    oder "cat /proc/zaptel/1"
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 ACTIVATED (G3)" AMI/CCS

    Gruß
    britzelfix
     
  3. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    da stimmt was nicht. Die Karte läuft, glaube ich, nicht im NT Modus.
    Wenn Ich make loadNT eingebe kommt diese:
    Da stimmt doch was nicht mit dem Kernel. Habe aber keine Ahnung was ich da machen muss.



    telefon:/usr/src/asterisk/bristuff-0.2.0-RC8q/zaphfc # make loadNT
    make -C /usr/src/linux-2.6 SUBDIRS=/usr/src/asterisk/bristuff-0.2.0-RC8q/zaphfc ZAP=-I/usr/src/asterisk/bristuff-0.2.0-RC8q/zaptel-1.0.10 modules
    make[1]: Entering directory `/usr/src/linux-2.6.11.4-20a'

    WARNING: Symbol version dump /usr/src/linux-2.6.11.4-20a/Module.symvers is missing; modules will have no modversions.

    Building modules, stage 2.
    MODPOST
    make[1]: Leaving directory `/usr/src/linux-2.6.11.4-20a'
    modprobe zaptel
    insmod ./zaphfc.ko modes=1
    ztcfg -v

    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    3 channels configured.

    telefon:/usr/src/asterisk/bristuff-0.2.0-RC8q/zaphfc # cat /proc/zaptel/1
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 1 [NT]" AMI/CCS

    1 ZTHFC1/0/1 Clear
    2 ZTHFC1/0/2 Clear
    3 ZTHFC1/0/3 HDLCFCS
    telefon:/usr/src/asterisk/bristuff-0.2.0-RC8q/zaphfc #
     
  4. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @achim22

    und mit dmesg hast Du nicht nachgeschaut?

    hier steht zwar NT, aber kein ACTIVATED, bzw. DEACTIVATED.
    Hast Du denn die Kabel nachgeprüft?

    Gruß
    britzelfix
     
  5. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi britzelfix!
    Kabel sind alle angeschloßen. Ich weiss jetzt nicht wie ich das machen muss, dass die Auflistung hier in einem Fenster erscheint.
    Also füge ich das Ergebniss von dmesg jetzt einfach mal so ein, nicht meckern !!!...smile

    CAPI Subsystem Rev 1.1.2.8
    capifs: Rev 1.1.2.3
    capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)
    capi: Rev 1.1.2.7: unloaded
    CAPI Subsystem Rev 1.1.2.8
    capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)
    fcpci: unsupported module, tainting kernel.
    fcpci: module license 'Proprietary' taints kernel.
    fcpci: AVM FRITZ!Card PCI driver, revision 0.6.0
    fcpci: (fcpci built on Mar 24 2005 at 00:27:51)
    ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
    ACPI: PCI interrupt 0000:02:09.0[A] -> GSI 11 (level, low) -> IRQ 11
    fcpci: AVM FRITZ!Card PCI found: port 0x4c00, irq 11
    fcpci: Loading...
    fcpci: Driver 'fcpci' attached to stack. (152)
    fcpci: Stack version 3.11-02
    kcapi: Controller 1: fcpci-4c00-11 attached
    kcapi: card 1 "fcpci-4c00-11" ready.
    fcpci: Loaded.
    CSLIP: code copyright 1989 Regents of the University of California
    ISDN subsystem Rev: 1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
    capidrv-1: now up (2 B channels)
    capidrv-1: D2 trace enabled
    capidrv: Rev 1.1.2.2: loaded
    HiSax: Linux Driver for passive ISDN cards
    HiSax: Version 3.5 (module)
    HiSax: Layer1 Revision 2.46.2.5
    HiSax: Layer2 Revision 2.30.2.4
    HiSax: TeiMgr Revision 2.20.2.3
    HiSax: Layer3 Revision 2.22.2.3
    HiSax: LinkLayer Revision 2.59.2.4
    HiSax: Total 1 card defined
    HiSax: Card 1 Protocol EDSS1 Id=contr1 (1)
    HiSax: HFC-PCI driver Rev. 1.48.2.4
    ACPI: PCI interrupt 0000:02:07.0[A] -> GSI 5 (level, low) -> IRQ 5
    HiSax: HFC-PCI card manufacturer: CCD/Billion/Asuscom card name: 2BD0
    HFC-PCI: defined at mem 0xc8ca8000 fifo 0xc3878000(0x3878000) IRQ 5 HZ 1000
    HFC 2BDS0 PCI: IRQ 5 count 916
    HFC_PCI: resetting card
    HFC 2BDS0 PCI: IRQ 5 count 951
    HiSax: DSS1 Rev. 2.32.2.3
    HiSax: 2 channels added
    HiSax: MAX_WAITING_CALLS added
    HiSax: debugging flags card 1 set to 4
    end_request: I/O error, dev fd0, sector 0
    zaptel: unsupported module, tainting kernel.
    Zapata Telephony Interface Registered on major 196
    zaphfc: no version for "struct_module" found: kernel tainted.
    zaphfc: unsupported module, tainting kernel.
    PCI: Enabling device 0000:02:07.0 (0006 -> 0007)
    ACPI: PCI interrupt 0000:02:07.0[A] -> GSI 5 (level, low) -> IRQ 5
    zaphfc: CCD/Billion/Asuscom 2BD0 configured at mem 0xc8cd4000 fifo 0xc5978000(0x 5978000) IRQ 5 HZ 1000
    zaphfc: Card 0 configured for NT mode
    zaphfc: 1 hfc-pci card(s) in this box.
    Registered tone zone 3 (Netherlands)
    Registered tone zone 3 (Netherlands)
    telefon:/usr/src/asterisk/bristuff-0.2.0-RC8q/zaphfc #
     
  6. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @achim22

    Ich nehme an, Du hast Suse 9.3?

    Ich vermute mal der Fehler liegt daran, daß Du falsche Header
    benutzt aber da streiten sich die Geister. Einige meinten, daß
    hätte keinen Einfluß, ich bin der Meinung, daß man besser mit
    einem ungetaintetem Kernel fährt.

    Was Du machen kannst ist, eine andere Distri zu nehmen, oder
    einen vanilla Kernel (von www.kernel.org) und es noch mal
    ohne "tainted" zu versuchen. Dann erst kann man sicher sein.

    Einen Versuch ist es wert.

    Gruß
    britzelfix
     
  7. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Für HFC-Karten über die du telefonieren willst, musst du im Yast den autoload von hisax auf manuell umstellen.

    Hisax und zap streiten sich sonst um deine Hardware.
     
  8. achim22

    achim22 Neuer User

    Registriert seit:
    20 Okt. 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!
    Ja, habe Suse 9.3. Kann aber auch was anderes aufspielen wenn es besser ist. Suse 9.2 etc.

    Habe per Yast den autoload von hisax auf manuell gestellt (habe es ja nach deiner Anleitung gemacht....smile) . Mist, weiß leider nicht bescheid wie ich das mit dem neuen Kernel machen muß. Muß ich dann alles noch einmal von vorne machen?

    Gruß
    Achim
     
  9. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Scheint aber nicht funktioniert zu haben, denn dein Rechner lädt laut deinem hier veröffentlichten Protokoll immer noch Hisax.

    Gruß
    Karl-Heinz