kein dtmf unter misdn -> kein transfer

he11e

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
37
Punkte für Reaktionen
0
Punkte
0
nach stundenlanger suche im forum sowie in meiner config mach ich jetzt einen thread auf.

kurz: atxfer funktioniert seit ein paar tagen nichtmehr.

geändert hab ich nichts, da bin ich mir sicher. mittags hab ichs noch getestet und abends kam dann eine beschwerde das es nichtmehr funktioniert.

ich höre die dtmf töne aber es passiert nichts.
mit zaptel funktioniert es optimal, nur mit misdn nicht.

hier erstmal meine configs:
misdn-init.conf
Code:
card=1,hfcpci,dtmf
card=2,hfcpci,dtmf

nt_ptmp=1
te_ptmp=2

poll=128
dsp_options=2
dtmftreshold=500
debug=2
Code:
[general]
debug=0
tracefile=/var/log/misdn.trace
bridging=no
stop_tone_after_first_digit=no
append_digits2exten=yes

[default]
context=misdn
language=de
nationalprefix=0
internationalprefix=00
te_choose_channel=no
dialplan=2
hold_allowed=yes
echocancel=32

[ISDNintern]
echotraining=no
jitterbuffer=1000
senddtmf=yes
pmp_l1_check=no
localdialplan=2
ports=1
context=from-ISDN

[ISDNtcom]
jitterbuffer=1000
senddtmf=yes
localdialplan=2
rxgain=0
txgain=1
pmp_l1_check=no
ports=2
context=from-pstn
callerid=91222
msns=91222,91223,91224,9415003,9415022,9415023
so sieht die dial option aus
Code:
exten => 91222,1,Dial(mISDN/g:ISDNintern/20/s|13|t)
Code:
router*CLI> show features
Builtin Feature           Default Current
---------------           ------- -------
Pickup                    *8      *8
Blind Transfer            #       1
Attended Transfer                 #
One Touch Monitor
Disconnect Call           *       0
jitterbuffer hab ich schon kleiner gestellt, in der dial option hab ich das /s hinzugefügt und senddtmf hab ich auch aktiviert. in der misdn-init.conf hab ich dtmf hinzugefügt. ich weiss einfach nicht woran es liegt! da die anlage produktiv benutzt wird ist das ein großes problem.

Code:
router*CLI> misdn show config
Misdn General-Config:
 -> Version: chan_misdn-0.3.1-rc23
 -> misdn_init: /etc/misdn-init.conf -> debug: 0
 -> tracefile: /var/log/misdn.trace  -> bridging: no
 -> stop_tone_after_first_digit: no  -> append_digits2exten: yes
 -> dynamic_crypt: no                -> crypt_prefix:
 -> crypt_keys:                      -> ntdebugflags: 0
 -> ntdebugfile: /var/log/misdn-nt.log

[PORT 1]
 -> name: ISDNintern                 -> allowed_bearers: all
 -> far_alerting: no                 -> rxgain: 0
 -> txgain: 0                        -> te_choose_channel: no
 -> pmp_l1_check: no                 -> block_on_alarm: yes
 -> hdlc: no                         -> context: from-ISDN
 -> language: de                     -> musicclass: default
 -> callerid:                        -> method: standard
 -> dialplan: 2                      -> localdialplan: 2
 -> cpndialplan: 0                   -> nationalprefix: 0
 -> internationalprefix: 00          -> presentation: -1
 -> screen: -1                       -> always_immediate: no
 -> nodialtone: no                   -> immediate: no
 -> senddtmf: yes                    -> hold_allowed: yes
 -> early_bconnect: yes              -> incoming_early_audio: no
 -> echocancel: 32                   -> echocancelwhenbridged: no
 -> need_more_infos: no              -> jitterbuffer: 1000
 -> jitterbuffer_upper_threshold: 0  -> callgroup:
 -> pickupgroup:                     -> msns: none
 -> ptp: no

[PORT 2]
 -> name: ISDNtcom                   -> allowed_bearers: all
 -> far_alerting: no                 -> rxgain: 0
 -> txgain: 1                        -> te_choose_channel: no
 -> pmp_l1_check: no                 -> block_on_alarm: yes
 -> hdlc: no                         -> context: from-pstn
 -> language: de                     -> musicclass: default
 -> callerid: 91222                  -> method: standard
 -> dialplan: 2                      -> localdialplan: 2
 -> cpndialplan: 0                   -> nationalprefix: 0
 -> internationalprefix: 00          -> presentation: -1
 -> screen: -1                       -> always_immediate: no
 -> nodialtone: no                   -> immediate: no
 -> senddtmf: yes                    -> hold_allowed: yes
 -> early_bconnect: yes              -> incoming_early_audio: no
 -> echocancel: 32                   -> echocancelwhenbridged: no
 -> need_more_infos: no              -> jitterbuffer: 1000
 -> jitterbuffer_upper_threshold: 0  -> callgroup:
 -> pickupgroup:                     -> msns: 9415023, 9415022, 9415003, 91224, 91223, 91222
 -> ptp: no
mit einer neueren misdn version hab ich übrigens auch große probleme. sobald ich ein update mache hängt sich asterisk beim ersten anruf auf.

am liebsten würde ich die ganze sache mit der R (flash) taste machen. doch das geht leider auch nicht. wenn ich die R taste drücke hört der anrufer moh, ich kann einen anderen internen teilnehmer anrufen, mit ihm reden; doch sobald ich den hörer auflege und es den anrufer sowie den angerufenen verbinden sollte schmeißt asterisk genau diese zwei aus der leitung.

ich bin für jeden versuch mir zu helfen mehr wie dankbar!!!

helle
 

crich

Mitglied
Mitglied seit
1 Sep 2005
Beiträge
529
Punkte für Reaktionen
0
Punkte
0
hallo helle,

Problem1:

deine DTMF Töne werden wahrscheinlich nicht erkannt weil ein Threshold von 500 doch ziemlich hoch ist, du kannst ja mal versuchen länger auf die # Taste zu drücken, dann sollte es nach ner weile klappen. typisch gute Werte für den dtmf threshold sind so um 200 etwa


Problem2:

mit der rc26 sollte die "R"- Taste wieder funzen, beim update musst du am besten das "install-misdn-mqueue.tar.gz" benutzen, das zieht dann die aktuellen mISDN/mISDNuser Quellen usw.
 

he11e

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
37
Punkte für Reaktionen
0
Punkte
0
hi crich

zu 1.
dtmfthreshold hab ich auf 200 und 100 probiert ohne erfolg. und auch wenn ich lange auf der # drauf bleibe geht asterisk nicht in transfer über.

ist sonst noch was falsch an der config?
oder was sind den alle faktoren an denen es liegen kann?

zu 2.
ich hatte letzte woche schon asterisk 1.2.13 - misdn rc26 instaliert, aber leider bekam ich ihn nicht stabil. immer wieder irgendwelche probleme. nun hab ich 1.2.12.1 mit misdn chan_misdn-0.3.1-rc23 stabil am laufen.

misdn instaliere ich nur noch mit dem mqueue script.

asterisk hab ich mit dem script auf der beronet seite instaliert sowie mit dem ebuild im gentoo portage. beides mit den gleichen folgen. mit debug=3 konnte ich keine warnings oder errors sehen.

wird wohl nächstes wochenende werden bis ich wieder zeit hab für 1.2.13.

danke so weit

gruß
 

he11e

Neuer User
Mitglied seit
10 Sep 2006
Beiträge
37
Punkte für Reaktionen
0
Punkte
0
hi crich

hab jetzt asterisk 1.2.13 mit chan_misdn-0.3.1-rc26 instaliert. einen absturz hat ich als ich mit der R taste rumspielte. allerdings nicht reproduzierbar.
dennoch funktioniert die R-Taste nicht mehr oder weniger wie ich es im 1. post beschrieben hab, auch mit der rc26 - leider.


dtmftreshold hab ich im momment auf 200 eingestellt. nun funktioniert atxfer mit einem beetel 440i. mit den tiptel telefonen die auf dem gleichen s0-bus liegen funktioniert es leider nicht.

werd noch bissl mit dtmfthreshold spielen...


dtmftreshold=100 und es funktioniert auch mit den tiptels.
somit ist nur noch die 'R' taste die nicht so geht wie sie soll.

gruß
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,284
Beiträge
2,032,400
Mitglieder
351,809
Neuestes Mitglied
wolfgang17