.titleBar { margin-bottom: 5px!important; }

Kein Freizeichen bei Anruf von CAPI über 1und1-SIP

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von ischisch, 4 Sep. 2005.

  1. ischisch

    ischisch Neuer User

    Registriert seit:
    4 Sep. 2005
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    mein Problem:
    Bei einem ausgehenden Gespräch von einem ISDN-Kanal über asterisk und meinen 1und1-SIP-Account zu einem beliebigen Festnetzanschluß gibt asterisk für den Anrufer keinen Ringing-tone aus, obwohl der Anruf durchgeht und das Zieltelefon beim Angerufenen klingelt. Der Ringing-tone wird nur dann ausgegeben, wenn der Angerufene auch über einen 1und1-SIP-Account angemeldet ist und die Verbindung darüber aufgebaut wird.
    Die Option r in der Dial-application einzufügen, wäre sicher nciht sinnvoll, da dann generell ein Ringing-tone ausgegeben würde, egal, ob die Verbindung durchgeht.
    Sonst läuft alles, wie es soll. Weiß jemand eine Lösung für dieses Problem?

    Viele Grüße, Christian


    extensions.conf:
    exten => _X.,1,Dial(SIP/${EXTEN}@mein-1und1-sip-out,30)
    exten => _X.,2,Congestion
    exten => _X.,3,Hangup

    sip.conf:
    [mein-1und1-sip-out]
    type=peer
    secret=meinpasswort
    username=meinetelefonnr
    host=sip.1und1.de
    fromuser=meinetelefonnr
    fromdomain=sip.1und1.de
    nat=no
    insecure=very


    Meine Konfiguration:
    Debian testing, Kernel 2.6.7
    asterisk 1.0.7.dfsg.1-2 mit asterisk-chan-capi 0.3.5-11
    AVM-Fritz-Card-PCI
    1und1 DSL 2000
    1und1-SIP-Account
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Versuch es mal damit, dass Du vor das Dial-Kommando ein "Answer setzt".

    exten => _X.,1,Answer
    exten => _X.,2,Dial(SIP/${EXTEN}@mein-1und1-sip-out,30)
    exten => _X.,3,Congestion
    exten => _X.,4,Hangup
     
  3. ischisch

    ischisch Neuer User

    Registriert seit:
    4 Sep. 2005
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    danke für die Antwort. Das hat leider keine Änderung gebracht.

    Genaugenommen ist meine Konfiguration folgendermaßen:
    Der interne S0-Bus einer TK-Anlage ist an die ISDN-Karte angeschlossen.

    capi.conf:
    -----------
    [interfaces]
    msn=25
    incomingmsn=25
    controller=1
    softdtmf=0
    context=CAPI-IN
    echocancel=yes
    echotail=64
    devices=2


    extensions.conf:
    -------------------
    [CAPI-IN]
    exten => 25,1,Answer
    exten => 25,2,DISA(no-password|MEIN-SIP-OUT)

    [MEIN-SIP-OUT]
    exten => _X.,1,Dial(SIP/${EXTEN}@mein-1und1-sip-out,30)
    exten => _X.,2,Congestion
    exten => _X.,3,Hangup

    sip.conf:
    ---------
    register ....

    [mein-1und1-sip-out]
    type=peer
    secret=meinpasswort
    username=meinetelefonnr
    host=sip.1und1.de
    fromuser=meinetelefonnr
    fromdomain=sip.1und1.de
    nat=no
    insecure=very

    Ich habe auch einen zusätzliches Answer vor der Dial-application ausprobiert, hat aber meines Wissens in diesem Fall keinen Sinn und hat auch nicht funktioniert.

    Christian
     
  4. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Graube ehrlich gesagt nicht, dass es an chan_capi liegt. Wenn der Channel schon beantwortet ist, wird einfach alles stumpf weitergegeben. 1und1 sended vielleicht einfach keinen ringtone. Benutz die "r" Option. der Klingelton sollte eigentlich nur abgesüpielt werden, wenn auch wirklich am anderen Ende das Telefon klingelt (so ist es zu mindest bei mir). Wenn der andere Client nicht angemeldet ist, sollte die Dial-Applikation eigentlich in die Priorität n + 101 springen. Das wäre bei dir dann ebenfalls ein Hangup, da die ja nicht existiert. Kannst Dir dann auch ne ansage einspielen lassen, dass der Client nicht erreichbar ist, oder so.