.titleBar { margin-bottom: 5px!important; }

kein misdn mehr installierbar?

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von winschrott, 1 Dez. 2008.

  1. winschrott

    winschrott Neuer User

    Registriert seit:
    27 Jan. 2007
    Beiträge:
    41
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo zusammen,

    langsam bin ich kurz vor der Verzweiflung. Irgendwie bekomme ich es nicht (mehr) hin:

    Ubuntu 8.10 server, AMD64, Kernel 2.6.25.20 (selbstgebaut)

    Wenn ich versuche misdn 1.1.7.2 aus dem zaptel-Packerl zu kompilieren hagelt es massive Mengen an Fehlern:

    [snip]
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1424: error: ‘ISDN_PID_L2_B_TRANS’ undeclared (first use in this function)
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1425: error: implicit declaration of function ‘mISDN_register’
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1436: warning: passing argument 1 of ‘pnp_register_driver’ from incompatible pointer type
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c: In function ‘Fritz_cleanup’:
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1476: error: implicit declaration of function ‘mISDN_unregister’
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1476: error: ‘fritz’ undeclared (first use in this function)
    /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.c:1485: warning: passing argument 1 of ‘pnp_unregister_driver’ from incompatible pointer type
    make[2]: *** [/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/avm_fritz.o] Error 1
    make[1]: *** [_module_/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.25.20'
    make: *** [all] Error 2

    Irgendwie hänge ich hier fest. Hat jemand eine Idee?

    Danke,
    winschrott
     
  2. JanG80

    JanG80 Mitglied

    Registriert seit:
    12 Juni 2008
    Beiträge:
    237
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die alten mISDN Pakete machen Probleme mit den neuen Kerneln. Der neueste Kernel, auf dem mISDN 1.1.X bei mir laufen wollte, war 2.6.18.
     
  3. winschrott

    winschrott Neuer User

    Registriert seit:
    27 Jan. 2007
    Beiträge:
    41
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hmm,
    weils mich so gelangweilt hat bin ich jetzt doch wieder bei Debian gelandet. Ratzfatz alles OK.
    So etwas doofes. Weder mISDN noch - weil es ja auch mISDN braucht - bristuff geht mit neuen Kerneln. Das kanns ja wohl nicht sein.

    Gruß
    winschrott