.titleBar { margin-bottom: 5px!important; }

kein Rufzeichen bei Anruf über sip

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von lotus-eater, 13 Dez. 2006.

  1. lotus-eater

    lotus-eater Neuer User

    Registriert seit:
    25 Sep. 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Telefonate können über Voip und Festnetz geführt werden, allerdings ist nur bei Anrufe über das Festnetz ein Rufzeichen zu hören, wenn die Extension 575 und 576 gewählt wird. Ohne b (early B3 connects) ist in keiner der drei Konfigurationen ein Rufzeichen zu hören.
    Code:
    exten => 574,1,Dial(CAPI/eicon3/xxxxxx/b,60,r)
    exten => 575,1,Dial(CAPI/eicon3/xxxxxx/b,60,R)
    exten => 576,1,Dial(CAPI/eicon3/xxxxxx/b,60)
    
    Leider schaffe ich es nicht mit dem SIP Kanal
    Code:
    exten => 571,1,Dial(SIP/xxxxx@xxxx-out,60,r)
    exten => 572,1,Dial(SIP/xxxxx@xxxx-out,60,R)
    exten => 573,1,Dial(SIP/xxxxx@xxxx-out,60)
    
    Die interne Telefonanlage mit analogen Telfonapparaten hängt an eicon1. Mit x-lite funktioniert alles einwandfrei.
    meine capi.conf:
    Code:
    [general]
    nationalprefix=0
    internationalprefix=00
    rxgain=0.8
    txgain=0.8
    ;ulaw=yes        ;set this, if you live in u-law world instead of a-law
    
    [eicon1]
    isdnmode=did
    ntmode=yes
    incomingmsn=*
    controller=1
    softdtmf=0
    group=1
    ;bridge=yes
    context=office
    echocancel=yes
    echocancelold=no
    devices=2
    immediate=yes
    overlapdial=yes
    
    [eicon2]
    msn=xxxxxx
    isdnmode=MSN
    ntmode=no
    incomingmsn=*
    controller=2
    softdtmf=0
    group=2
    bridge=yes
    context=capi-in
    echocancel=yes
    echocancelold=no
    faxdetect=incoming
    devices=2
    
    [eicon3]
    msn=xxxxxx
    isdnmode=MSN
    ntmode=no
    incomingmsn=*
    controller=3
    softdtmf=0
    group=2
    bridge=yes
    context=capi-in
    echocancel=yes
    echocancelold=no
    devices=2
    
    Ich weiß nicht wo ich ansetzen muss.
     
  2. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei CAPI brauchst Du ,rR nicht. Wenn Du die Progress-Toene hoeren willst, benutze early-B3.
    Warum es bei SIP nicht funktioniert, kann ich nicht sagen, denn das hat mit CAPI dann nichts zu tun.

    Armin
     
  3. lotus-eater

    lotus-eater Neuer User

    Registriert seit:
    25 Sep. 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für deine Antwort.

    Es ist nur komisch, dass es jetzt nicht mehr funktioniert. Bei der vorherigen Konfiguration mit bristuff in Kombination mit einer HFC-Karte war dies kein Problem.

    Wird das Rufzeichen mit r oder R nicht genauso von Asterisk erzeugt wie mit Playtones? Dies kann ich nämlich hören.

    Hab auch die "Source of local tones" Treibereinstellung ausprobiert, aber hat auch nichts am Verhalten verändert. Werde mal weiter in Richting SIP Channel suchen.