.titleBar { margin-bottom: 5px!important; }

Kein Ton bei ausgehendem Anruf

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von commanderx, 28 Nov. 2005.

  1. commanderx

    commanderx Neuer User

    Registriert seit:
    27 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ich bin erst seit letzten Samstag in der Asterisk Welt.
    Ich kann über X-Lite Anrufe aus dem Festnetz annehmen und auch externe Nummern anrufen.
    Allerdings hört mich der angerufenen nicht und ich ihn auch nicht.
    Bei eingehenden Anrufen klappt das wunderbar.
    Da ich nicht weiss was für Angaben bzw config File braucht, geb ich ein paar allgemeine Infos.
    Falls mehr gebraucht wird einfach Bescheid sagen.
    Das ganze läuft unter Debian Sarge.
    Asterisk hat die Version 1.0.7.dfsg.1-2, und meldet sich in der Console mit Asterisk 1.0.7-BRIstuffed-0.2.0-RC7k.
    chan_capi ist Version 0.3.5.
    Im Rechner steckt eine FritzCard PCI.

    Grüssle....
     
  2. cibi

    cibi Mitglied

    Registriert seit:
    6 Apr. 2005
    Beiträge:
    561
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ba-Wü
    Welche Kernelversion?
    Fall 2.6 musst du auf jeden Fall chan_capi_cm nehmen.
    Eventuell kann es auch nicht schanden die neuste bristuff Version (-RC8o) zu Benutzen.
     
  3. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also, die Asterisk-Version ist schon reichlich alt. Ao damit chan_capi_cm läuft?
    Ich würde Dir dazu raten, Asterisk selbst zu kompilieren. Das ist auch nicht schwer!
     
  4. commanderx

    commanderx Neuer User

    Registriert seit:
    27 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kernel ist 2.6.13.2.
    Das mit chan_capi_cm werde ich mal probieren.
    Wenn das nicht geht muss ich wohl Asterisk selbst kompilieren.

    Nur was mich interessieren würde, was unterscheidet denn einen ausgehenden Anruf von einem eingehenden?
    Also, in meinem Fall, wieso bei dem einen Ton kommt, und bei dem anderen nicht?
     
  5. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Der Unterschied ist sehr gross und das Handling im chan_capi auch. Bei Version 0.3.5 ist ein Fehler drin, der sich bei Kernelversionen 2.6>9 erst zeigt.

    Armin
     
  6. commanderx

    commanderx Neuer User

    Registriert seit:
    27 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ok danke, dann werde ich mir mal bei Gelegenheit ans kompilieren machen.
     
  7. cibi

    cibi Mitglied

    Registriert seit:
    6 Apr. 2005
    Beiträge:
    561
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ba-Wü
    Sollte keine Problem mit Debian sein (s. Signatur).
    Um Probleme zu vermeiden würde ich die alte Version komplett deinstallieren (Backup natürlich nicht vergessen, nicht nur /etc/asterisk sondern eventuell auch die Datenbank, etc).
    (ich benutze Asterisk aber selber noch nicht allzu lange, also Vorsicht bei meinen Tipps ;)

    Dann einfach das aktuelle bristuff Paket herunterladen und kompilieren/installieren.

    Sollte Asterisk vorher von den offizillen Debian Quellen installiert worden sein, würde ich das init Sript behalt (/etc/init.d).
    Damit kannst du dann nacher Asterisk wieder als non-root starten; ein paar Modifikationen sind aber vor/nach dem Kompilieren nötig:
    http://www.ip-phone-forum.de/forum/viewtopic.php?t=21305&postdays=0&postorder=asc&start=15

    Das gleiche mit chan_capi_cm, geht alles recht einfach.
     
  8. commanderx

    commanderx Neuer User

    Registriert seit:
    27 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, hat alles wunderbar geklappt, aber das telefonieren kann ich erst richtig heute abend testen.
    Hier rennt jetzt Asterisk 1.2.0-BRIstuffed-0.3.0-PRE-1 mit chan-capi_cm 0.6.1

    Danke für den Hint in dem anderen Thread, cibi