keine eingehenden Anrufe mit Asterisk

Chimbo2004

Mitglied
Mitglied seit
24 Jan 2005
Beiträge
344
Punkte für Reaktionen
0
Punkte
16
Ich habe staendig mit Problemen bei eingehenden Anrufen ueber Asterisk zu kaempfen.
Gestern ging es noch gut ,ich hatte eine neu erworbene Nummer in Caracas zu Sipgate geroutet und Anrufe kamen in hervorragender Qualitaet ueber Asterisk herein.
Heute aber wieder einmal sind keine eingehenden Anrufe moeglich weder ueber Sipgate
noch ueber Carpo oder ueber die Nummer in Caracas.
Auf der Konsole sieht das dann so aus:

Anruf von Carpo auf Sipgate

Code:
[Dec 17 17:14:37] WARNING[4524]: app_dial.c:1183 dial_exec_full: Unable to create channel of type 'SIP' (cause 3 - No route to destination)
  == Everyone is busy/congested at this time (1:0/0/1)
    -- Executing [[email protected]:4] Goto("SIP/sipgate.de-082a9338", "r-CHANUNAVAIL|1") in new stack
    -- Goto (ankommend,r-CHANUNAVAIL,1)
[Dec 17 17:14:37] WARNING[4524]: pbx.c:2483 __ast_pbx_run: Channel 'SIP/sipgate.de-082a9338' sent into invalid extension 'r-CHANUNAVAIL' in context 'ankommend', but no invalid handler
Kurze Zeit spaeter ohne Probleme:
Code:
 Executing [[email protected]:6] Goto("SIP/2000-082a7da8", "s-CONGESTION|1") in new stack
    -- Goto (bingo,s-CONGESTION,1)
    -- Executing [[email protected]:1] Goto("SIP/2000-082a7da8", "fehler|s-CONGESTION|1") in new stack
    -- Goto (fehler,s-CONGESTION,1)
    -- Executing [[email protected]:1] Goto("SIP/2000-082a7da8", "s-NOANSWER|1") in new stack
    -- Goto (fehler,s-NOANSWER,1)
    -- Executing [[email protected]:1] Playback("SIP/2000-082a7da8", "vm-theperson") in new stack
    -- <SIP/2000-082a7da8> Playing 'vm-theperson' (language 'de')
    -- Executing [[email protected]:2] SayDigits("SIP/2000-082a7da8", "") in new stack
    -- Executing [[email protected]:3] Playback("SIP/2000-082a7da8", "vm-isunavail") in new stack
    -- <SIP/2000-082a7da8> Playing 'vm-isunavail' (language 'de')
    -- Executing [[email protected]:4] Hangup("SIP/2000-082a7da8", "") in new stack
  == Spawn extension (fehler, s-NOANSWER, 4) exited non-zero on 'SIP/2000-082a7da8'
    -- Executing [[email protected]:1] Dial("SIP/204.11.194.38-082a7da8", "SIP/2000") in new stack
    -- Called 2000
    -- SIP/2000-082a9338 is ringing
    -- SIP/2000-082a9338 answered SIP/204.11.194.38-082a7da8
    -- Packet2Packet bridging SIP/204.11.194.38-082a7da8 and SIP/2000-082a9338
  == Spawn extension (default, 0058212, 1) exited non-zero on 'SIP/204.11.194.38-082a7da8'
Und so geht das laufend,mal gehts und mal wieder nicht.Kann jemand helfen ?
 
Zuletzt bearbeitet:

kombjuder

IPPF-Promi
Mitglied seit
2 Nov 2004
Beiträge
3,086
Punkte für Reaktionen
0
Punkte
0
I
[Dec 17 17:14:37] WARNING[4524]: app_dial.c:1183 dial_exec_full: Unable to create channel of type 'SIP' (cause 3 - No route to destination)
Wenn du in diesem Zustand ein "sip show peers" eingibst, wird dir angezeigt werden, dass dein Gerät an der 2000 nicht erreichbar ist. Dein Sip-Gerät an der 2000 antwortet nicht auf die Anforderung deines Asterisk.

Such mal in der Anleitung von deinem Grandstream wie du die Zeit bis zur nächsten Registrierung verkürzen kannst.
 

Chimbo2004

Mitglied
Mitglied seit
24 Jan 2005
Beiträge
344
Punkte für Reaktionen
0
Punkte
16
Wenn ich aber im Status des BT-200 nachschaue,dann sehe ich,das das Telefon
auch waehrend des Anruf-Fehlers registriert ist.Rausrufen geht ja nach wie vor.
Ich habe jetzt die Register Expiration auf 1000 min gesetzt,eingestellt waren 60 min.
Ein weiterer Fehler der auch gelegentlich auftritt:
Obwohl ich feste IP vergeben habe,kommt es mindestens 1 x taeglich vor, das das Telefon
keine IP hat,also unregistriert ist,dann hilft meistens ein Neustart des ADSL-Routers.
Das kann aber auch nicht normal sein ?
 
Zuletzt bearbeitet:

kombjuder

IPPF-Promi
Mitglied seit
2 Nov 2004
Beiträge
3,086
Punkte für Reaktionen
0
Punkte
0
Ich habe jetzt die Register Expiration auf 1000 min gesetzt,eingestellt waren 60 min.

Nicht hochsetzen, sondern runtersetzen! Also nicht 1000 sondern 10 oder 5.

Dein Grandstream merkt nur bei einem Register oder ausgehendem Anrufversuch, dass es die Verbindung zum Server verloren hat.
 

Chimbo2004

Mitglied
Mitglied seit
24 Jan 2005
Beiträge
344
Punkte für Reaktionen
0
Punkte
16
Auf 5 runtergesetzt und es tut sich gar nichts mehr,das Telefon verbindet sich dann nicht mehr.
Dann wieder auf 1000 min hochgesetzt,Loesung des Problems nach wie vor durch ADSL-Router
neustart.
 

kritter

Neuer User
Mitglied seit
20 Dez 2008
Beiträge
62
Punkte für Reaktionen
0
Punkte
0
Auf 5 runtergesetzt und es tut sich gar nichts mehr,das Telefon verbindet sich dann nicht mehr.
Dann wieder auf 1000 min hochgesetzt,Loesung des Problems nach wie vor durch ADSL-Router
neustart.
Du musst auch überlegen, ob Du hier wirklich von Minuten oder Sekunden redest...! :) Normal sind Registrierungen zwischen 600 und 7200 Sekunden, für kritische Testzwecke nimmt man sie auch mal auf 60 oder 120 Sekunden runter, wie der Vorredner ja schon anmerkte. So prinzipiell.


Aber noch ne ganz andere Idee: Erklär mal Deinen Router, also welches Modell und so.
Wir hatten gestern auch wieder <irony mode="on"> seeeeehr viel Spaß <irony mode="off"> mit einem Snom hinter einem Speedport-Router, der nach anfänglicher Funktion irgendwann im laufe des Tages meinte, jegliches SIP oder RTP als "UDP Flood" einstufen und blocken zu müssen...

Lag also bei uns eindeutig(!) am Router...

Telefon sendete auch ständig Registrierungen, aber der Server (externer Provider) meinte, er habe vom Telefon seit vielen Stunden nix gehört. Sei schlicht unerreichbar...
 
Zuletzt bearbeitet:

Chimbo2004

Mitglied
Mitglied seit
24 Jan 2005
Beiträge
344
Punkte für Reaktionen
0
Punkte
16
Die Zeitangabe im Grandstream ist in minuten Register Expiration: (in minutes. default 1 hour, max 45 days)

Ich habe 1000 min angegeben,wenn ich 5 oder weniger angebe,verbindet sich das Teil
gar nicht erst.

Zu meinem Modem:Es handelt sich einen ADSL-Router Modell DSL-524B
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,769
Beiträge
2,038,213
Mitglieder
352,702
Neuestes Mitglied
Mieze09