.titleBar { margin-bottom: 5px!important; }

klackern bei isdn verbindungen

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von carlofbf, 23 Sep. 2006.

  1. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    hallo, ich habe bei gesprächen über isdn immer alle sekunde so ein "klack"...
    das ganze gespräch klackerts also.
    hat jemand mal ein ähnliches problem gehabt?
    könnte das theoretisch am kabel liegen?
     
  2. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Könnten Synchronisationsprobleme sein.
     
  3. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    okay wo würdest du ansetzen?
    synced der ntba häufiger oder nur einmal beim reinstecken der stromzufuhr?
     
  4. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Erstmal würde ich mir den Systemaufbau ansehen, um festzustellen, wo es Probleme geben könnte. Der NTBA hat damit vermutlich weniger zu tun.
     
  5. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    kannst du bitte einwenig ins detail gehen? es hat aufjedenfall schonmal 100% funktioniert...hab aber eigentlich nichts verändert. hab nur mal versucht das gespräch mitzuscheniden ...danach kam auch das klackern. zurzeit tritt es jedoch bei jedem gespräch auf (eigehend sowei ausgehend)
    gruß
     
  6. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du meinst, wild herumraten was an deiner Konfiguration falsch sein könnte? Nein.
     
  7. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    vl hilft das:
    wobei ich da irgendwie keinen fehler finden kann...es hat ja mal funktioniert :(
    zapata.conf

    Code:
    ; Zapata telephony interface
    ;
    ; Configuration file
    
    [trunkgroups]
    
    [channels]
    
    language=de
    
    nationalprefix = 0
    internationalprefix = 00
    usecallerid=yes
    usecallingpres=yes
    switchtype=euroisdn
    echocancel=yes
    echocancelwhenbridged=yes
    echotraining=100
    
    callwaiting=yes
    callwaitingcallerid=yes
    adsi=yes
    
    faxdetect=both
    ;faxdetect=incoming
    ;faxdetect=outgoing
    ;faxdetect=no
    
    ;jitterbuffers=0
    immediate=no
    overlapdial=yes
    
    
    ; TE Modus (Amt)
    signalling=bri_cpe_ptmp
    pridialplan = unknown
    prilocaldialplan = national
    group=2
    context=isdn
    channel => 1-2
    
    meine zaptel.conf
    Code:
      GNU nano 1.3.8                                 Datei: zaptel.conf
    
    #/etc/zaptel.conf
    loadzone=nl
    defaultzone=nl
    # Hinweis: Zone nl ist mit Zone de identisch
    
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    
    #;span=2,1,3,ccs,ami
    #;bchan=4-5
    #;dchan=6
    
    hab mal das echo canceling ausgemacht...ändert aber nichts
     
  8. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    hat vl noch irgendwer ne idee?
    würd mich echt freuen
     
  9. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Irgendwie hast du immer noch nicht verstanden, daß man dir nur helfen kann wenn du selber mit ein paar Informationen 'rausrückst. Stell dir einfach mal vor, du wüsstest garnichts über dein System und lies dir doch mal deine vorigen postings durch. Die beiden Konfigurationsdateien sind ja schon ein Anfang, aber ohne ein bischen Hintergrund zur Asterisk-Version, bristuff, Patches, wieviele ISDN-Karten, usw kann dir keiner helfen. Und einige Leute ignorieren solch informationsarmen Fragen einfach.

    Ich verweise auch gerne auf Wie man Fragen richtig stellt, die Informationen, die bei einem (fast) beliebigen anderen Problemthema geben dir vielleicht ja auch einen Hinweis, welche Informationen wir brauchen um überhaupt die Chance zu haben, dir zu helfen.
     
  10. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    #10 carlofbf, 13 Okt. 2006
    Zuletzt bearbeitet: 13 Okt. 2006
    SUSE10.0 - Asterisk 1.2.9.1-BRIstuffed-0.3.0-PRE-1r - eine hfc karte (cologne chip)...(florz patch ...weil ich sonst immer diese fehlermeldung hatte) an nomalem netzwerkkabel am ntba - 2000mhz 512mbram - ca. 10 sip teilnehmer...
    ztcfg -v

    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    3 channels configured.
    sonst fällt mir nichts mehr ein
    gruß carlo
    ps: ein debug bei anruf:

    Code:
    1 < Protocol Discriminator: Q.931 (8)  len=37
    1 < Call Ref: len= 1 (reference 1/0x1) (Originator)
    1 < Message type: SETUP (5)
    1 < [1 a11 ]
    1 < Sending Complete (len= 1)
    1 < [1 041  031  801  901  a31 ]
    1 < Bearer Capability (len= 5) [ Ext: 1  Q.931 Std: 0  Info transfer capability: Speech (0)
    1 <                              Ext: 1  Trans mode/rate: 64kbps, circuit-mode (16)
    1 <                              Ext: 1  User information layer 1: A-Law (35)
    1 < [1 181  011  891 ]
    1 < Channel ID (len= 3) [ Ext: 1  IntID: Implicit, Other Spare: 0, Exclusive Dchan: 0
    1 <                        ChanSel: B1 channel
    1                          ]
    1 < [1 6c1  0c1  211  831  311  371  331  341  311  341  361  321  361  331 ]
    1 < Calling Number (len=14) [ Ext: 0  TON: National Number (2)  NPI: ISDN/Telephony Numbering Plan (E.164/E.163) (1)
    1 <                           Presentation: Presentation allowed of network provided number (3) '173******' ]
    1 < [1 701  081  c11  341  301  311  341  361  311  361 ]
    1 < Called Number (len=10) [ Ext: 1  TON: Subscriber Number (4)  NPI: ISDN/Telephony Numbering Plan (E.164/E.163) (1) '4014616' ]
    1 -- Making new call for cr 1
    1 -- Processing Q.931 Call Setup
    1 -- Processing IE 161 (cs0, Sending Complete)
    1 -- Processing IE 4 (cs0, Bearer Capability)
    1 -- Processing IE 24 (cs0, Channel Identification)
    1 -- Processing IE 108 (cs0, Calling Party Number)
    1 -- Processing IE 112 (cs0, Called Party Number)
    1 > Protocol Discriminator: Q.931 (8)  len=7
    1 > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    1 > Message type: CALL PROCEEDING (2)
    1 > [1 181  011  891 ]
    1 > Channel ID (len= 3) [ Ext: 1  IntID: Implicit, Other Spare: 0, Exclusive Dchan: 0
    1 >                        ChanSel: B1 channel
    1                          ]
    1 > Protocol Discriminator: Q.931 (8)  len=4
    1 > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    1 > Message type: ALERTING (1)
    1 > Protocol Discriminator: Q.931 (8)  len=11
    1 > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    1 > Message type: CONNECT (7)
    1 > [1 181  011  891 ]
    1 > Channel ID (len= 3) [ Ext: 1  IntID: Implicit, Other Spare: 0, Exclusive Dchan: 0
    1 >                        ChanSel: B1 channel
    1                          ]
    1 > [1 1e1  021  811  821 ]
    1 > Progress Indicator (len= 4) [ Ext: 1  Coding: CCITT (ITU) standard (0) 0: 0   Location: Private network serving the local user (1)
    1 >                               Ext: 1  Progress Description: Called equipment is non-ISDN. (2) ]
    1 < Protocol Discriminator: Q.931 (8)  len=4
    1 < Call Ref: len= 1 (reference 1/0x1) (Originator)
    1 < Message type: CONNECT ACKNOWLEDGE (15)
    1 NEW_HANGUP DEBUG: Calling q931_hangup, ourstate Active, peerstate Active
    1 > Protocol Discriminator: Q.931 (8)  len=8
    1 > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    1 > Message type: DISCONNECT (69)
    1 > [1 081  021  811  901 ]
    1 > Cause (len= 4) [ Ext: 1  Coding: CCITT (ITU) standard (0) 0: 0   Location: Private network serving the local user (1)
    1 >                  Ext: 1  Cause: Unknown (16), class = Normal Event (1) ]
    1 < Protocol Discriminator: Q.931 (8)  len=4
    1 < Call Ref: len= 1 (reference 1/0x1) (Originator)
    1 < Message type: RELEASE (77)
    1 NEW_HANGUP DEBUG: Calling q931_hangup, ourstate Null, peerstate Release Request
    1 > Protocol Discriminator: Q.931 (8)  len=8
    1 > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    1 > Message type: RELEASE COMPLETE (90)
    1 > [1 081  021  801  901 ]
    1 > Cause (len= 4) [ Ext: 1  Coding: CCITT (ITU) standard (0) 0: 0   Location: User (0)
    1 >                  Ext: 1  Cause: Unknown (16), class = Normal Event (1) ]
    1 NEW_HANGUP DEBUG: Calling q931_hangup, ourstate Null, peerstate Null
    1 NEW_HANGUP DEBUG: Destroying the call, ourstate Null, peerstate Null
    server*CLI>
    
    
     
  11. carlofbf

    carlofbf Mitglied

    Registriert seit:
    28 Dez. 2005
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Aachen
    habe grade asterisk neuaufgesetzt....komischerweise funktioniert jetzt wieder alles.
    wundert mich trotzdem, worans nun letztendlich gelegen hat.
    gruß carlo