.titleBar { margin-bottom: 5px!important; }

Komisches Verhalten mit DISA und TELNET WILLI Anlage

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von jlassen, 12 Nov. 2004.

  1. jlassen

    jlassen Neuer User

    Registriert seit:
    12 Nov. 2004
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo !

    Ich habe ein komisches Verhalten im zusammenhang mit DISA.
    Kurz zu meinem Aufbau.

    Linuxrechner mit Asterisk 1.0 sowie FritzPCI.
    Telefonanlage Willi von TELNET (Telebau) mit internem S0-Bus.
    Der Interne S0 ist an die ISDN - Karte im Linuxrechner angeschlossen.
    So weit so gut.

    Habe es so konfiguriert, das ich die ISDN-Karte von meiner Anlage aus anrufen kann. Bekomme dann auch ein "Freizeichen" von DISA und kann dann locker weiterwählen (Nummern fest im DIALPLAN eingetragen). Funktioniert auch alles wunderbar.
    Jetzt kommt das Aber : Nach einiger Zeit geht es nicht mehr. Ich bekomme zwar immer noch das Freizeichen von DISA, aber es reagiert nicht mehr auf die Zahlen (Tonewahl an der Nebenstelle).
    Und jetzt der Witz : Wenn ich bei der Telefonanlage den Stecker rausziehe und wieder reinpacke, dann geht's wieder für eine bestimmte Zeit.

    Ich zweifle ja sehr, das das an Asterisk liegt, aber vielleicht hat ja jemand eine Idee, warum DISA die Tonwahl nicht mehr erkennt. (Vielleicht, weil die MFW-Töne in ISDN-Signale umgesetzt werden ?)

    Hier der eintrag in der extensions.conf

    exten => 55,1,Wait(1)
    exten => 55,2,DISA,no-password|isdn-to-sip ; alles ISDN geht ueber MSN 55
    exten => 55,3,Hangup


    55 ist die interne MSN der Anlage.
     
  2. chtephan

    chtephan Neuer User

    Registriert seit:
    7 Nov. 2004
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Welchen Channel-Treiber verwendest du?

    Ich habe auch festgestellt, daß die Asterisk-eigene DTMF-Erkennung bei meiner Telefonanlage Müll macht, genau das gleiche Phänomen. Die ersten Ziffern erkennt es und dann irgendwie plötzlich nichts mehr.

    Aber normalerweise reicht es, einfach "nicht ranzugehen" und die Telefonanlage die DTMF-Auswertung machen zu lassen, also kein DISA zu verwenden, sondern den Wählton vom Channel-Treiber erzeugen zu lassen, dann kommt's aber teilweise auf den jeweils verwendeten Channel-Treiber an.