.titleBar { margin-bottom: 5px!important; }

Kompatibilität der DSL Treiber zur Fritz!Box7050

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Bennylein, 16 Jan. 2009.

  1. Bennylein

    Bennylein Neuer User

    Registriert seit:
    23 Dez. 2008
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    einmal ist immer das erste Mal...
    Hallo an all die fleissigen Tüftler.
    Die 7050 ist schon ein wenig betagt und wird leider wohl auch nicht mehr weiter von AVM mit aktuellen Treiber versorgt. So bastelt man halt selber. Hier im Froum stehen ja auch einge Dinge zum Austausch des Treibers beschrieben. Mich würde aber schon interessieren, ob nicht doch die aktuellen Treiber der "neueren" Boxen auch irgendwie zu integrieren wären. Meine "kleine" 7050 bringt am ADSL1 Anschluss von Arcor leider doch recht häufige Resyncs zu stande. Lustigerweise ist so ein gefritzes w501v(juppiee das kann ich schon) da viel stabiler und synct zudem auch deutlich höher. Da ist doch auch vergleichbares Material drinne und die 7050 bietet mehr Funktionalität. Im Skript für die W501v wird da weiter der Telekom Treiber behalten, oder:confused:??. Obwohl auch da 1.35.73.01 steht. Vielleicht kann mir da jemand weiter helfen. Schön wäre natürlich irgendwie Treiber von der 7141 oder 7170 einpflegen zu können. Mir geht es nicht um das eigentliche Basteln, sondern eher um die Kompatibiltät, bevor ich weiter bastel.
     
  2. MaSe87

    MaSe87 Neuer User

    Registriert seit:
    18 Dez. 2007
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Soweit ich das weiß, ist das DSL-Modem bei AVM-Geräten das Problem. Zumindest wurde mir das an andere Stelle und sogar mal vom Telekomsupport (ja es gibt da auch kompetente Menschen) gesagt.

    Kann also durchaus sein, dass die OEM-Geräte an die Telekom da andere Modems drin haben.
     
  3. Bennylein

    Bennylein Neuer User

    Registriert seit:
    23 Dez. 2008
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zurück.
    Ne, ich mein da schon den vergleich mit den Speedports auch mit Innenleben von AVM. Wie geschrieben w501v stand mir zur Verfügung und hab ich "gemoddet". Daher ja auch meine Verwunderung über die Werte. Die "SpeedBox" synct mit schlappen 500-800kb mehr und hat doch nichts anderes als Modem drin?! 5600 oder 6300 down ist ja irgendwie schon ein Wort und dann sogar über Tage stabil. Daher wie auch in anderen Threads schon angesprochen, die Frage nach Kompatibilität. Einen älteren Treiber wie schon beschrieben, war da nicht meine Idee. Eher halt 7141 oder 7170 Treiber.
     
  4. Sirus

    Sirus Neuer User

    Registriert seit:
    15 Dez. 2005
    Beiträge:
    92
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Soweit ich weiß hat MaSe87 recht und ab und zu weichen die OEM geräte im Modem Teil von den von AVM ab.

    die 7050 hatte glaube ich Hadwareseitig nen schlechtes modem.
     
  5. Bennylein

    Bennylein Neuer User

    Registriert seit:
    23 Dez. 2008
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das "Problem" mit dem Modem ist mir auch bekannt. Das ist aber wohl auch nicht die ganze Wahrheit. Wie in
    http://www.ip-phone-forum.de/showthread.php?t=183888
    beschrieben scheint sich ja durchaus ein Treiberwechsel zu lohnen. AVM hat an einer Verbesserung dieser Treiber in der 7050 wohl kein Interesse mehr. Schade nur das in dem o.g. Thema erwähnt wird, dass es eher was für Annex A Nutzer ist. Also wahrscheinlich keine Verbesserung in Deutschland bringt. Ein Austausch der Treiber ist aber schon möglich, auch zu den aktuelleren Produkten. So heißt es mal bei Zeiten zu probieren. Werde mich da dann auch mal dran machen. So denn ein 7050 Besitzer, der dies auch schon probierte, da schon Erfahrung hat, hoffe ich noch auf Meldung. Erfahrung halt mit DSL-Treiber-Austausch der Annex B Version 7050 in Deutschland.
    Grüße
     
  6. leibezem

    leibezem Neuer User

    Registriert seit:
    23 Dez. 2006
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Es funktioniert auch mit den AnnexB Treibern. Ich habe z.B. den AnnexB Treiber aus dem Beta Image 14.04.50-10009 in ein Freetz Image eingebaut. (DSL Version 1.36.02.00). Der Treiber brachte (an meinem AnnexA Anschluss) etwas bessere Sync Werte als der original Treiber aus der 14.04.33. Ich denke aber, das sollte auch mit AnnexB funktionieren. Treiber von anderen Boxen (andere Hardware, kein ubik2) funktionieren aber anscheinend nicht (zumindest habe ich bis jetzt noch keinen zum Laufen gebracht).
     
  7. Bennylein

    Bennylein Neuer User

    Registriert seit:
    23 Dez. 2008
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    so
    denke, ne hoffe ich das auch. Daher wird gebastelt, und die zweite Hoffnung darin ist halt auch die bessere Stabilität, da meine 7050 hier am etwas schwächlichen Anschluss schon ihre Zicken macht. Werde es auch mit dem 1.36.02.00 versuchen. Wegen dem "doofen" Nachtdienst brauch ich aber noch etwas zum basteln.
     
  8. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,919
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hi,

    am einfachsten geht das, wenn du es erstmal direkt in der Box testets, indem du die "neue" Firmware von Hand lädst. Was ich nicht weiß: reicht für die 7050 auch die Folge

    rmmod tiatm
    modprobe tiatm firmware_load_file=/var/tmp/<neue_Firmware>.bin annex=[A|B]

    oder muss man da wegen ubik2 noch mehr Dinge "entladen" und dann wieder neu laden? Was sagt denn ein "lsmod" auf der Box dazu?


    Jörg
     
  9. leibezem

    leibezem Neuer User

    Registriert seit:
    23 Dez. 2006
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Code:
    # DSL Treiber und abhängige Module entladen
    rmmod isdn_fbox_fon2
    rmmod ubik2 -> falls dieser Aufruf fehlschlägt prüfe mit ps, ob ein cat auf /dev/debug läuft, und beende den vorher.
    rmmod tiatm
    
    # neue  DSL Firmware laden
    modprobe tiatm firmware_load_file=[neue DSL Treiber Datei] annex=[A|B]
    modprobe ubik2 takeover_printk=1
    /bin/ubik2_boot -d -r -0 /lib/modules/ubik/boot-ubik2-sport.lod -3 /lib/modules/ubik/ubik2-firmware.lod
    
    Wenn alles ohne fehler durchläuft, sollte der Treiber auf der 7050 funktionieren.
     
  10. engel-love

    engel-love Neuer User

    Registriert seit:
    25 Okt. 2005
    Beiträge:
    98
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    anfrage

    kann mir erklären ob dieses austauschen auch für eine fritzbox 7150 und die treiber von der beta auch gehen