[Gelöst] korrektes Format in der Anrufliste (mobil)

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
Liebes Forum,

ich habe an meinem Asterisk mein Handy als Client angemeldet.
Keine APP, sondern den nativen VoIP Clienten im Phone (xiaomi).
Alle Anrufe in/out funktionieren fehlerfrei.
Es gibt allerdings einen 'Schönheitsfehler'.
Alle Anrufe stehen in der Anrufliste im Format [email protected]
Es wird mir richtigerweise die Registrar/Domain des SIP-Anbieters angezeigt.
Ich hätte aber gern folgendes mit dem Asterisk konfiguriert:
aus 0401123344 wird +49 und alles ab dem @ wird abgeschnitten.
Am Ende hätte ich gern +49401123344, so das ich aus der Anrufliste heraus direkt zurück rufen kann.

Bis jetzt habe ich allerdings nur Lösungen gefunden welche eine bestimmte Stellenanzahl vor dem @ abschneiden.
Konkret: wie kann ich für den SIP Clienten (xiaomi) im Asterisk bei Anruf ankommend den Registrar/Domain entfernen?

Besten Dank.
Henry
 
Zuletzt bearbeitet:

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
Mmh, ist meine Frage so ungewöhlich? Vielleicht könntet ihr mir bitte ein paar Stichwörter nennen mit der ich die Suchfunktion weiter füttern könnte.
Besten Dank.
Henry
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,608
Punkte für Reaktionen
149
Punkte
63
Geht schon ganz banal los: Welche Anrufliste? Du möchtest bei eingehenden Anrufen den "Display Name" auf +49 Rufnummer setzen, damit in der Anrufliste Deines des nativen VoIP/SIP-Client in Deinem Android-Telefon auch nur das steht, also nicht die ganze SIP-URI. Richtig?
 

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
Hi sonyKatze,

ja, ich meine die Anrufliste im Handy. Richtig, ich möchte den 'Display Name' auf +49 40 123456 setzen. Ohne xxx@ipaddress. In der Anrufliste wird ja richtigerweise der verpasste Anruf mit [email protected] angezeigt, nur kann ich dieses Format so nicht einfach zurück rufen. Da das xiaomi direkt am Asterisk registriert ist dachte ich mir es gäbe für mein Problem eine 'einfache' Lösung.

Besten Dank und Beste Grüße
Henry
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,608
Punkte für Reaktionen
149
Punkte
63
Da geht es banal weiter: Wie willst Du zurückrufen, über Mobilfunk oder auch über den nativen SIP-Client? Letzteres müsste gehen. Ansonsten ist irgendwas an der Asterisk-Konfiguration krumm.
 

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
Hi sonyKatze,
ja, ich möchte gern mit dem nativen SIP-Client zurück rufen.
Letzteres müsste gehen. Ansonsten ist irgendwas an der Asterisk-Konfiguration krumm.
Und da genau habe ich das Problem. Der Rückruf auf [email protected] funktioniert leider nicht.

Der Asterisk (13.14.1) läuft auf einem Raspberry hinter einer Fritzbox.
Keine statische IP, dyndns.
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,608
Punkte für Reaktionen
149
Punkte
63
  1. Welche Server-Adresse steht in den Einstellungen Deines Android Telefon, jene IP oder Deine DynamicDNS?
  2. Wenn Du nicht chan_pjsip sondern chan_sip nutzt, hast Du in der Datei sip.conf in der Section [general] pedantic=no stehen?
 

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
1. die dyndns adresse des asterisk
2. in meiner sip.conf steht pedantic=yes. Und ja, ich nutze chan_sip
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
12,653
Punkte für Reaktionen
349
Punkte
83
Moinsen


Naja, dann kommts drauf an wie Asterisk das INVITE aufbaut und ob es Sinn macht zusätzliche Header mitzuliefern.
Dabei kommts auch darauf an wie der native SIP Klient gewillt ist was anzuzeigen/präferieren.
Mit Asterisk haste da auch Alles was du brauchst um damit rumzuexperimentieren.

Hier mal ein INVITE von Asterisk zu einem FRITZ!Box VoIP Benutzer/Nummer...
Rich (BBCode):
INVITE sip:[email protected];uniq=<hash> 2.0
Via: SIP/2.0/UDP 192.168.188.9:5060;branch=<hash>
From: "EIERKOPF" <sip:[email protected]>;tag=<hash>
To: <sip:[email protected];uniq=<hash>>
Call-ID: [email protected]:5060
CSeq: 102 INVITE
Contact: <sip:[email protected]:5060>
Max-Forwards: 70
User-Agent: PiBX
Date: Thu, 20 Aug 2020 10:55:13 GMT
Supported: replaces
Supported: timer
P-Asserted-Identity: "EIERKOPF" <sip:[email protected]>
( P-Asserted-Identity: wird in der sip.conf über rpid* aktiviert und kann mittels CALLERID() im Wahlplan geändert werden )
Die FRITZ!Box beachtet beispielsweise P-Asserted-Identity: bevorzugt, besonders wenn der noch nicht in irgendeinen Telefonbuch steht.
...für einen Rückruf würde aber immer der Nummernteil hinter sip: bis zum @ genommen.

*
Code:
trustrpid=yes            ; If Remote-Party-ID should be trusted
;sendrpid = yes        ; If Remote-Party-ID should be sent (defaults to no)
;sendrpid = rpid       ; Use the "Remote-Party-ID" header
                                ; to send the identity of the remote party
                                ; This is identical to sendrpid=yes
sendrpid=pai           ; Use the "P-Asserted-Identity" header
                                ; to send the identity of the remote party
rpid_update=yes     ; In certain cases, the only method by which a connected line
                                ; change may be immediately transmitted is with a SIP UPDATE request.
                                ; If communicating with another Asterisk server, and you wish to be able
                                ; transmit such UPDATE messages to it, then you must enable this option.
 
Zuletzt bearbeitet:

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
'n Abend,

erst einmal Danke Euch beiden für die Tipps und Anregungen zu meinem Problem.
Gern teste ich morgen ein paar Dinge zum Thema rpid und pai mal aus.

Für heute vorerst 'Gute Nacht'.
 

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
Hi,

neue Erkenntnisse: nachdem ich Eure Ratschläge umgestzt hatte, habe ich mal einige Anrufe auf CLI angeschaut.
Der Asterisk mach alles richtig, aber der SIP-Client am xiaomi setzt die @ip_vom_asterisk zu!
Sobald der Anruf auf dem SIP Account des xiaomi reinkommt wird die Nummer mit @ip_vom_asterisk ergänzt.
Wieder was gelernt. Da der native SIP Client im xiaomi sehr rudimentär in seinen Einstellungen ist, sehe ich weiter keine Möglichkeit der Abhilfe.
Nochmals besten Dank an Euch für die wertvollen Tipps.

Beste Grüße
Henry
P.S. hätte der SIP-Client des xioami die Möglichkeit eines Stun-Servers, dann würde ich das xiaomi an der Fritte anmelden und wäre aller Sorgen ledich.
Geht aber leider nicht.
 

=Henry=

Mitglied
Mitglied seit
4 Sep 2006
Beiträge
340
Punkte für Reaktionen
0
Punkte
16
gute Nachrichten: es funktioniert!
Ich hatte ja anfangs alle Eure Tipps leider erfolglos umgesetzt.
Dann bin ich nochmals alle Einstellungen am xiaomi SIP-Konto durch gegangen.
Und siehe da: es hatte unter optionale Einstellungen den ausgehenden Proxy vergessen.:(
Also wieder eingetragen & reboot. Seitdem kann ich auch das Format [email protected] aus der Anrufliste fehlerfrei zurückrufen.
Die Änderungen in der sip.conf (pedantic/fromdomain) und extensions.conf (PAI) habe ich fest übernommen.
Danke schön für Eure Unterstützung!

Beste Grüße
Henry