l2 geht nicht UP

onkel_fritz

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
110
Punkte für Reaktionen
0
Punkte
0
hi

ich habe misdn mittels install-asterisk.tar.gz installiert

ich will einen internen S0 bus erzeugen, sprich ich habe
nt-pmp parametriert; an der hfc-2bd0 karte habe ich ein
ausgekreuztes kabel und einen richtig terminierten s0 bus
mit 2 isdn-telefonen;

ein paar auszüge aus den config-files:

# /etc/misdn-init
card=1,hfcpci
nt_ptmp=1
poll=128
#pcm=1,1
dsp_options=0
dtmftreshold=100
debug=1
# /etc/asterisk/misdn.conf
misdn_init=/etc/misdn-init.conf
debug=2
ntdebugflags=56
ntdebugfile=/var/log/asterisk/misdn-nt.log
<rest ist default>
[intern]
ports=1
context=demo

# misdn-init start
-----------------------------------------
Loading module(s) for your misdn-cards:
-----------------------------------------
/sbin/modprobe --ignore-install hfcpci protocol=0x12 layermask=0x3
modprobe mISDN_dsp debug=0x0 options=0 poll=128 dtmftreshold=100

asterisk startet dann auch ohne fehler

CLI> misdn show channels
Chan List: (nil)
CLI> misdn show config
Misdn General-Config:
-> Version: chan_misdn-0.3.1-rc23
-> misdn_init: /etc/misdn-init.conf -> debug: 2
-> tracefile: /var/log/asterisk/misdn.log -> bridging: no
-> stop_tone_after_first_digit: yes -> append_digits2exten: yes
-> dynamic_crypt: no -> crypt_prefix: **
-> crypt_keys: test,muh -> ntdebugflags: 56
-> ntdebugfile: /var/log/asterisk/misdn-nt.log

[PORT 1]
-> name: intern -> allowed_bearers: all
-> far_alerting: no -> rxgain: 0
-> txgain: 0 -> te_choose_channel: no
-> pmp_l1_check: yes -> block_on_alarm: yes
-> hdlc: no -> context: demo
-> language: en -> musicclass: default
-> callerid: -> method: standard
-> dialplan: 0 -> localdialplan: 0
-> cpndialplan: 0 -> nationalprefix: 0
-> internationalprefix: 00 -> presentation: -1
-> screen: -1 -> always_immediate: no
-> nodialtone: no -> immediate: no
-> senddtmf: yes -> hold_allowed: no
-> early_bconnect: yes -> incoming_early_audio: no
-> echocancel: 0 -> echocancelwhenbridged: no
-> need_more_infos: no -> jitterbuffer: 4000
-> jitterbuffer_upper_threshold: 0 -> callgroup:
-> pickupgroup: -> msns: none
-> ptp: no
CLI> misdn show port 1
BEGIN STACK_LIST:
* Port 1 Type NT Prot. PMP L2Link DOWN L1Link:UP Blocked:0 Debug:2

am telefon kommt nur "störung" wenn man abhebt :-(

/var/log/asterisk# cat misdn-nt.log
Sun Sep 17 00:14:25 2006: P(01): L(0x20):msg_mux: msg len(16)
Sun Sep 17 00:14:25 2006: P(01): L(0x20):msg_mux: adr(42000100) pr(10082) di(0) len(0)
Sun Sep 17 00:14:25 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Sun Sep 17 00:14:25 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Sun Sep 17 00:14:25 2006: P(01): L(0x20):msg_mux: msg len(16)
Sun Sep 17 00:14:25 2006: P(01): L(0x20):msg_mux: adr(42000100) pr(10182) di(0) len(0)
Sun Sep 17 00:14:26 2006: P(-1): L(0x20):tei0 State ST_TEI_REMOVE Event EV_T201
Sun Sep 17 00:14:26 2006: P(-1): L(0x20):tei0 remove req(2) tei 0
Sun Sep 17 00:14:26 2006: P(01): L(0x20):tei_l2: prim(121280)
Sun Sep 17 00:14:26 2006: P(-1): L(0x20):tei0 ChangeState ST_TEI_NOP

also was könnte ich noch probieren??
mfg
 

crich

Mitglied
Mitglied seit
1 Sep 2005
Beiträge
529
Punkte für Reaktionen
0
Punkte
0
Sieht eigentlich alles ganz vernünftig aus. Vielleicht ist das kabel aber nicht korrekt gekreuzt:

3->4
4->3
5->6
6->5

muss es sein
 

onkel_fritz

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
110
Punkte für Reaktionen
0
Punkte
0
crich schrieb:
Sieht eigentlich alles ganz vernünftig aus. Vielleicht ist das kabel aber nicht korrekt gekreuzt:

3->4
4->3
5->6
6->5

muss es sein
jep die belegung ist richtig! hab sie genau so

auf jeden fall habe ich mir heute eine zweite hfc karte eingebaut und auch die normale hisaxmodule weggeschoben (wurden automatisch geladen!)

hab jetzt an einer karte den S0 angeschlossen, an der anderen ist nichts drauf; wenn man umsteckt wandert L1Link wunderbar mit; sprich die karten erkennen dass etwas dransteckt


CLI> misdn show stacks
BEGIN STACK_LIST:
* Port 1 Type NT Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:2
* Port 2 Type NT Prot. PMP L2Link DOWN L1Link:UP Blocked:0 Debug:2


was könnte ich sonst noch versuchen? irgendwelche logfileoptions?

/var/log/asterisk# cat misdn-nt.log
Mon Sep 18 21:27:34 2006: P(01): L(0x20):msg_mux: msg len(16)
Mon Sep 18 21:27:34 2006: P(01): L(0x20):msg_mux: adr(42000100) pr(10082) di(0) len(0)
Mon Sep 18 21:27:34 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:27:34 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:27:36 2006: P(02): L(0x20):msg_mux: msg len(16)
Mon Sep 18 21:27:36 2006: P(02): L(0x20):msg_mux: adr(42000200) pr(10082) di(0) len(0)
Mon Sep 18 21:27:36 2006: P(02): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:27:36 2006: P(02): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:27:36 2006: P(02): L(0x20):msg_mux: msg len(16)
Mon Sep 18 21:27:36 2006: P(02): L(0x20):msg_mux: adr(42000200) pr(10182) di(0) len(0)
Mon Sep 18 21:41:25 2006: P(02): L(0x20):msg_mux: msg len(16)
Mon Sep 18 21:41:25 2006: P(02): L(0x20):msg_mux: adr(42000200) pr(10182) di(0) len(0)
Mon Sep 18 21:41:25 2006: P(01): L(0x20):msg_mux: msg len(16)
Mon Sep 18 21:41:25 2006: P(01): L(0x20):msg_mux: adr(42000100) pr(10082) di(0) len(0)
Mon Sep 18 21:41:25 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:41:25 2006: P(01): L(0x20):L2 State ST_L2_4 Event EV_L1_DEACTIVATE
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 State ST_TEI_REMOVE Event EV_T201
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 remove req(2) tei 0
Mon Sep 18 21:41:26 2006: P(01): L(0x20):tei_l2: prim(121280)
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 ChangeState ST_TEI_NOP
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 State ST_TEI_REMOVE Event EV_T201
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 remove req(2) tei 0
Mon Sep 18 21:41:26 2006: P(02): L(0x20):tei_l2: prim(121280)
Mon Sep 18 21:41:26 2006: P(-1): L(0x20):tei0 ChangeState ST_TEI_NOP
 

onkel_fritz

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
110
Punkte für Reaktionen
0
Punkte
0
onkel_fritz schrieb:
CLI> misdn show stacks
BEGIN STACK_LIST:
* Port 1 Type NT Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:2
* Port 2 Type NT Prot. PMP L2Link DOWN L1Link:UP Blocked:0 Debug:2
habe immer noch keine neuen erkenntnisse :(

was sagt eingentlich L2Link down aus?
nach dem osi-modell sollte es die kommunikation zwischen den geräten am S0
bus als nicht funktionsfähig zeichnen; aber wie erkennt er das?
vorallem was ist wenn man an einem S0 bus hängt, der kein telefon dran hat; ist dann L2 immer down?
 

onkel_fritz

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
110
Punkte für Reaktionen
0
Punkte
0
trara *g*

ja seit gestern gehts bei mir :cool:
was mir aufgefallen ist (noch nicht alle punkte gefunden)

1) das modul "netjetpci" darf ned geladen sein
2) habe alle karten jetzt in einem anderen PC -> vielleicht auch ein grund
3) terminierung sehr unwichtig; hab mal testhalber die widerstände abgeschaltet -> ging immer noch :-o
4) L2Link wird bei mir auch als DOWN angezeigt, wenn ich nicht telefoniere
-> sprich ich habe immer nur auf diese anzeige geachtet und ja garnimmer
am telefon probiert
das war natürlich dann ned recht sinnvoll :mad::mad::mad::mad:
5) dsp_options=0 -> im file steht:
#set this to 2 and you'll have software bridging instead of
# hardware bridging.
gilt das auch wenn man nur eine HFC karte hat? ich denke auch das
hat mal ein NOGO ausgemacht; konnte es aber nachher nicht mehr
reproduzieren :mad:

aber hauptsache es geht :D
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
232,847
Beiträge
2,027,349
Mitglieder
350,937
Neuestes Mitglied
Elperator