.titleBar { margin-bottom: 5px!important; }

Labor-All + push_firmware -> kein Mini

Dieses Thema im Forum "Freetz" wurde erstellt von franzb, 23 Nov. 2008.

  1. franzb

    franzb Neuer User

    Registriert seit:
    13 Sep. 2005
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Mit allen von mir versuchten Labor-All-Firmwares ab 54.04.63 (Fritzbox 7270) inkl. der aktuellen 13014 funktioniert das Fritz! Mini nicht, wenn die Firmware mittels push_firmware geflasht wird. Mit exakt derselben Firmware, über das Fritzbox-Interface upgedatet, meldet sich das Mini einwandfrei an. Habe push_firmware sowohl das gepackte Image als auch das extrahierte kernel.image übergeben, kein Unterschied.

    Hat jemand eine Lösung? Würde gerne auf meiner 16 MB Box wieder eine aktuelle Firmware > 8 MB flashen...

    MfG, Franz
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hm, das klingt ja spannend. Ich wußte gar nicht, dass da was besonderes gemacht wird, wenn übers Webinterface flasht.

    Vielleicht solltest du die /var/install mal nach Kommentaren bezüglich mini durchforsten.

    Bist du dir ganz sicher, dass es daran liegt und nicht vielleicht doch an Freetz Optionen?

    MfG Oliver
     
  3. franzb

    franzb Neuer User

    Registriert seit:
    13 Sep. 2005
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Freetz sollte als unmittelbare Fehlerquelle ausscheiden. Ich habe es auf zwei verschiedenen Fritzboxen verifiziert: ein und dieselbe (Freetz-) Firmware übers Webinterface geflasht erlaubt dem Mini, sich anzumelden, mittels push_firmware bleibt das Mini im Anmeldevorgang hängen.

    Habe auch einen Versuch mit push_FTP (http://ippf.eu/showpost.php?p=1151675&postcount=31) unternommen, gleiches Ergebnis wie mit push_firmware.

    MfG, Franz

    P.S.: mit der Firmware 59.04.59-11779 (Labor-Mini) und dem damals aktuellen Freetz konnte sich das Mini noch anmelden, wenn mit push_firmware geflasht wurde.
     
  4. franzb

    franzb Neuer User

    Registriert seit:
    13 Sep. 2005
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich muss meine Aussage relativieren: das Firmwareupdate übers Webinterface funktioniert nur insofern anders als push_firmware, als plugins.update (inkl. Dateien fürs Mini) bei ersterem automatisch auf dem USB-Stick abgelegt wird.

    Wenn diese Datei händisch dorthin kopiert wird (oder "Add Freetz version to subversion string" beim Firmwarebauen deaktiviert wird, sodass die Box sich die Datei vom AVM-Server holen kann), funktioniert das Mini (und ein paar Dinge mehr wie ntfs oder samba).

    Damit ist dieses Problem gelöst.

    MfG, Franz