.titleBar { margin-bottom: 5px!important; }

langzeitstabilität von misdn

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von onkel_fritz, 9 Dez. 2006.

  1. onkel_fritz

    onkel_fritz Neuer User

    Registriert seit:
    10 Apr. 2006
    Beiträge:
    110
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi

    ich habe heute zum zweiten mal dasselbe problem gehabt; sprich ich gehe von einem echten bug aus;
    was ist passiert.

    ich habe ein setup mit 2*hfc-pci; eine karte in nt, eine im te
    mode; nach ca einem monat betrieb mit ~300 anrufen geht
    das NT-mode port nicht mehr; es ist aber nicht sofort aus sondern läuft so ab:

    1) ein anruf kommt am TE rein und am NT port raus; das telefon (siemens gigaset 3035) läutet; wenn man abhebt,
    ist es aus, das telefon zeigt störung. man kann nicht mehr wegrufen
    2) andere telefone am selben bus funktionieren noch (abheben bringt freizeichen)
    3) macht man einen powerreset bei einem der noch funktionierden telefone zeigen auch die störung an
    4) asterisk kriegt von dem allem nix mit; tut so als wär nix geschehen und kein telefon abheben würde
    misdn show stacks ist auch ok
    5) ein asterisk reload ändert daran nichts
    6) ein misdn-init stop && start + asteriskstart behebt das problem wieder; alles geht danach wieder einwandfrei

    vor einem monat hatte ich das selbe problem, damals war
    aber die TE karte eine fritz; hab das damals sicherheitshalber
    umgebaut -> war aber offensichtlich nicht das problem

    also ich denke das hier ein problem im code sein muss; vorallem finde ich es sonderbar,
    dass die telefone noch weiter funktionieren, bis man sie neustartet;

    was passiert den mit so einem telefon wenn es am bus
    aufgedreht wird? dachte es ist solange passiv bis der erste
    anruf kommt oder man wegzurufen versucht ....

    ich muss noch im logfile nachsehn, wielange die genau zeit
    zwischen den beiden hängern war -> wenn die absolut gleichlang ist
    dann ist es ein problem mit einem überlauf einer variable (meine vermutung..)
     
  2. chrisdog

    chrisdog Neuer User

    Registriert seit:
    18 Mai 2006
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    probier das nächste mal doch in der asterisk cli ein 'misdn restart port X' mit X=dein nt-port.

    sind die anderen telefone denn auch siemens-devices? erfahrungsgemäß reagieren siemens geräte immer anders als andere hersteller
     
  3. onkel_fritz

    onkel_fritz Neuer User

    Registriert seit:
    10 Apr. 2006
    Beiträge:
    110
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    warum sollte das funktionieren, wenn ein restart von asterisk selbst nichts bringt?

    eine fritzbox und eins wo ich gerade den typ nicht kenne