Latest CVS Head + Authentication Changes (Incoming)

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
Wer auf einmal nicht mehr eingehende Anrufe (Incoming Calls) erreichbar ist und eine aktuelle Asterisk CVS Head Version verwendet, der ist wie ich in was reingelaufen....

Änderungen asterisk/channels/chan_sip.c :

revision 1.403
date: 2004/05/28 15:47:57; author: markster; state: Exp; lines: +1 -1
Really don't authenticate if we're not supposed to authenticate (bug #1738)

revision 1.395
date: 2004/05/24 14:44:47; author: markster; state: Exp; lines: +24 -22
Always authenticate when insecure is not "very" even on matching IP

Dies hat für mich bedeutet, dass wenn ich mich auf meiner Sipgate-Nr. vom Festnetz anrufe, ich folgende Fehlermeldung bekomme:

Jun 10 19:43:00 NOTICE[1116941120]: chan_sip.c:6416 handle_request: Failed to authenticate user "<Festnetznummer>" <sip:<Festnetznummer>@217.10.66.11>;tag=as61d9b612

Geklingelt hat mit chan_capi + AVM Karte mein PBX Analog-Telefon NICHT mehr.

Ich musste in sip.conf bei

[sipgate]

folgendes hinzufügen: insecure=very

Jetzt geht's wieder :)
 

wusel

Neuer User
Mitglied seit
9 Jun 2004
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
toll,
habe ich mir nun den stress mit der alten version nun umsonst gemacht ?? na ja au jedenfall läuft jetzt alles wieder. ich werde es mir aber merken wenn ich wieder bastel will :)

mfg wusel
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Das wäre doch ein Eintrag für die FAQ, oder nicht?
Auf jeden Fall. Man sollte auch noch so andere Sachen aufnehmen, also auch nötwendige änderungen im Quelltext, wie z.B. diese:
http://www.ip-phone-forum.de/forum/viewtopic.php?p=8099#8099
Diesbezüglich muß ich mich bei Blackvel für die aktuellen Informationen Bedanken

Das wäre mal sowieso mal ne gute Idee:
Ein Thread, daß beschreibt, wie man Asterisk installiert. Also nur die "Anpassungen", die man am Quelltext vornehmen muß (z.B. beim CAPI-Treiber, chan_capi, oder Asterisk selbst). Für die Standardinstallation gibt es ja schon sowas.
 

obelix

Mitglied
Mitglied seit
6 Apr 2004
Beiträge
345
Punkte für Reaktionen
0
Punkte
0
also ich habe heute eine Version in der Fa. aktiviert und bekomme nun auch den fehler
Jun 15 10:35:06 NOTICE[4101]: chan_sip.c:6351 handle_request: Failed to authenticate user "11" <sip:[email protected]>;tag=as53032a12


[sipgate]
......
insecure=very

ist vorhanden.

die Version vom CVS-HEAD-05/25/04-10:03:38

OBELIX

ps
so altes cvs wieder hochgeladen und compiliert, und sihe da alles geht wieder.
na ja man sollte nicht bastel :-(
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,105
Beiträge
2,030,177
Mitglieder
351,441
Neuestes Mitglied
Airmr