.titleBar { margin-bottom: 5px!important; }

[Problem] lighttpd und php

Dieses Thema im Forum "Freetz" wurde erstellt von franky28, 15 Feb. 2012.

  1. franky28

    franky28 Neuer User

    Registriert seit:
    23 Dez. 2007
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ort:
    Dresden
    Guten Abend,

    ich nutze den Trunk 8640, habe u.a. lighttpd und php mit im image und kann den lighttpd nur ohne php starten.

    Beim Versuch, lightppd UND php zu starten erhalte ich folgendes error.log:

    Code:
    2012-02-15 22:42:40: (log.c.166) server started 
    2012-02-15 22:42:40: (mod_fastcgi.c.1103) the fastcgi-backend /usr/bin/php-cgi failed to start: 
    2012-02-15 22:42:40: (mod_fastcgi.c.1107) child exited with status 2 /usr/bin/php-cgi 
    2012-02-15 22:42:40: (mod_fastcgi.c.1110) If you're trying to run your app as a FastCGI backend, make sure you're using the FastCGI-enabled version.
    If this is PHP on Gentoo, add 'fastcgi' to the USE flags. 
    2012-02-15 22:42:40: (mod_fastcgi.c.1397) [ERROR]: spawning fcgi failed. 
    2012-02-15 22:42:40: (server.c.945) Configuration of plugins failed. Going down. 
    Wie kann ich den gewünschten Parameter "fastcgi" mit übergeben?

    Code:
    root@fritz:/var/mod/root# /usr/bin/php-cgi -m
    
    [PHP Modules]
    cgi-fcgi
    Core
    ctype
    date
    ereg
    exif
    filter
    hash
    mbstring
    pcre
    PDO
    posix
    Reflection
    SPL
    standard
    tokenizer
    
    [Zend Modules]
    
    Fehlt ein Modul für die korrekte Ausführung?

    Gibt es andere Lösungsmöglichkeiten?

    Welche weiteren Informationen sind zur Fehlersuche notwendig?

    Frank
     
  2. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es fehlt nicht ein Modul oder ein Parameter.

    Die Meldung besagt, dass httpd versucht, ein FastCGI Programm zu starten, während das gestartete Programm keine FastCGI Programm ist (oder ein anderweitiges Problem hat).

    Entweder stellst Du also httpd so ein, dass er ein CGI Programm starten will, oder DU stellst ihn so ein, dass er die FastCGI Version von PHP startet.
     
  3. franky28

    franky28 Neuer User

    Registriert seit:
    23 Dez. 2007
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ort:
    Dresden
    #3 franky28, 16 Feb. 2012
    Zuletzt bearbeitet: 16 Feb. 2012
    Hallo Ralf,

    danke für die Info.

    Für mich bleiben damit zwei Fragen:

    1. Handelt es sich bei dem "normal" von Freetz ins Image gebauten PHP nicht um ein FastCGI-Programm? Wo bekomme die FastCGI-Version her und kann ich diese mit im Freetz einbinden?

    ODER

    2. Wie kann ich (über die Oberfläche ?) einen Parameter übergeben, dass lighttpd die CGI-Version (ist das die, die Freetz "normal" mit einbaut) startet?

    Danke


    Nachtrag: Gehe ich recht in der Annahme, dass das PHPModul "cgi-fcgi" beides beinhaltet?
     
  4. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Anscheinend ist in den neueren Versionen von PHP CGI und FastCGI im gleichen Programm enthalten. Ich weiß aber nicht, wie das aufgerufene Programm unterscheidet, was von ihm erwartet wird.

    Ich weiß auch nicht, wie man beim lighttpd einstellt, ob er CGI oder FastCGI verwenden soll.