Loading module app_rxfax.so failed!

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
Hey Folks

Habe spandsp-0.0.2pre25 kompiliert und installiert. Den appsMakefile Patch ausgeführt und Asterisk 1.2.12.1 neu kompiliert. Habe auch die app_rxfax.so und app_txfax.so erhalten und ins Moduleverzeichnis kopiert.

Beim Starten bricht Asterisk mit folgenden Worten ab und macht Feierabend:
Code:
[app_rxfax.so]Sep 19 21:07:43 WARNING[20447]: loader.c:325 __load_resource: /usr/lib/asterisk/modules/app_rxfax.so: undefined symbol: t30_get_far_ident
Sep 19 21:07:43 WARNING[20447]: loader.c:554 load_modules: Loading module app_rxfax.so failed!
Habe auch schon diesen Tread gelesen, hatte aber nichts gebracht: http://www.ip-phone-forum.de/showthread.php?t=102739&highlight=t30_get_far_ident

Hat jemand eine Idee was ich falsch mache?

Danke und Gruss
Düsentrieb
 

soylentgreen

Neuer User
Mitglied seit
20 Sep 2006
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
hallo,

pack mal folgendes in deine modules.conf:

Code:
noload => app_rxfax.so
noload => app_txfax.so
das hindert den * daran, die beiden module zu laden, und er startet dann
wieder sauber.
macht allerdings nur sinn, wenn du die beiden apps nicht brauchts (kein faxemfang und -senden).

das behebt zwar nicht den den fehler, aber die kiste startet wieder.

viele gruesse

sg
 

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
Vielen Dank für den Hinweis. Ich hatte die Module einfach aus dem Verzeichnis gelöscht. Lief danach wieder sauber.

Aber eigentlich wollte ich ja faxen machen ;)
 

soylentgreen

Neuer User
Mitglied seit
20 Sep 2006
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
So kann man es natuerlich auch machen ;)

Ich bin schon auf dem weg, ne Loesung fuer das Urspruengliche Problem zu finden...

sg.
 

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
Musste mich in den letzten Tagen mit meinem Cisco Firmware herumschlagen. Bin nun aber wieder bei dieser Baustelle angelangt.

Schon weiter?

Gruss Düsentrieb
 

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
OK - ist mir nun ein bischen peinlich.

Ist eine ISDN-Karte zwingend notwendig? Hab nämlich keine...
 

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
Wieder ein Samstag am Ar... - es fängt an zu nerven :mad:

Habe nun mal auf einer Suse 10.0 Asterisk und spandsp von Yast installiert und siehe da: der gleiche Fehler.

Ich habe nun wirklich alle Treads über dieses Thema gelesen und mich schlau gemacht. Ich bekomms einfach nicht hin.

Gibt's da draussen jemand der das Teil mit Suse 10.0 am laufen hat? Muss ich noch was dazu installieren?
 

duesentrieb

Neuer User
Mitglied seit
26 Dez 2005
Beiträge
19
Punkte für Reaktionen
0
Punkte
0
Es läuft

Ins apps Verzeichnis wechseln.

Dann app_txfax.c kompilieren, mit folgendem Befehl (Alles auf einer Zeile)

Code:
gcc -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes
-Wmissing-declarations -g3 -Iinclude -I../include -D_REENTRANT
-D_GNU_SOURCE -O6 -march=i686 -DZAPTEL_OPTIMIZATIONS
-fomit-frame-pointer -fPIC -c -o app_txfax.o app_txfax.c
Nun sollte es app_txfax.o geben.
Dann linken:

Code:
gcc -shared -Xlinker -x -o app_txfax.so  app_txfax.o  -lspandsp -ltiff
Nun sollte es app_txfax.so geben.

Dasselbe nun mit app_rxfax.c

Code:
gcc -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes
-Wmissing-declarations -g3 -Iinclude -I../include -D_REENTRANT
-D_GNU_SOURCE -O6 -march=i686 -DZAPTEL_OPTIMIZATIONS
-fomit-frame-pointer -fPIC -c -o app_rxfax.o app_rxfax.c
Code:
gcc -shared -Xlinker -x -o app_rxfax.so  app_rxfax.o  -lspandsp -ltiff
Die beiden app_rxfax.so und app_txfax.so nach /usr/lib/asterisk/modules kopieren und asterisk starten.

Wenn die Fehlermeldung:
Code:
Sep 30 22:57:56 WARNING[24715]: loader.c:325 __load_resource: libspandsp.so.0: cannot open shared object file: No such file or directory
Unable to load module app_txfax.so
erscheint,
Code:
ldconfig -v
ausführen.

Tolles Forum...
 

goodwill2323

Neuer User
Mitglied seit
6 Jun 2007
Beiträge
1
Punkte für Reaktionen
0
Punkte
0
Ich hatte das Problem nun auch und nach langem Rumprobieren festgestellt, daß ich das Patch der Makefile im apps-Verzeichnis manuell eingebaut hatte und dabei aber vergessen hatte, die Zeilen

+app_rxfax.so : app_rxfax.o
+ $(CC) $(SOLINK) -o [email protected] ${CYGSOLINK} $< ${CYGSOLIB} -lspandsp -ltiff
+
+app_txfax.so : app_txfax.o
+ $(CC) $(SOLINK) -o [email protected] ${CYGSOLINK} $< ${CYGSOLIB} -lspandsp -ltiff
+


einzubauen.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,118
Beiträge
2,030,320
Mitglieder
351,465
Neuestes Mitglied
mathador