Lokale Port-freigabe in Router

eldar134

Neuer User
Mitglied seit
22 Feb 2008
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich habe Spiel-Server und HTTP-Server auf meinem PC. Ausserhalb meines Netzes kann man mit Servers die Verbindung (durch ***.dyndns.org) aufbauen und alles funkt. Das Problem ist, dass Lokal nur auf Router(also 192.168.1.1) ge-"forwarded" wird nicht zu PC(wo sich eigentlich Servers befinden), wenn man mit ***.dyndns.org Verbindung aufbauen will. Wenn man zu 127.0.0.1 verbindet - alles funktioniert. Kann jemand mir bitte erklären, warum Router sich so kommisch verhält, und ob dieses Problem behoben werden kann. Ports sind freigegeben.

Danke im Voraus!
 

scolopender

Aktives Mitglied
Mitglied seit
13 Mai 2008
Beiträge
2,296
Punkte für Reaktionen
0
Punkte
36
eldar134 schrieb:
Kann jemand mir bitte erklären, warum Router sich so kommisch verhält...
Zugriffe aus dem LAN auf die eigene WAN-IP-Adresse (indirekt über den DynDNS-Namen oder direkt über die IP-Nummer) funktionieren nur dann richtig, wenn der Router NAT Loopback beherrscht - Dein Router kann oder macht es wohl nicht.

eldar134 schrieb:
... und ob dieses Problem behoben werden kann.
Das hängt vom Router bzw. dessen Firmware ab.

G., -#####o:
 

chked

IPPF-Promi
Mitglied seit
20 Nov 2006
Beiträge
4,252
Punkte für Reaktionen
14
Punkte
38
Wo ist das Problem? Du erreichst den Server halt über zwei verschiedene Adressen. Alternativ kannst du die ***.dyndns.org-Adresse auch in die Windows-Hosts-Datei eintragen (C:\WINDOWS\SYSTEM32\DRIVERS\ETC\HOSTS)