lua version -> 5.3.x

albundy118

Neuer User
Mitglied seit
23 Aug 2011
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Hallo,
für haproxy gibt es support für lua scripte, nur leider wird lua version 5.3. benötigt.
Aktuell wird noch 5.1.5 benutzt und ich weiß leider nicht ob es unhängigkeiten zu dieser Version in Freetz gibt oder ob ein upgrade 5.3. eventuell ohne große Problem machbar wäre?
Ich habe selber noch nicht viel mit Lua gearbeitet.

Danke und beste Grüße
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
13,353
Punkte für Reaktionen
457
Punkte
83
Moinsen


Die meisten "Engines" die ich kenne, auch eine FRITZ!Box, setzen auf die stabile Lua 5.1 Version.
Die Unterschiede zu 5.3.5 sind eher marginal.
...und 5.4 macht mir persönlich noch keinen Spaß, da in einer Linuxsitzung ( lua -i ) alles neu eingetippt werden muss, was schonmal eingegeben wurde.
Also keine Commandhistory mit Cursortaste nach oben, oder das Editieren (Cursortasten) des aktuell eingegebenen Kommandos geht damit nicht.
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via