.titleBar { margin-bottom: 5px!important; }

make: *** [firmware] Error 2

Dieses Thema im Forum "Freetz" wurde erstellt von Seppl82, 22 Dez. 2006.

  1. Seppl82

    Seppl82 Neuer User

    Registriert seit:
    14 Okt. 2006
    Beiträge:
    23
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    hab ein Problem beim build vom Binary...
    Hab die: 7170.
    Hab den: ds-0.2.9
    Hab das: SuSE Linux 10.1

    any ideas????

    DANKESCHÖN!!!

    frsc@brainfuck:~/downloads/ds-0.2.9> make
    STEP 1: UNPACK
    unpacking firmware image
    splitting kernel image
    unpacking filesystem image
    create_inode: could not create character device build/original/filesystem/dev/Piglet, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/acxHwDrv, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/avm_event, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/avm_power, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/capi20, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/console, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/debug, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsld, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsld_traffic, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsld_user, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsldptrace0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsldptrace1, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsldptrace2, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsldptrace3, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kdsldptrace4, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/kmem, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/led, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mem, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd1, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd10, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd2, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd3, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd4, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd5, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd6, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd7, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd8, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/mtd9, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock0, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock1, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock10, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock2, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock3, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock4, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock5, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock6, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock7, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock8, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/mtdblock9, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/new_led, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/null, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ptmx, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/1, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/2, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/3, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/4, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/5, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/6, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/pts/7, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/random, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda1, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda10, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda11, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda12, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda13, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda14, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda15, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda2, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda3, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda4, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda5, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda6, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda7, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda8, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sda9, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb1, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb10, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb11, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb12, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb13, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb14, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb15, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb2, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb3, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb4, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb5, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb6, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb7, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb8, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdb9, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc1, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc10, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc11, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc12, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc13, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc14, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc15, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc2, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc3, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc4, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc5, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc6, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc7, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc8, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdc9, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd1, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd10, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd11, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd12, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd13, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd14, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd15, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd2, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd3, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd4, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd5, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd6, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd7, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd8, because you're not superuser!
    create_inode: could not create block device build/original/filesystem/dev/sdd9, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/tffs, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/tiatm, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/tty, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/tty0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ttyS0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ttyp0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ttyp1, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ttyp2, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/ubik_debug, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/urandom, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/usblp0, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/userman, because you're not superuser!
    create_inode: could not create character device build/original/filesystem/dev/watchdog, because you're not superuser!
    unpacking var.tar
    done.

    STEP 2: MODIFY
    applying patches
    make: *** [firmware] Error 2
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    1. Toller Thread Name
    2. Du hast vergessen die Firmware-Version reinzuschreiben (29.04.29?)
    => Dann geht es für dich hier weiter...

    MfG Oliver ;-)
     
  3. Seppl82

    Seppl82 Neuer User

    Registriert seit:
    14 Okt. 2006
    Beiträge:
    23
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, firmware Version = 29.04.29.
    Bin gerade am compilieren.
    Bis jetzt läuft alles sehr gut.

    DANKESCHÖN
     
  4. mrprinco

    mrprinco Neuer User

    Registriert seit:
    3 Apr. 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ...und bei einer 7050??

    Servus! Ich bekomme genau denselben Fehler. Allerdings habe ich keine 7170, sondern eine 7050 (1und1). Ich versuche das ganze unter Gentoo mit der ds-0.2.9. Ein "make precompiled" bringt keine Lösung. Ach ja, ich habe in den Optionen angegeben, dass das Skript das Image fritz.box_fon_wlan_7050.14.04.31.image von AVM ziehen soll (was er auch macht).
    Woran kann das liegen?
     
  5. kriegaex

    kriegaex Aktives Mitglied

    Registriert seit:
    7 Nov. 2006
    Beiträge:
    2,927
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Projektmanagement-Coach (Certified Scrum Professio
    Ort:
    Großraum Nürnberg
    Du verwendest schon den ds-0.2.9_26, aktuell in Version 14.1, Patch 2 und nicht den Original-Mod von Danisahne für Kernel 2.4? Deine Firmware-Version hat Kernel 2.6, also brauchst Du auch einen passenden Mod, den Du im Thread ds-0.2.9_26-14 findest.