.titleBar { margin-bottom: 5px!important; }

MGCP Gateway ohne SRST

Dieses Thema im Forum "Cisco" wurde erstellt von olliman, 7 Feb. 2007.

  1. olliman

    olliman Neuer User

    Registriert seit:
    4 Jan. 2007
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Leute,

    ich hab ein großes Problem! Ich würde gern mittels CallManager 5.0(4) ein MGCP Gateway einbinden (Router 2851) das einen ISDN Anschluss hat. Sprich ich will mit den Telefonen vom CallManager über das Gateway ins PSTN telefonieren können.
    Jetzt weiß ich weder ob die Konfiguration beim Router noch beim CallManager stimmt.
    wenn ich show ccm-manager mache sagt er mir, dass ich mitn CallManager registriert bin --> sie finden sich wenigstens schon mal. Ich hab sämtliche Online Dokus von Cisco durchgelesen, da steht nicht mehr drinnen, als ich gemacht habe. :( *verzweifelt sei*

    Jetzt kanns sein, dass ich was falsch habe bei den Dial-Peers oder das Route Pattern vom CallManager falsch ist 0.! sollte zum BRI 0/0/1 des Cisco Router 2851 routen.

    PS: es läuft sicherheitshalber noch ein CallManager Express drauf (in einem anderen VLAN) und sollte das ganze nicht stören.

    IOS = 12.4(11)T

    Hier meine Config:
    Building configuration...

    Current configuration : 7806 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname CISCO_2851
    !
    boot-start-marker
    boot system flash c2800nm-spservicesk9-mz.124-11.T.bin
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    aaa new-model
    !
    !
    !
    !
    aaa session-id common
    !
    network-clock-participate wic 0
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.61.1 192.168.61.10
    ip dhcp excluded-address 192.168.61.245 192.168.61.255
    !
    ip dhcp pool VOIP
    network 192.168.61.0 255.255.255.0
    default-router 192.168.61.2
    option 150 ip 192.168.61.2
    !
    !
    ip tftp source-interface GigabitEthernet0/1
    no ip domain lookup
    ip domain name voip.local
    ip ssh time-out 60
    ip ssh version 2
    ip dhcp-server 192.168.61.2
    multilink bundle-name authenticated
    !
    isdn switch-type basic-net3
    !
    voice-card 0
    no dspfarm
    dsp services dspfarm
    !
    interface Loopback0
    ip address 192.168.11.254 255.255.255.255
    !
    interface GigabitEthernet0/0
    description Management Port
    ip address 10.10.10.1 255.255.255.248
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description Anschluss VOIP
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 61
    ip address 192.168.61.2 255.255.255.0
    !
    interface GigabitEthernet0/1.2
    encapsulation dot1Q 62
    ip address 192.168.62.4 255.255.255.0
    !
    interface BRI0/0/0
    no ip address
    isdn switch-type basic-net3
    isdn overlap-receiving
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn guard-timer 1000
    isdn send-alerting
    isdn sending-complete
    isdn static-tei 0
    !
    interface BRI0/0/1
    no ip address
    isdn switch-type basic-net3
    isdn overlap-receiving
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn guard-timer 1000
    isdn bind-l3 ccm-manager service mgcp
    isdn send-alerting
    isdn sending-complete
    isdn static-tei 0
    !
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip http path flash:
    !
    !
    !
    tftp-server flash:p00307020400.bin
    tftp-server flash:p00307020400.sb2
    tftp-server flash:p00307020400.sbn
    tftp-server flash:p00307020400.loads
    tftp-server flash:germany_SCCP-dictionary.xml
    tftp-server flash:germany_7960-dictionary.xml
    tftp-server flash:germany_7960-kate.xml
    tftp-server flash:germany_7960-font.xml
    tftp-server flash:/de-td-sccp.jar alias German_Germany/td-sccp.jar
    tftp-server flash:/de-mk-sccp.jar alias German_Germany/mk-sccp.jar
    tftp-server flash:/g3-tones.xml alias Germany/g3-tones.xml
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0
    compand-type a-law
    cptone AT
    timeouts call-disconnect 0
    bearer-cap Speech
    !
    voice-port 0/0/1
    compand-type a-law
    cptone AT
    timeouts call-disconnect 0
    bearer-cap Speech
    !
    ccm-manager mgcp
    ccm-manager music-on-hold
    ccm-manager config server 192.168.62.2
    ccm-manager config
    !
    mgcp
    mgcp call-agent 192.168.62.2 2427 service-type mgcp version 0.1

    #ab hier hat er sich das alles selbst eingestellt#
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp rtp unreachable timeout 1000 action notify
    mgcp modem passthrough voip mode nse
    mgcp package-capability rtp-package
    no mgcp package-capability res-package
    mgcp package-capability sst-package
    no mgcp package-capability fxr-package
    mgcp package-capability pre-package
    no mgcp timer receive-rtcp
    mgcp sdp simple
    mgcp rtp payload-type g726r16 static
    #-------------bis hier------------------------

    !
    mgcp profile default
    !
    !
    !
    dial-peer voice 2 pots
    description ISDN
    service mgcpapp
    destination-pattern 0T
    direct-inward-dial
    port 0/0/0
    forward-digits all
    !
    dial-peer voice 3 pots
    destination-pattern 0T
    direct-inward-dial
    port 0/0/1
    forward-digits all
    !
    !
    !
    telephony-service
    load 7960-7940 P00307020400
    max-ephones 50
    max-dn 200
    ip source-address 192.168.61.2 port 2000
    timeouts interdigit 2
    cnf-file location flash:
    cnf-file perphone
    user-locale DE
    user-locale 1 DE
    user-locale 2 DE
    user-locale 3 DE
    user-locale 4 DE
    network-locale AT
    network-locale 1 AT
    network-locale 2 AT
    network-locale 3 AT
    network-locale 4 AT
    max-conferences 8 gain -6
    moh MoH.alaw.wav
    web admin system name admin secret 5 dn-webedit
    time-webedit
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00


    Danke für eure Hilfe!

    MfG
    Martin