.titleBar { margin-bottom: 5px!important; }

Miese Klangqualität

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Xantomorph, 31 Jan. 2005.

  1. Xantomorph

    Xantomorph Neuer User

    Registriert seit:
    31 Jan. 2005
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hamburg
    Hallo,

    ich bastle seit ein paar Tagen mit einer Asterisk herum, dabei wollte ich mich
    hauptsächlich ersteinmal mit dem Thema vertraut machen.

    In ein Redhat Enterprise Linux 3 Update 4 (P4 , 1 GB Ram) habe ich eine
    ISDN Karte (Fritz!PCI) gesteckt, alles gemacht wie es hier und anderswo
    beschrieben war und es läuft. Ich kann rauswählen, reinwählen, monitoren
    etc. - toll.

    Telefonieren fängt ja aber erst an Spaß zu machen über das Netz. Also
    habe ich mir iaxcomm heruntergeladen, einen IAX2 User eingerichtet und
    wollte drauflos telefonieren. Die Soundqualität ISDN => Asterisk
    (Voicebox) ist klasse. Die Soundaufzeichnungen sind völlig ok. Aber VoIP
    => ISDN ist mies, VoIP => VoIP ist sogar noch schlechter. Das
    Schlimme ist - so finde ich - selbst wenn ich einen u-law Codec anstelle
    des GSM auswähle ist die Klangqualität nicht besser (eher - subjektiv,
    schlechter).

    Hat jemand eine Idee wo ich anfangen kann die Soundqualität zu verbessern?
    Ist irgendwo der Wurm drin oder ist das vielleicht völlig normal?
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Das hört sich nach Wurm an.

    Versuche mal eine Asterisk-interne Verbindung von zwei Usern, nicht über ISDN-Karte! Also z.B. echte VOIP-Telefone oder Soft-phone mit gleichen Codec.

    Wenn du hier schon Probleme hast, spinnt meist irgendwelche harte Ware.

    Dann mit unterschiedlichem Codec

    Wenn erst hier Probleme, dann fehlt Rechnenleistung => Täter suchen

    Wenn das gut ist, einer der User über die ISDN-Karte, aber wieder intern.

    Wenn hier Probleme, alles was an onboard-Hardware (LPT, seriell ...) abstellbar ist, abstellen, bzw irq's wegnehmen. Bei Mehrfachbelegung von IRQ's gibts desöfteren Probleme.

    Dann ein Versuch über Internet. dazu alles was Trafik macht abstellen und zu unchristlicher Zeit (Morgens zwischen 5 und 7) versuchen.

    Manche Provider haben mehr Kunden als Bandbreite ...

    Wenn hier Probleme, dann Ursachenforschung (Bandbreite, Kabelqualität)

    Nicht weiter weiss
     
  3. Xantomorph

    Xantomorph Neuer User

    Registriert seit:
    31 Jan. 2005
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hamburg
    Ja, genau das hab ich auch ausprobiert - das rauscht und klingt gedämpft
    wie nur irgendetwas. Kann das sonst auch der Client sein (iaxcomm) ?

    Ich werde mich jetzt erstmal auf die Suche nach Hardwareproblemen machen.
     
  4. traxanos

    traxanos Mitglied

    Registriert seit:
    15 Juli 2004
    Beiträge:
    486
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nimm mal 2x x-lite-Clients (www.xten.com) und Teste dann nochmal Intern. Als was würde Asterisk Compiliert? hast du schonmal i586 aus probiert. Verwende mal einen kompletten andere Codec auf beiden seiten.
     
  5. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Auch der ist möglich.

    Fang am besten bei Mic/Soundkarte & Co an.

    Hast du irgendwelche Hf-Schleudern in unmittelbarer Nähe von Mic oder Soundkarte, z.B. Wireless-Lan, Bluetouth, Funkmaus ...
    das Rauschen deutet daraufhin, oder dein Mic ist zu empfindlich und sammelt z.B. Lüfterlärm ein.
     
  6. Xantomorph

    Xantomorph Neuer User

    Registriert seit:
    31 Jan. 2005
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hamburg
    Wow, danke - das sind ja eine Menge Tipps gewesen.

    Sound & Mic sind eine Audigy und eine Plantronics Headset - nicht so schlecht.
    Störfelder hab ich hier eher nicht, den Lüfter höre ich kaum. Ich werde
    aber nochmal die neuesten Treiber benutzen, nur für alle Fälle.

    Der Test mit den 2x X-Lite war ähnlich den 2x iaxComm - recht schlechte
    Qualität. Das verwunderliche daran: ISDN -> VoIP und VoIP -> ISDN klingt
    recht gut, fast kristallklar. Der Verlust der Qualität passiert immer wenn
    ich ein zweites Mal VoIP in die Gleichung mit aufnehme, als z.B.
    VoIP -> ISDN -> PSTN -> ISDN -> VoIP.
    Ich forsche weiter, zur Zeit hab ich ersteinmal alle Codecs auf uLaw/G711u
    gesetzt, Bandbreite ist ohnehin eher kein Problem.

    Was auf jeden Fall eine Verbesserung beracht hat: Hardware deaktivieren.
    Ich habe eine Menge an integrierten Schnittstellen abgestellt und nur noch
    die nötigsten in Betrieb, das macht es ein wenig besser. Dabei ist auch die
    integrierte Soundkarte abgeschaltet worden.

    Den "*" neu compilen als 586 hab ich noch nicht gemacht, hab ich aber im Auge.
     
  7. Xantomorph

    Xantomorph Neuer User

    Registriert seit:
    31 Jan. 2005
    Beiträge:
    38
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hamburg
    Update: Das mit der Soundqualität hat sich erledigt, vielen Dank für die
    vielen guten Tipps.

    Ich denke es lag vor allem an zwei Dingen: iaxComm und den codecs (G711a und GSM)

    Mit 2x SIP / X-Lite Clients und G711u Codec ist das eine astreine Qualität geworden,
    da kann keiner was gegen sagen. Das war eine interessante Odysse ;-)