.titleBar { margin-bottom: 5px!important; }

Miniserver für Asterisk

Dieses Thema im Forum "Andere VoIP-Hardware" wurde erstellt von astrakid, 25 Feb. 2012.

  1. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo,
    aktuell läuft Asterisk ganz gut auf meinem Router unter tomato-firmware (Asus RT N-16).
    Ganz gut, weil:
    - voicemail ist "choppy", was wohl am fehlenden timing-modul liegt. das kann ich aber nicht so einfach nachinstallieren, zumindest habe ich noch keinen weg gefunden...
    - kompilieren war sehr umständlich und hat sehr lang gedauert...
    - faxen geht noch nicht (hängt wohl auch mit dem timing-modul zusammen)

    Das ist alles nicht dramatisch, aber da auch ein usb-stick am router hängt als zentrales backup für ein paar sachen, denke ich doch langsam darüber nach, diese funktionen auf ein eigenes system umzuziehen.
    meine Anforderungen sind relativ klar abgegrenzt:

    Prio1: Niedriger Stromverbrauch! Für den dauerbetrieb möchte ich ungerne mehr als 10W verbraten. Mein Router kommt momentan auf 8W mit Asterisk.

    Prio2: Windows und Linux sollten darunter laufen, wobei ich zunächst nur linux benötige.
    Anwendungen:
    - Medienplayer (nur mp3s, muss fernbedienbar über android sein, aktuell mache ich das unter windows mit vlc und auf android mit vlc remote)
    - datenzentrale: ftp reicht notfalls, smb wäre gut. performance? s. prio1... ;) mir reicht es, wenn die daten etwas schneller als bisher geschrieben würden (jetzt unter 2mb/s, 5mb/s wäre schon praktisch)

    Prio2: Bitte standard-Linux, damit ich hier flexibel bleibe.

    Prio3: mehr als eine Netzwerkschnittstelle, dann könnte ich meinen Router ablösen und gänzlich durch diesen "server" ersetzen.

    Prio4: das ganze sollte auf SSD- oder CF- oder USB-Basis laufen, damit die festplatten nicht dauern loslaufen (damit wird ein 10W auch erst machbar denke ich)

    Gibt es in dieser Richtung etwas?
    Ich kenne Alix, Via, AMD Geode oder auch AMD e-*50-Systeme. Vom atom halte ich weniger, weil meistens odch mehr Leistung verbraten wird als bei den anderen. Bei Alix bin ich, was die Linux-Distribution angeht, aber ziemlich eingeschränkt...


    gruß,
    astrakid
     
  2. DasTelefon

    DasTelefon Mitglied

    Registriert seit:
    5 März 2011
    Beiträge:
    435
    Zustimmungen:
    3
    Punkte für Erfolge:
    18
    Schaue dir mal den HP Micro Server an. Das teil ist einfach nur Geil.
     
  3. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    also ich benutze hier einen Iomega iConnect, auf dem allerdings nicht die Originalfirmware, sondern ein relativ "normales" Debian läuft. Das Rechnerlein hat eine ARM v5 CPU mit 1 GHz, 256 MB RAM, 512 MB Flash, sowie 4 USB-Ports. Vom Flash nutze ich aber nur ca. 5 MB für Kernel und Initramfile, weils relativ lahm ist.
    Eine Grafikkarte ist nicht eingebaut, dafür gibts aber die Möglichkeit über eine 3,3V-Seriell-Verbindung und ein Terminalprogramm auch ohne funktionierendes LAN drauf zuzugreifen (Minicom lässt grüßen).

    Momentan läuft darauf hauptsächlich nur der Asterisk, sonst ssh, sftp (später soll da noch einiges mehr drauf laufen, der RAM hat noch reichlich Reserven):

    Asterisk 1.8.10.0-rc3 built by pr @ iconnect on a armv5tel running Linux on 2012-03-02 15:55:15 UTC

    Zum Thema Stromverbrauch:
    - im Leerlauf bei eingeschaltetem WLAN (funkt zu meinem 1 km entfernten AP) + CF-Adapter am USB: ca. 4,7 W
    - bei Volllast (nur getestet mit einer kurzen Endlos-Schleife): ca. 5,5 W
    - wenn ich einen USB-WLAN-Stick dranhänge (Alfa AWUS036H) steigt der Verbrauch auf ca. 6,5 W (bei ansonsten Leerlauf, d.h. das Teil alleine braucht schon 2 W?!)

    Also wenn Du Dich mit Linux (gut! :) ) auskennst, könnte das vielleicht eine Alternative für Dich sein. Windoof läuft da definitiv NICHT drauf, soviel ist schon mal klar, aber das habe ich bisher (fast) noch nie gebraucht :)

    Voicemail habe ich momentan noch nicht laufen, soll auch noch kommen, mich wunderts nur, wieso es bei Dir "choppy" ist - dafür wird ja normalerweise nicht sooviel Rechenleistung benötigt? Übrigens braucht der "*" bei einem laufenen Gespräch (SIP) nur ca. 1 % CPU!

    Zum Thema Compilieren: ich war ehrlich gesagt zu faul, mir einen Cross-Compiler zu installieren und habe stattdessen direkt auf dem iConnect im Debian die normale Enwicklungsumgebung installiert. Eine Linux-Kernelübersetzung dauert ca. 65 Min., den Asterisk zu übersetzen hatte glaube ich ca. 45 min gedauert. Mich selbst stört das nicht, daß das so "lange" dauert, wenn ich da an die Zeiten zurückdenke, die eine Kernelübersetzung auf einem 386SX dauerte (vor ca. 20 Jahren :) ), dann ist das Teil "rasend" schnell... ;-)

    Thema Faxen (über SIP): damit habe ich mich noch gar nicht befasst, brauche ich im Moment auch nicht, es kann aber durchaus sein, daß Du Recht hast mit dem Timingmodul...

    Die Lesegeschwindigkeit von der CF-Karte (über 100 MBit LAN) ist ca. 10 MB/sec, Schreiben ist komischerweise viel langsamer, genaue Messung müsste ich noch nachholen...

    Deine 2. Prio wäre wohl erfüllt, da wie gesagt ein normales Debian darauf läuft, bzw. auf der CF-Karte installiert ist...
    Prio3: da muß der kleine iConnect leider passen, mich selbst ärgert das auch, daß das Teil nur eine LAN-Schnittstelle hat (die hat aber immerhin Gigabit!).
    Prio4: siehe oben, bei mir steckt eine 32 GB-CF Karte in so einem 4-fach USB-Medienadapter (CF, SD, MicroSD usw.)

    Später möchte ich da auch noch eine USB-Soundkarte und einen USB-Fernbedienungsempfänger (von Pollin) dranhängen um darüber Musik zu hören, bzw. Asterisk "klingeln" lassen...

    Ich hatte den iConnect gebraucht bei eBay für 32 Euro ersteigert und habe es bisher noch nicht bereut :)

    Falls das Teil aber trotzdem nichts für Dich wäre, und Du noch etwas warten kannst wäre vielleicht der KTT20/pITX von Kontron etwas für Dich (siehe c't Heft 7/12, Seite 30). Das Teil soll bei nur ca. 3-5 W eine Dual-GHz CPU, 1 GB RAM, DVI-Grafik, 3xRS232 usw. haben, nur leider ist das Ding noch nicht erhältlich. Wenns mal soweit sein sollte, hätte ich da auch Interesse dran :)
     
  4. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    das iomega-teil klingt sehr interessant...
    war es kompliziert, ein anderes OS daraufzubügeln? ich bin zwar linux-bewandert, aber kein experte. kompilieren kriege ich hin, wenn ich die dafür benötigten pakete zur verfügung habe (gcc, make etc.). am cross-kompilieren scheitere ich bereits...
    ansonsten kommt es dem, was ich haben möchte, sehr nahe.
    alternativ bin ich jetzt noch auf das raspberry pi teil gestoßen - das ist auch genial, ist aber noch nicht lieferbar... (www.raspberrypi.org).

    gruß,
    astrakid

    p.s.: du scheinst dich mit linux gut auszukennen - momentan versiuche ich, ein fehlendes modul für meinen bisherigen asterisk nachzukompilieren, scheitere aber an fehlenden linux-sourcen. kannst du mir hier helfen?

    [Edit foschi: kein Schieben, daher Folgepost von astrakid hier eingefügt.]

    Ja, aber es ist oversized. Ansonsten wäre es perfekt - skalierbar, alle Möglichkeiten offen, aber dadurch auch sehr stromdurstig...
    trotzdem danke.
     
  5. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ob es also kompliziert war, auf dem iConnect Debian zu installieren? Naja, ganz so einfach wie bei bei einem PC isses nicht, da das Ding ja ein "Embedded" Gerät ist. Du hast keine Grafikkarte, an der man einen Monitor anschließen kann, von daher braucht man schonmal einen anderen Zugang. Es gibt zwar im Netz eine Anleitung, wie man ohne 3,3V Seriellkabel nur per ssh Archlinux draufbekommt - aber Vorsicht! Wenn man sich dabei den Netzwerkzugang zerschießt, geht ohne Seriellverbindung sowieso nichts mehr!

    Also isses besser, man baut sich gleich ein entsprechendes Kabel :) Ich für meinen Fall habe ein "CA-42 Kabel" im eBay für 5 Euro gekauft und es entsprechend umgebaut, d.h. das Ende abgeschnitten und an die 3 Adern ein 3-poligen Stecker gelötet, der mit dem Board des iConnects verbunden wird (bei Interesse schreibe ich mehr dazu, oder suche mal nach CA-42 und 3,3V ...)

    Ein Stolperstein war z.B. auch, daß der Debian-Installer einen Bug hat, er besteht unbedingt auf einer 1000 MBit-Netzverbindung zur Installation - und genau da mußte ich passen, weil ich nur einen 100 MBit-Switch habe. Nur alleine deswegen auf die Schnelle einen GBit-Switch zulegen wollte ich mir dann doch nicht, und habe mir dann letztlich so geholfen, daß ich nicht den Original-Debiankernel für die Installation verwendet habe, sondern einen anderen, der das LAN-Interface auf 100 MBit läßt...

    Ein weiteres Problem war auch, daß der Bootloader vom iConnect ("uboot") scheinbar Schwierigkeiten hat, von einem USB-Medium zu booten, manchmal klappts, aber eher nicht :-(

    Ich hab's dann so gemacht, daß ich den Kernel und das InitRamfile in den eingebauten Flash geschrieben habe (vorher vom Flash ein Backup gemacht). Von dort aus liest uboot Kernel und Initramfile problemlos ein, der dann startende Kernel kann ohne weiteres von der CF-Karte booten. Dieses Problem wurde auch anderswo schon beschrieben. Ich habe mir aber ehrlich gesagt nicht getraut, den Bootloader durch eine neuere Version zu ersetzen: wenn da was schief geht, ist das Teil entweder nur noch ein Briefbeschwerer oder man bräuchte zur Wiederbelebung ein JTAG-Kabel usw., was alles ziemlich aufwendig ist...

    Also, alles in allem - es waren doch schon einige Hürden zu überwinden, bis ich alles zum laufen gebracht hatte, aber ab da, war es relativ leicht, weiterzukommen, z.B. weitere Programme per aptitude oder apt-get install zu installieren. Das Linux auf dem iConnect "fühlt" sich so an, wie wenn man auf einem ganz normalem PC eingeloggt wäre (per ssh oder wie erwähnt per Seriellverbindung). Man merkt eigentlich so gut wie keinen Unterschied, außer, daß die Rechenleistung natürlich nicht Superspitze ist. Aber für den Zweck, den das Teil erfüllen soll, reicht es mehr als aus. Meine erste eigene Linuxinstallation war ca. 1992 auf einem 486DX/2 66 MHz mit 16 MB Speicher, darauf lief auch ganz bequem X11 - im Vergleich zum 486-er ist der iConnect ein Großrechner! :) (und das bei wie gesagt nur ca. 4-5 Watt Verbrauch!)

    Zum Thema Compilieren schrieb ich ja schon, meiner Meinung nach isses auch sicherer, direkt auf dem iConnect alles zu übersetzen, weil wenn z.B. irgendeine Lib fehlt, dann meckert der configure das auch an - ich weiß nicht, wie das beim Crosscompiler dann ist, man müßte ja die komplette Systemumgebung mit allen installierten Libs nachbilden, oder? Also ehrlich gesagt kenne ich mich da auch nicht so genau aus, u.a. war das auch ein Grund, mich für den iConnect zu entscheiden, weil er eben doch schon ausreichend viel Speicher und Rechenleistung zum direkten Übersetzen mitbringt. Der Vorgänger bei mir war der Asus WL500gP, das Teil war auch nicht schlecht, allerdings doch schon sehr viel langsamer und hat auch viel weniger Speicher, so daß es da fraglich ist, ob gcc & Co.laufen würden...

    Du schreibst, Du möchtest "ein fehlendes modul für meinen bisherigen asterisk nachzukompilieren, scheitere aber an fehlenden linux-sourcen"? Wie soll man das denn jetzt genau verstehen? Fehlen die Quelltexte des Asterisk-Moduls, oder fehlen die Linux-Quelltexte? Die kann man sich ja normalerweise von www.kernel.org runterladen :)

    Du mußt natürlich beachten, daß das ein Maschinchen mit ARM-CPU ist, da könnte es schonmal sein, daß das eine oder andere Programm wie selbstverständlich von einer x86-Architektur ausgeht und dann beim Compilieren Schwierigkeiten macht...

    BTW: hat evtl. einer der werten Mitleser irgendwo eine genaue Beschreibung des "Marvell RD-88F6281 Reference Board" gefunden, d.h. mich würde mal interessieren, ob Schaltpläne verfügbar sind? Kann man irgendwo die GPIO-Pins anzapfen? Oder was auch toll wäre - der verwendete SOC hat ja 2 SATA-Ports eingebaut, nur leider weiß ich nicht, ob man die evtl. nutzen kann um daran direkt eine 2,5"-SATA-Platte zu hängen?
     
  6. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    hi,
    danke für deine ausführliche antwort.
    ganz so grün bin ich dann doch nicht hinter den ohren, arbeite selbst im moment mit einem asus rt n16, davor mit einem wrt54g und mit dreamboxen - mir ist schon klar, dass beim "abschuss" des netzwerk-interfaces man nicht mehr einfach so da ran kommt...

    ich versuche gerade, bei ebay an ein iconnect zu kommen. aber da muss ich wirklich ein schnäppchen machen, sonst warte ich lieber auf den raspberry pi.

    beim compilen des fehlenden moduls auf dem asus rt n16 (tomato firmware) bekomme ich die fehlermeldung:

    root@Rantanplan_Asus:/opt/16gb/tmp/dahdi-linux-2.6.0# make
    make -C drivers/dahdi/firmware firmware-loaders
    make[1]: Entering directory `/opt/16gb/tmp/dahdi-linux-2.6.0/drivers/dahdi/firmware'
    make[1]: Leaving directory `/opt/16gb/tmp/dahdi-linux-2.6.0/drivers/dahdi/firmware'
    You do not appear to have the sources for the 2.6.22.19 kernel installed.
    make: *** [modules] Error 1

    Die SRC habe ich mir bereits heruntergeladen (2.6.22). aber was nun??? wie binde ich die srcen ein?

    gruß,
    astrakid
     
  7. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe ja auch nicht behauptet, oder auch nur angedeutet, daß Du "grün hinter den Ohren" wärest :)
    Aber Du kannst mir gerne glauben, daß die Installation von Debian auf'm iConnect durchaus "tricky" war...
    Mein Hinweis wegen dem "Abschuss" des LANs bezog sich eher auf die Anleitung im Netz, wo halt beschrieben ist, wie man nur per ssh (ohne Absicherung mit 'ner Seriellverbindung) Archlinux installiert bekommt...

    Ab und zu taucht mal wieder einer auf, scheinbar ist das wohl ein Auslaufmodell, wird wohl nicht mehr hergestellt?
    Beim Raspberry Pi würde mich die arg eingeschränkte Schnittstellenausstattung stören, wenn's aber nicht benötigt wird,
    wäre das auch ein guter Kandidat für Deine Anforderungen eines Miniservers...

    Hast Du vorher ./configure aufgerufen? Wenn ja, hat er irgendeinen Hinweis ausgegeben auf die Linuxsourcen?
    Wo genau hin hast Du die Linuxsourcen installiert?

    Übrigens hatte ich auch mal probiert, DAHDI zu installieren - aus irgendeinem Grund scheiterte das auch bei mir (auf'm iConnect, mit 2.6.38.4-er Kernel)... Ist aber schon
    eine Weile her - ich glaube, das lag daran, daß DAHDI nur von älteren Kerneln unterstützt wurde, etwas in der Art. Ich glaube, der einzige Grund, für was ich DAHDI brauchte,
    war wg. 3-er Konferenzen...
     
  8. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hi,
    die Schnittstellenausstattung beim Raspberry Pi ist a.m.S ausreichend. Einzige Einschränkung ist die 100MBit-Schnittstelle, ansonsten ist alles dran, was man braucht (Audio, HDMI, Netzwerk, USB).
    DAHDI brauche ich nur wegen der timing-Quelle, da mit dem res_timing-pthread der Fax-Empfang nicht funktioniert (bringt Asterisk jedes mal zum absturz). entweder timer_fd oder dahdi - beides gleich schwierig.
    Die SRCen habe ich gar nicht installiert, bisher nur heruntergeladen. wie soll ich die denn installieren? der Kernel ist ja installiert.
    Und DAHDI hat kein ./configure, das wird direkt über make aufgerufen... Bin im Moment hilflos, suche verzweifelt nach Hilfe im www...

    gruß,
    astrakid
     
  9. doktorknow

    doktorknow Neuer User

    Registriert seit:
    16 Okt. 2008
    Beiträge:
    76
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #9 doktorknow, 20 Juni 2012
    Zuletzt bearbeitet: 20 Juni 2012
    Moin moin,

    ich versuche hier gerade auch ein Debian auf eine IConnect zu bekommen und habe jetzt ein Problem.
    Petri69, kannst Du mir dabei vielleicht helfen?

    Ich bekommen im Moment das hier:
    Ich habe nach dieser Anleitung http://www.cyrius.com/debian/kirkwood/openrd/install.html die ArcNumber geändert... das war sicherlich dumm ;-(


    So, ich habe die ArcNumber wieder auf 1682 gesetzt und nun bootet die iConnect wieder durch. Dennoch könnte ich Hilfe beim Installieren von debian gebrauchen ;-)
    Ich nutze zwar schon eine ganze Zeit Linux, jedoch wenn es um UBoots und Kernels geht, die getauscht werden sollen, da hört es dann definitiv bei mir auf...

    Gruß,
    doktorknow
     
  10. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo doktorknow,

    also, so wie ich die Sache sehe, hattest Du wohl vorher die "arcNumber" auf 2325 (= hexadez. 0x00000915) gesetzt, und der Kernel oder uboot beschwert sich darüber :) Wie Du selbst schon geschrieben hast, setze einfach die ArcNumber auf 1682 (= hexadez. 0x00000692, siehe Deine Fehlermeldung).

    Ehrlich gesagt verstehe ich das auch nicht so ganz, was das mit den ArcNumber´s bedeuten soll, bei mir im uboot-Environment ist das jedenfalls auch auf 1682 (dezimal) gesetzt. Auf der Seite von Martin Michlmayr, die Du erwähntest, steht ja auch nur was von "OpenRD" (Base and Client) bzw. "OpenRD-Ultimate". Scheinbar gibt es kleinere Hardwareunterschiede zwischen diesen ARM-basierten Boards (inkl. iConnect), und die ArcNumber beschreibt vielleicht genau eine spezielle Variante der Hardware - wer weiß, vielleicht kann sich mal dazu ein Experte äußern? :)

    Ich kann mich nicht mehr genau erinnern, aber irgendwo las ich mal eine Diskussion im Netz, wo jemand empfahl, einfach die ArcNumber auf ??? zu setzen (Zahl habe ich vergessen), und sich jemand anderes ziemlich drüber beschwerte, daß der andere da nicht drin rumzupfuschen habe :) In dem Artikel gings um die Unterstützung des iConnect und welche Arcnumber nun zu verwenden sei oder auch nicht...

    OK, also konkret zu *diesem* Problem mit der Arcnumber kann ich Dir auch nur empfehlen, sie auf 1682 zu setzen (im U-Boot, vor dem Kernelboot):

    setenv arcNumber 1682
    saveenv

    Daß Du ein Seriell-Konsolenkabel brauchst, dürfte aber bekannt sein (siehe mein Posting weiter oben)?

    Wie gesagt, ist die Installation von Debian auf dem iConnect etwas tricky, was mich vorallem genervt hatte, waren die Probleme beim direkten Booten von USB - da kannste Dich schonmal seelisch/moralisch auf auf einiges Haareausraufen gefasst machen :)

    Ansonsten helfe ich gerne weiter, laß Dich von anfänglichen Schwierigkeiten nicht entmutigen.

    Übrigens hat sich mein iConnect sowohl bei -20° im Februar als auch jetzt gerade bei 35°C tapfer geschlagen - das Teil ist bei mir in einem Blechkasten unter dem Dach installiert (wegen der WLAN-Kabellänge gings nur dort). Das Programm sensors meldet +53.0°C CPU-Temp., das Teil läuft super stabil.

    Schöne Grüße aus dem heißen Ungarn,
    Petri69
     
  11. doktorknow

    doktorknow Neuer User

    Registriert seit:
    16 Okt. 2008
    Beiträge:
    76
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moni Petri69,
    danke für die schnelle Nachricht.
    Die ArcNumber stimmt jetzt wieder. Ich gehe nach dieser Anleitung vor:
    http://www.kroonen.eu/wiki/Install%20Debian

    Hast Du das auch so in etwa gemacht? Die Bad Magic Numbers kommen nun auch nicht mehr. Da scheint mein FAT16 formatierter Stick nicht mitgespielt zu haben. Mit ext2 funktioniert das nun. Ich bin gerade bei der debian Installation. Ich habe in der Anleitung aber nicht genau verstanden, wie ich die Kernel-Module und den Kernel auf die Iconnect bringe...
    Beste GRüße von der Nordsee (wolkenverhangen ;-( )
    doktorknow
     
  12. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo doktorknow,

    OK, also an der ArcNumber würde ich jetzt nicht weiter rumfummeln :)

    Hast Du nun ein Seriellkabel für die Konsole oder nicht? Weil vieles von dem, was ich Dir beschreibe, geht nur über die serielle Konsole!

    Die "kroonen.eu"-Seite hatte ich auch gelesen, vorallem aber die von dem portugisischen IT-Prof. Diogo Gomes
    (http://diogogomes.com/2010/11/14/debian-install-iconnect/). Mittlerweile findet man einiges im Netz beim Suchen nach "iconnect+Debian"...

    So, wegen des USB-Sticks-Dateisystems:

    Booten kannst Du auch von FAT16 (oder FAT32) formatierten Medien (fatload-Kommando im uboot), um es ganz genau zu sagen: uboot kann den Kernel und die InitRamdisk von dort in den Arbeitsspeicher des iConnect laden (mehr aber auch nicht). Um aber Kernel+Initrd zu starten, brauchst Du schon ein übliches Linuxdateisystem. Im Falle einer CF, SD-Karte oder anderer Flashmedien würde ich aber dringend empfehlen, KEIN Journaling zu nutzen (also ext3, ext4 usw.) - weil dadurch die Flash-Speicherzellen zu schnell verschleißen.
    Siehe diogogomes.com: "USB harddisk or stick (harddisk is advisable since stick tend to wear off)"

    Der zu startende Kernel muß auf alle Fälle USB-Storage unterstützen, da es bei iConnect ja leider nicht anderes geht (theoretisch hat der verwendete SOC 2 SATA-Ports, ich weiß aber nicht, ob und wie diese sich nutzen ließen.)

    Konkret mußte ich wegen der erwähnten Schwierigkeiten beim USB-Booten vom uboot aus (ext2load usb...) beim Testen ständig zwischen einer Uralt-FAT 32MB SD-Karte (die enthielt die verschiedenen Kernels/Initrds) und der CF-Karte (die jetzt das System enthält) wechseln. Dieser verfluchte uboot hat es wiederholbar nicht auf die Reihe gebracht, direkt von der CF zu booten, es ging reproduzierbar nur von der kleinen SD-Karte.

    Wie bereits weiter oben erwähnt, hat der Original-Installationskernel von Debian ("Armel") das Problem, daß er eth0 fest auf 1 GBit schaltet, falls Du "nur" einen 100 MBit-Switch hast, gibts da Probleme. Ich hatte es so gemacht, daß ich mir irgendwo aus´m Netz einen Kernel für die "Sheeva"-Plattform runtergeladen habe, und diesen als Bootkernel für die Installations-Initrd von Debian verwendet hatte. Dabei hat er zwar irgendwelche kleineren Sachen angemeckert, aber die Installation lief soweit durch...

    OK, also bevor ich hier noch Romane schreibe, wäre es wichtig zu wissen, ob Du so ein Seriell-Konsolenkabel hast oder nicht? Ohne das wirds schwierig.
    Hast Du evtl. einen 1 GBit-Switch oder switching Hub? Das würde die Sache vereinfachen, weil sonst der Bug im Debian-Installationskernel zuschlägt...

    Schick´ mal ein paar Wolken von der Nordsee hier runter, wir verkochen hier
    fast :)

    Viele Grüße,
    Petri69
     
  13. doktorknow

    doktorknow Neuer User

    Registriert seit:
    16 Okt. 2008
    Beiträge:
    76
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #13 doktorknow, 20 Juni 2012
    Zuletzt bearbeitet: 20 Juni 2012
    Also, serielles Kabel ist vorhanden und angeschlossen. Leider habe ich hier nur 100er Switches. Ich könnte mir bis zum WE noch einen 1000er Switch bestellen. Es eilt hier nicht mit der Installation...
    Wenn Du allerdings sagst, dass das auch mit einem Sheevaplug Kernel geht, dann versuche ich das da natürlich erst mit. Muss ich da auf irgend etwas achten, oder kann ich einfach einen Kernel von hier:http://www.xilka.com/sheeva/ aussuchen?

    Beste Grüße,
    doktorknow

    PS Eine Mischung aus ungarischer Hitze und norddeutscher Frische wäre ein Traum ;-)

    PPS Ich habe jetzt mal einen 1000er Switch bestellt. Sobald der da ist melde ich mich hier wieder! Vielen Dank schon einmal für die Hilfe!!!
     
  14. Petri69

    Petri69 Neuer User

    Registriert seit:
    12 Apr. 2012
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    OK, lade Dir z.B. den folgenden Kernel:
    http://www.xilka.com/sheeva/2.6/2.6.38/2.6.38.4/sheeva-2.6.38.4-uImage runter, speichere ihn auf einen USB-Stick ins Hauptverzeichnis.
    (Ich habe mehrere Kernels ausprobiert, auch 3.x.x-er, z.B. 3.2.4, hat auch geklappt...)

    Dann lade Dir http://m.kroonen.eu/iconnect/installer/uInitrd und speichere die uInitrd ebenfalls ins Hauptverzeichnis des USB-Sticks.
    Schließe sowohl das Seriellkabel als auch den USB-Stick (oder SD-Kartenleser, was auch immer) am iConnect an.

    Das schonmal ganz gut, wenn das Seriellkabel funktioniert. Wenn Du mit angeschlossenem Seriellkabel und funktionierendem Terminalprogramm
    (ich verwende Minicom mit 115200 8N1) den iConnect startest, solltest Du als allererstest die Bootmeldungen vom U-Boot sehen:

    ----------------------------- schnipp -----------------------------
    Welcome to minicom 2.5

    OPTIONS: I18n
    Compiled on Feb 5 2011, 06:31:35.
    Port /dev/ttyUSB0

    Press CTRL-A Z for help on special keys


    __ __ _ _
    | \/ | __ _ _ ____ _____| | |
    | |\/| |/ _` | '__\ \ / / _ \ | |
    | | | | (_| | | \ V / __/ | |
    |_| |_|\__,_|_| \_/ \___|_|_|
    _ _ ____ _
    | | | | | __ ) ___ ___ | |_
    | | | |___| _ \ / _ \ / _ \| __|
    | |_| |___| |_) | (_) | (_) | |_
    \___/ |____/ \___/ \___/ \__|
    ** MARVELL BOARD: RD-88F6281A LE

    U-Boot 1.1.4 (Feb 2 2010 - 10:13:16) Marvell version: 3.4.25

    Mapower version: iConnect 2.1 (512MB) (2010/02/02)

    U-Boot code: 00600000 -> 0067FFF0 BSS: -> 006CFB00

    Soc: 88F6281 A0 (DDR2)
    CPU running @ 1000Mhz L2 running @ 333Mhz
    SysClock = 333Mhz , TClock = 200Mhz

    DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
    DRAM CS[0] base 0x00000000 size 256MB
    DRAM Total size 256MB 16bit width
    Addresses 8M - 0M are saved for the U-Boot usage.
    Mem malloc Initialization (8M - 7M): Done
    NAND:512 MB
    Flash: 0 kB

    CPU : Marvell Feroceon (Rev 1)
    Streaming disabled
    Write allocate disabled

    Module 0 is RGMII
    Module 1 is TDM

    USB 0: host mode
    PEX 0: PCI Express Root Complex Interface
    PEX interface detected Link X1
    Net: egiga0 [PRIME], egiga1
    Hit any key to stop autoboot: 0
    ----------------------------- schnapp -----------------------------

    So, wenn er an dieser Stelle ("Hit any key...") angekommen ist, dann hast Du nur 3 Sekunden, um das autoboot anzuhalten und im Bootloader zu bleiben.
    Also einfach drauf achten, wenn er das anzeigt (von 3 rückwärts bis 0 runterzählt), rechtzeitig Enter drücken.

    Dann gibst Du am "Marvell>>" Prompt ein:
    usb start <Enter>

    Theoretisch müßte er jetzt in etwa folgendes sagen:

    (Re)start USB...
    USB: scanning bus for devices... 3 USB Device(s) found
    Waiting for storage device(s) to settle before scanning...
    1 Storage Device(s) found

    (An genau der Stelle bin ich manchmal fast verzweifelt, bis ich darauf kam, daß er mit der kleinen 32MB-SD Karte IMMER starten konnte, und mit der 32GB CF-Karte fast NIE :) )

    Dann gibst Du ein:
    fatload usb 0:1 0x00800000 /boot/uImage-Linux-2.6.38.4-iConnect <-- genaue Pfadangabe des Kernels
    fatload usb 0:1 0x01100000 /boot/uInitrd-2.6.32-5-kirkwood <-- genaue Pfadangabe der Initrd

    Nach beiden Kommandos kommt eine Reihe von Punkten und dann die Angabe der gelesenen Bytes.

    Als nächstes:
    setenv bootargs console=ttyS0,115200n8 root=/dev/sda1 <-- das muß später um einiges erweitert werden, reicht aber für den Anfang
    bootm 0x00800000 0x01100000 <-- Damit wird der Kernel+Initrd gestartet

    Dann sollte was ähnliches erscheinen wie:

    ## Booting image at 00800000 ...
    Image Name: Linux-2.6.38.4-iconnect
    Created: 2011-05-02 21:01:15 UTC
    Image Type: ARM Linux Kernel Image (uncompressed)
    Data Size: 2437260 Bytes = 2.3 MB
    Load Address: 00008000
    Entry Point: 00008000
    Verifying Checksum ... OK
    OK
    ## Loading Ramdisk Image at 01100000 ...
    Image Name: initramfs
    Created: 2012-02-05 0:44:33 UTC
    Image Type: ARM Linux RAMDisk Image (uncompressed)
    Data Size: 5480896 Bytes = 5.2 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    <---- bis hier lief uboot, ab jetzt startet der Kernel ---->
    Starting kernel ...

    Uncompressing Linux... done, booting the kernel.
    [ 0.000000] Linux version 2.6.38.4-iconnect (root@merlin-vm) (gcc version 4.4.1 (Sourcery G++ Lite 2010q1-188) ) #1 Mon May 2 22:01:10 WEST 2011
    [ 0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=00053977
    [ 0.000000] CPU: VIVT data cache, VIVT instruction cache
    [ 0.000000] Machine: Marvell RD-88F6281 Reference Board


    OK, versuche Dein Glück, es wird wahrscheinlich nicht gleich von Anfang an klappen, aber nur Mut :)

    Meistens bleibt er (war bei mir zuminstest so) am "usb start" hängen, deshalb der Hinweis, daß Du evtl. mehrere unterschiedliche Flashmedien durchprobierst, bei mir klappte es mit einer Uralt 32MB SD-Karte am besten. Wenn einmal alles installiert ist, ist es am besten, man schreibt Kernel und Initrd in den internen Flash (davon hat er ja 512 MB), und läßt uboot alles von da laden. Das würde aber jetzt erst einmal zu weit führen, versuche erstmal o.g. Booten von USB.

    Viel Glück und Erfolg,
    Petri69
     
  15. doktorknow

    doktorknow Neuer User

    Registriert seit:
    16 Okt. 2008
    Beiträge:
    76
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, da bin ich wieder ;-)
    Es hat beim zweiten USB-STick geklappt. Installation ist durchgelaufen und ich kann nun Debian vom Stick starten.
    Super Anleitung, danke!

    Nun bin ich natürlich gespannt, wie man den Kernel und die Initrd in den Flash bekommt...

    Braucht es da spezielle Dateien oder nehme ich die, die ich schon bei der USB-Installation genutzt habe?

    Beste Grüße,
    doktorknow
     
  16. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #16 astrakid, 13 Okt. 2012
    Zuletzt bearbeitet: 15 Okt. 2012
    Nach langem Hin und Her habe ich nun auch ein iconnect ergattert - gebraucht für 34,-... sollte ende nächster Woche ankommen, dann werde ich mich ans Werk begeben und hoffen, hier notfalls Unterstützung zu bekommen.
    Auf meinem Router läuft mittlerweile zwar asterisk 1.8 inkl. Fax (über entware, die neue optware-Alternative), allerdings mit anderen Fehlern (bestimmte Funktionen fehlen), so dass ich endlich mein eigenes asterisk kompilieren können möchte... außerdem läuft die Datenbank nicht so wie ich will und und und... aber das hat ja bald hoffentlich dann alles ein Ende. ;-)

    Danke für den Hinweis. Kurzzeitig hatte ich auch an einen fast baugleichen goflex net gedacht (2xsata, dafür nur 1xusb), aber da ich sata nicht wirklich brauche aber mind. 2xusb, habe ich mich für den iconnect entschieden.

    Zur Debian-Installation habe ich diese Anleitung gefunden. was haltet ihr davon?
    http://www.congenio.de/infos/iconnect.html

    gruß,
    astrakid
     
  17. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hi,
    ich habe nun mein iConnect hier stehen, bereits lauffähig mit debian (die Anleitugn von congenio klappt hervorragend).
    Nun stehe ich vor dem Problem, nicht kompilieren zu können, da ich immer die Fehlermeldung

    checking build system type...
    configure: error: invalid value of canonical build

    erhalte.
    Aber was muss ich als "--build"-Parameter angeben? --build=arm-unknown-linux-gnu ergibt die gleiche Fehlermeldung. Ich vermute, dass mir etwas zum Kompilieren noch fehlt - kann mir einer auf die Sprünge helfen?

    vielen Dank vorab,
    astrakid
     
  18. wincom

    wincom Neuer User

    Registriert seit:
    19 Sep. 2012
    Beiträge:
    198
    Zustimmungen:
    1
    Punkte für Erfolge:
    18
  19. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    perfekt, mit der anleitung sollte ich definitiv weiterkommen. DANKE!
    Jetzt muss ich aber erstmal wieder mit dem iconnect kämpfen - jetzt startet das Debian nicht mehr vom Stick. 1. Neueinrichtung hat auch nicht weitergeholfen... :-/

    Gruß,
    astrakid
     
  20. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    hi,
    weitergekommen bin ich, aber jetzt habe ich ähnliche Probleme wie vorher:

    Die linux-headers konnten nicht installiert werden. Auf dem iconnect wird als Linux-Version folgendes ausgegeben:
    Linux iconnect 3.6.2-iconnect #1 Sat Oct 13 16:57:58 CEST 2012 armv5tel GNU/Linux
    Dazu gibt es keine header-files. Ichhabe auch schon die header-files für "kirkwood" heruntergeladen und einen link angelegt, aber das hilft auch nicht:

    root@iconnect:/usr/src# ls -l
    total 29272
    drwxr-xr-x 29 root root 4096 Oct 17 21:35 asterisk-11.0.0-rc2
    -rw-r--r-- 1 root root 29915474 Oct 17 22:21 asterisk-11.0.0-rc2.tar.gz
    drwxrwxr-x 6 root root 4096 Apr 18 2012 dahdi-linux-2.6.1
    drwxrwxr-x 7 root root 4096 Apr 18 2012 dahdi-tools-2.6.1
    drwxr-xr-x 4 root root 4096 Oct 19 12:41 linux-headers-2.6.32-5-common
    drwxr-xr-x 4 root root 4096 Oct 19 12:47 linux-headers-2.6.32-5-kirkwood
    lrwxrwxrwx 1 root root 31 Oct 19 12:47 linux-headers-3.6.2-iconnect -> linux-headers-2.6.32-5-kirkwood
    lrwxrwxrwx 1 root root 26 Oct 19 12:41 linux-kbuild-2.6.32 -> ../lib/linux-kbuild-2.6.32

    Das ./configure für Asterisk funktioniert erstmal, aber dahdi kann ihc nich tkompilieren, weil er die header-files nicht findet.
    Hat hier jemand einen Tipp, wie ich weiter vorgehen kann?

    Gruß und danke vorab,
    astrakid