.titleBar { margin-bottom: 5px!important; }

misdn 2hfc durchwahl

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von otmar.ganahl, 6 Nov. 2006.

  1. otmar.ganahl

    otmar.ganahl Neuer User

    Registriert seit:
    9 Okt. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Habe endlich eine Asterisk-Kiste mit 2 hfc (beide TE-Mode) per misdn am laufen. Das österreichische "Kopfnummernproblem" habe ich ebenfalls im Griff (Dank crich und immediate=yes). Per WaitForDigits(...) kann ich auch die Durchwahlen von Analogtelefonen abwarten (wenn erst abgehoben wird, und dann gewählt). Scheint fast alles perfekt zu sein.

    Nun aber hat sich ein neues Problemszenario aufgetan:

    - Anruf von einem Analogtelefon (im Speziellen ein GIGASET)
    - Zuerst Wahl der Ziffern mit 3-stelliger Durchwahl z.B. 312 (z.B. 8938 - 312)
    - Erst dann Drücken der grünen Wähltaste

    Asterisk nimmt ab, im Kontext steht dann aber nur eine 3 (1. Ziffer der Durchwahl 312). Ein Einbau von WaitForDigits(...), um weitere Ziffern abzuwarten bringt auch nichts, diese kommen nicht an. Scheint als ob misdn diese nicht durchreicht bzw. dass misdn meint, das eine Blockwahl mit Durchwahl 3 stattgefunden hat.

    Hat jemand ein ähnliches Szenario festgestellt?

    Dank und Gruß an die Community.

    Gruß Otmar Ganahl
     
  2. crich

    crich Mitglied

    Registriert seit:
    1 Sep. 2005
    Beiträge:
    529
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das Gigaset hängt bei dir intern am Isdn Bus ?
     
  3. otmar.ganahl

    otmar.ganahl Neuer User

    Registriert seit:
    9 Okt. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Christian!
    Nein das analoge Gigaset ist das externe Telefon, mit welchem ich die Tests fahre. Also von außen kommt ein Anruf von einem Analogtelefon an ein ISDN Anschluss. An diesem ISDN Anschluss ist die Asteriskanlage mit misdn angeschlossen.

    Im Thread http://www.ip-phone-forum.de/showthread.php?t=118939 hat Stefan meiner Ansicht ein ähnliches Problem. Dort habe ich meine PRoblematik noch einmal verdeutlicht.
    Vorerst Dank und Gruß
    Otmar