Mit Freetz kein DSL

maceis

Mitglied
Mitglied seit
9 Apr 2006
Beiträge
660
Punkte für Reaktionen
4
Punkte
18
Hallo zusammen,

ich bekomme seit eignen tagen mit einer Fritzbox 7270 und installiertem freetz keine DSL Verbindung.

Mit einer 7170 und Freetz, geht DSL ohne Probleme.
Bei beiden 7270 (v1 und v3) wird gar keine DSL Verbindung aufgebaut.
Es ist, als ob das DSL Kabel gar nicht eingesteckt wäre.

Einer der beiden 7270-Boxen war rund neun Monate ohne Änderungen an der Konfiguration problemlos am Netz.
Kaum habe ich testweise eine AVM Firmware aufgespielt, wird DSL problemlos verbunden.

Ich bin ziemlich ratlos und hoffe, dass mir hier jemand aus der Klemme helfen kann.

Danke und Gruß
maceis

Update:
Wenn ich eine Minimalkonfiguration - ohne Pakete baue, bekomme ich eine Freetz Firmware, mit der ich eine DSL Verbindung aufbauen kann.

Ursprünglich hatte ich eine sehr kleine Freetzfirmware, hauptsächlich OpenVPN, dropbear, bftpd, bash und WOL.
Auf der v1 kann man auch nicht viel mehr machen.
Die lief auf der 7270_v1 ewig gut, und jetzt plötzlich nicht mehr.

Wenn ich auf die v3 eine Firmware mit den o.g. Paketen (und einigen mehr) lade, geht DSL - wie beschrieben - nicht mehr.

Wie komme ich jetzt drauf, wo der Fehler liegt?
 
Zuletzt bearbeitet:

SaschaBr

Aktives Mitglied
Mitglied seit
1 Mai 2007
Beiträge
2,306
Punkte für Reaktionen
17
Punkte
38
Welches Freetz? .config?
 

maceis

Mitglied
Mitglied seit
9 Apr 2006
Beiträge
660
Punkte für Reaktionen
4
Punkte
18
Freetz aus dem aktuellem Trunk neu gebaut.
Allerdings bei der stable Version wars auch nicht besser.
Am meisten irritiert mich, dass auf der v1 das selbe Problem wie aus dem Nichts aufgetaucht ist.

config Datei des neuen v3-Images befindet sich im Anhang.
 

Anhänge

SaschaBr

Aktives Mitglied
Mitglied seit
1 Mai 2007
Beiträge
2,306
Punkte für Reaktionen
17
Punkte
38
Wenn Du die DSL-Treiber entfernst, kann das auch nicht funktionieren.
Code:
FREETZ_REMOVE_ANNEX_A_FIRMWARE=y
FREETZ_REMOVE_ANNEX_B_FIRMWARE=y
Du musst den für Deinen notwendigen Anschluss notwendigen DSL-Treiber (in DE: Annex B) drinnen lassen, den anderen kann man gefahrlos entfernen (in DE wird normalerweise kein Annex A geschaltet).
 
Zuletzt bearbeitet:

maceis

Mitglied
Mitglied seit
9 Apr 2006
Beiträge
660
Punkte für Reaktionen
4
Punkte
18
Vielen Dank für den Hinweis.
Ich dachte Annex braucht man nur für Telefon über Festnetz.

Ich hab zwischenzeitlich eine funktionierende FW gebaut, bei der ich mal auf Verdacht auch alle Patches weggelassen habe.
Bei der v3 muss man ja nicht so knickerig sein mit dem Platz.

Bleibt die Frage, warum das Image für die 7270-v1 (ohne Veränderung) plötzlich nicht mehr ging. Da war auch Annex B noch drin.
Komisch war dabei, dass es über den Tag verteilt zwei mal doch noch eine DSL-Verbindung aufgebaut hatte.
Einmal ganz kurz, einmal über ca. 2 Stunden.