Mit Subversion 1.8 keine Verbindung zu freetz.org/trunk

peterhacke

Neuer User
Mitglied seit
12 Mai 2012
Beiträge
74
Punkte für Reaktionen
0
Punkte
6
Hallo!

Bei meiner Distribution (Arch) kam Subversion 1.8.0 als Update. Seitdem ist kein Zugriff mehr auf http://svn.freetz.org/trunk möglich. Weder per checkout oder als update.

Als Fehler kommt:

svn: E175002: OPTIONS-Anfrage auf »/trunk« schlug fehl: 408 Request Timeout

Das Problem liegt nur bei Freetz vor, daher auch mein Frage in diesem Forum.

Liegt ein Konfigurationsproblem meinerseits vor?


Grüße
 

roadman17

Mitglied
Mitglied seit
8 Apr 2008
Beiträge
336
Punkte für Reaktionen
1
Punkte
0
Habe es gerade getestet. Es scheint wohl generell an Subversion 1.8 zu liegen.

Zuerst kommt wird folgende Anfrage an den Server geschickt,
Code:
OPTIONS /trunk HTTP/1.1
Host: svn.freetz.org
User-Agent: SVN/1.8.0 (x86_64-apple-darwin11.4.2) serf/1.2.1
Content-Type: text/xml
Connection: keep-alive
Accept-Encoding: gzip
DAV: http://subversion.tigris.org/xmlns/dav/svn/depth
DAV: http://subversion.tigris.org/xmlns/dav/svn/mergeinfo
DAV: http://subversion.tigris.org/xmlns/dav/svn/log-revprops
Content-Length: 131

<?xml version="1.0" encoding="utf-8"?><D:options xmlns:D="DAV:"><D:activity-collection-set></D:activity-collection-set></D:options>
Worauf die nachfolgende Anfrage zu deinen besagten Fehler führt:
Code:
OPTIONS /trunk HTTP/1.1
Host: svn.freetz.org
User-Agent: SVN/1.8.0 (x86_64-apple-darwin11.4.2) serf/1.2.1
Content-Type: text/xml
Accept-Encoding: gzip
DAV: http://subversion.tigris.org/xmlns/dav/svn/depth
DAV: http://subversion.tigris.org/xmlns/dav/svn/mergeinfo
DAV: http://subversion.tigris.org/xmlns/dav/svn/log-revprops
Transfer-Encoding: chunked

<?xml version="1.0" encoding="utf-8"?><D:options xmlns:D="DAV:"><D:activity-collection-set></D:activity-collection-set></D:options>
Benutz einfach einen älteren SVN-Clienten, bis das Problem behoben wird.
 

peterhacke

Neuer User
Mitglied seit
12 Mai 2012
Beiträge
74
Punkte für Reaktionen
0
Punkte
6
Gut, weiss ich bescheid. Konnte ich mir ja schon denken, wollte aber lieber sicher gehen.

Danke schön fürs Nachkontrollieren.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hm, mein Ubuntu 13.04 hat noch 1.7, daher ist es mir bisher nicht aufgefallen. Ich fürchte, dass ich für das ubuntu 10.04 auf freetz.org kein subversion 1.8 bekomme. Selbst bauen ist wegen Apache mod dav AVN hässlich.
 

peterhacke

Neuer User
Mitglied seit
12 Mai 2012
Beiträge
74
Punkte für Reaktionen
0
Punkte
6
Dann wars ja gut, dass ich mich gemeldet habe. War schon verwundert, dass ich der einzigste mit dem Problem bin. Ich hab jetzt subversion erstmal vom update ausgeschlossen. Nicht schön, aber auch nicht so dramatisch.

Grüße
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Ich hab mich mal umgeschaut und wie erwartet gibt es für Lucid nichts fertiges.

Auch ist mir nicht klar, ob das Problem jetzt an der verwendeten Version 1.7.7 des libapache2-svn Moduls liegt oder an der Konfiguration. Gibts irgendwelche Vorschläge in welche Richtung ich mich umsehen soll?

Gruß
Oliver
 

peterhacke

Neuer User
Mitglied seit
12 Mai 2012
Beiträge
74
Punkte für Reaktionen
0
Punkte
6
Ich kann nur soviel sagen, dass auf meiner Fritzbox noch suberversion 1.7 läuft und darauf kann ich zugreifen. Also scheint es ja nicht nur rein an subversion zu liegen. Aber ich kann dir leider nicht weiterhelfen :(


Grüße
 
Zuletzt bearbeitet:

roadman17

Mitglied
Mitglied seit
8 Apr 2008
Beiträge
336
Punkte für Reaktionen
1
Punkte
0
Vielleicht liegt es an Transfer-Encoding: chunked und der Server oder Proxy unterstützt diese Übertragungsart nicht.

Der Server antwortet nämlich mit
Code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>408 Request Time-out</title>
</head><body>
<h1>Request Time-out</h1>
<p>Server timeout waiting for the HTTP request from the client.</p>
<hr>
<address>Apache/2.2.14 (Ubuntu) Server at svn.freetz.org Port 8080</address>
</body></html>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>408 Request Time-out</title>
</head><body>
<h1>Request Time-out</h1>
<p>Your browser sent a request that this server could not understand.<br />
</p>
<hr>
<address>Apache/2.2.14 (Ubuntu) Server at svn.freetz.org Port 8080</address>
</body></html>
 

uli.e

Neuer User
Mitglied seit
30 Apr 2007
Beiträge
22
Punkte für Reaktionen
0
Punkte
0
Seit dem Update auf OpenSUSE 13.1 habe ich das Problem auch, hier ist jetzt Version 1.8.4 aktuell
 

er13

Aktives Mitglied
Mitglied seit
20 Dez 2005
Beiträge
1,030
Punkte für Reaktionen
31
Punkte
48
Kann ich leider bestätigen. Mit 1.8.5:
Code:
Updating '.':
svn: E175002: Unable to connect to a repository at URL 'http://svn.freetz.org/trunk'
svn: E175002: OPTIONS request on '/trunk' failed: 408 Request Timeout
Mit 1.7.14 geht's problemlos.

Edit: Angeblich soll es nach dieser Anpassung funktionieren.

Edit2: Und wo bekommt man subversion 1.8 für Ubuntu? Antwort: hier. Unabhängig von der tatsächlich verwendeten Ubuntu Version sollte die .list-Datei precise referenzieren.
 
Zuletzt bearbeitet:

zaptac

Neuer User
Mitglied seit
16 Mai 2006
Beiträge
31
Punkte für Reaktionen
0
Punkte
6
Habe das gleiche Problem (Fedora) und folgende Workarounds gefunden:

Olistudent hat einen Clone des Repos auf Github (laut Wiki ist das aber unsupported):
Code:
git clone [email][email protected]:olistudent/freetz.git[/email] freetz-devel
Alternativ kann man sich ein 1.7er Static Binary bauen wie in https://retracile.net/blog/2012/08/23/21.00 beschrieben.
Auf Fedora 20 ist libneon zu neu, deshalb musste ich das extra bauen: http://www.isnull.com.ar/2012/07/solved-svn-e170000-unrecognized-url.html
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Das git repository wird direkt von freetz.org gesynct und sollte daher immer aktuell sein...

Ich habe schon probiert das Problem zu beheben, habe es aber nicht geschafft. Problem ist scheinbar, dass wir den lighttpd als Proxy für Apache + mod_dav_svn verwenden. Auf dem Host läuft ein Ubuntu Lucid. Dafür gibt es kein subversion 1.8 + Apache mod_dav_svn

Gruß
Oliver

edit: Workaround gefunden. lighttpd arbeitet nur noch mit HTTP/1.0. Auswirkungen sind mir nicht klar...
 
Zuletzt bearbeitet:

kuppe

Neuer User
Mitglied seit
15 Sep 2008
Beiträge
52
Punkte für Reaktionen
0
Punkte
0
Hallo,
ich verwende seit kurzen Fedora 20 64bit. Dabei bin ich natürlich sofort über obiges Problem gefallen :(
Beitrag #8 hat mich dann auf die Lösung gebracht:
In die Datei ~/.subversion/servers muss einfach folgender Eintrag:
Code:
[global]
http-chunked-requests = no
Vielleicht könnte das ja mal mit ins Wiki http://freetz.org/wiki/common/source_code geschrieben werden.

Viele Grüße, kuppe
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Komisch, ich dachte eigentlich, dass das Problem gelöst sei. Bei dir geht es ohne den Schalter aber immer noch nicht? Gleiche Fehlermeldung wie oben? Welche subversion Version hast du?
 

kuppe

Neuer User
Mitglied seit
15 Sep 2008
Beiträge
52
Punkte für Reaktionen
0
Punkte
0
Hallo,

stimmt es geht bei mir nicht ohne den beschriebenen Schalter.

Ich habe aber mal weiter gesucht:
Ich verwende svn 1.8.8 (aus dem F20 Repo). Zuerst dachte ich, daß es an meiner 64bit-Version liegt (Remote habe ich auf Arbeit "nur" ein F20 32bit zur Verfügung). Auf Arbeit ging´s, zu Hause nicht. Also habe ich meinen 64bit Notebook, wo es nicht funktioniert mit auf Arbeit genommen. Und: Es geht!
Das Problem liegt also nicht am svn, dessen Version oder der verwendeten Distribution, sondern am Übertragungsweg.
Zu Hause hänge ich über Vodafone-Mobilfunk (ja, im Jahre 2014 gibt es in einer mittleren Großstadt, Chemnitz, noch kein DSL) am Internet. Bei Vodafone jagt man seine Pakete durch einen transparenten Proxy (damit die Obrigkeit auch alles problemlos mitschnüffeln kann?). Der lässt sich zwar konfigurieren (alle "Optimierungen" aus), aber eben nicht ausschalten. Und dieser Vodafone-Proxy unterstützt die chunked-Übertragung scheinbar nicht.
Heute abend versuche ich das ganze nochmals von zu Hause, aber durch einen VPN-Tunnel über den VPN-Concentrator bei mir auf Arbeit. Da gibt´s dann keinen Zwangs-Proxy.

Viele Grüße, kuppe

Ergebnis VPN-Test:
Ich habe das ganze jetzt ohne obige Schalter nochmal von zu Hause getestet:

  • direkte Verbindung (Vodafone-Zwangs-Proxy)
    -> svn: E175002: Unable to connect to a repository at URL 'http://svn.freetz.org/trunk'
    svn: E175002: OPTIONS-Anfrage auf »/trunk« schlug fehl: 408 Request Time-out

  • Verbindung via VPN-Tunnel (ohne Proxy)
    -> Aktualisiere ».«:
    Revision 11938.
Da schmeißt mir also Vodafone einen Knüppel zwischen die Füße. Ich hoffe, die verändern nicht noch mehr...
 
Zuletzt bearbeitet:

metalhead1976

Neuer User
Mitglied seit
6 Jan 2007
Beiträge
39
Punkte für Reaktionen
0
Punkte
6
wollte bei mir mit Freetz-Linux auch eben svn up machen und bekomme auch einen Fehler angezeigt.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Danke für die Info. Wenn du Hilfe brauchst sag bescheid...
 

metalhead1976

Neuer User
Mitglied seit
6 Jan 2007
Beiträge
39
Punkte für Reaktionen
0
Punkte
6
Ja sehr gerne. Ohne Hilfe komme ich doch nicht weiter.
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,022
Beiträge
2,041,706
Mitglieder
353,326
Neuestes Mitglied
Taimi01