.titleBar { margin-bottom: 5px!important; }

mod 0.52 macht WLAN kaputt?

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von self, 18 März 2005.

  1. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    ich habe meine Fritzbox SL WLAN mit der fritz.box_sl_wlan.09.03.22.image + mod 0.52 geflasht. Den Box Typ habe ich im Mod-Script entsprechend gesetzt. Alles ging wunderbar - SSH Zugang vom Internet aus + etherwake ist schon was feines.

    Leider musste ich heute feststellen, dass die WLAN Led nicht leuchtet und das WLAN auch nicht mehr gefunden wird :(

    Ich habe dann mal Wild die Standard-Dienste gestartet um zu testen ob's dann vielleicht geht:

    /sbin/multid
    2005-03-18 15:14:29 multid: dyncfg: libar7cfg.so loaded for Dyn_AR7CFG_struct
    Mar 18 15:14:29 multid[553]: dyncfg: libar7cfg.so loaded for Dyn_AR7CFG_struct
    2005-03-18 15:14:29 multid: startup (Jan 20 2005 14:50:07)
    Mar 18 15:14:29 multid[553]: startup (Jan 20 2005 14:50:07)
    2005-03-18 15:14:29 multid: dyncfg: libar7cfg.so unloaded
    Mar 18 15:14:29 multid[553]: dyncfg: libar7cfg.so unloaded
    # Mar 18 15:14:29 multid[555]: aready running (270), exit
    Mar 18 15:14:29 multid[555]: 15:14:29 [Segmentation fault] /sbin/multid(555) CRA
    SHED at 2ae56720 (?) accessing 0x2ae56720
    Mar 18 15:14:29 multid[555]: 15:14:29 [Segmentation fault] /sbin/multid(555) CRA
    SHED at 2ac0d8f4 (/lib/libboxlib.so.0.0.0 at 0000d8f4) accessing 0x2ae56724
    Mar 18 15:14:29 multid[555]: [bt] Number of functions: (1)
    Mar 18 15:14:29 multid[555]: [bt] 2ac0d834+184 (/lib/libboxlib.so.0.0.0 at 0000d
    834)


    Das Segmentation fault macht mir irgendwie Angst...


    Wenn ich in der WebOberfläche WLAN deaktiviere und wieder aktiviere geht auch irgendwann sogar die WLAN Lampe an und das Netz wird gefunden. Verbinden klappt trotzdem nicht (ging vorher) .. scheinbar wird keine Netzwerkadresse zugewiesen oder so.

    Ideen?

    Grüße, Alex
     
  2. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Alex,

    der Segementation fault hört sich wirklich nicht gut an. Aber... ich habe gerade bei mir mal getestet wie es mit einem doppelt gestartetem multid aussieht: CRASH..

    Also: versuch mal mit "multid -s" den alten Daemon zu stoppen und dann multid neu zu starten. Dann tritt kein "segmentation fault "Fehler auf.

    Wieviel Hauptspeicher hat die SL-WLAN eigentlich ? ( Befehl "top" => output ) Kommentar in etc/init.d/rc.net:
    reload)
    # NOTE: on the SL (8MB RAM) this is not used!
    # The ctlmgr stops and starts the processes by itself!

    Ich könnte mir vorstellen, dass mit gestartetem telnetd, crond und dropbear eng wird. Versuch mal die ProzessID von crond und dropbear mit "ps" heraus zu finden und
    diese Prozesse mit "kill <prozessid>" zu beenden.

    Dann bitte mit: /etc/init.d/rc.net wlanstop ; /etc/init.d/rc.net wlanstart
    Wlan restarten und die Verbindung noch mal zu versuchen.

    Haveaniceday
     
  3. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    danke für die schnelle Antwort :)

    Multid -s ; Multid hat geklappt ...

    Das sagt mein Top:

    Mem: 14184K used, 492K free, 0K shrd, 184K buff, 6100K cached

    Ich habe telnetd und crond via killall beseitigt. Dannach war zwar in top nicht mehr ram frei, aber das liegt wohl (hoffentlich) an der dyn. Speicherverwaltung des Linux.

    Nach dem WLAN Restart ging es trotzdem nicht. Gleiches Problem: Netz wird zwar erkannt, aber dann keine Adresse zugewiesen. Zumindest scheint Windows keine zu bekommen.

    Was macht eigentlich der dsld ?

    Irgendwie scheint was mit dem DHCP oder so nicht zu stimmen.

    Das Log sagt übrigens:

    19.03.05 12:37:12 WLAN-Station angemeldet. Name: ####, IP-Adresse: 192.168.178.25, MAC-Adresse: ##:##:##:##:##:##, Geschwindigkeit 11 MBit/s.

    (statt den # steht natürlich schon was sinnvolles*G* aber man is ja paranoid *g*)

    Ideas ?

    Grüße, Alex
     
  4. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo nochmal!

    ich habe jetzt etwas RAM geschaffen indem ich recht wild einige Prozesse terminiert habe. Aber mir ist aufgefallen, dass crond und dropbear nicht wirklich viel Speicher in Anspruch nehmen. Erst websrv hat sich wirklich gelohnt :) Aber das verhalten ist das selbe. Dann habe ich versucht auf dem Laptop (die WLAN Station) eine Fest IP zu setzen. Dann wartet Windows zwar nicht mehr bis eine zugewiesen wird, aber ins Internet komm ich dann trotzdem nicht :(

    Grüße, Alex
     
  5. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Self,

    ich werde mal versuchen meinen bisher ungenutzten Siemens WLAN Adapter unter Linux
    zum Laufen zu bekommen. Dann werde ich mal mit meiner Fon WLAN ein paar Trace-Szenarien auszuprobieren.
    Im Moment habe ich keine Idee warum das ganze mit mod-* nicht geht. Die Bibliotheken sollten bis auf Erweiterungen identisch mit denen von AVM sein.

    Haveaniceday
     
  6. MattisBLN

    MattisBLN Neuer User

    Registriert seit:
    15 März 2005
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Berlin
    Was heisst "Windows startet nicht mehr, bis eine zugewiesen wird? Wenn du unter Windows eine feste IP vergibst (aus obigem Log würde ich sagen 192.168.178.25, dann musst du auch Gateway und DNS fest eintragen, vermutlich 192.168.175.1 (IP der Fritz! Box), damit Internet funktioniert.

    Ach so, und ohne dsld auf der Fritzbox geht Internet sowieso nicht, dsld ist der DSL-Dienst auf der Box...

    Greetings, Matthias
     
  7. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    normalerweise ist DHCP welches auch bei den über Netzwerk-Kabel verbundenen PCs wunderbar klappt, nur eben nicht über WLAN. Testweise hatte ich dann o.g. IP und als DNS/GW jeweils 192.168.178.1 eingetragen. Dann funktioniert's aber trotzdem nicht :(

    Grüße, Alex
     
  8. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hi.
    Hast du mal mit netstumbler geguckt, ob der was von der Fritz sieht?
    Oder bekommst du nur keine IP?
    Poste doch mal ein Log vom /etc/ini.d/rc.net wlanstart

    Code:
    kernel: tiwlan0 device is de-activated
    kernel: lan: port 3(tiwlan0) entering disabled state
    multid[552]: interface tiwlan0 gone.
    kernel: removing proc dir mgmt
    kernel: removing proc dir bit
    kernel: removing proc dir wlan
    kernel: dda proc: finish removing proc entries
    kernel: dda: cleanup finish succesfully ,good-bye.
    kernel: 4521951: mainSm unloaded !!!
    kernel: 4521952: WDRV_MGMT: mgmtSm unloaded !!!
    kernel: 4521952: RX unloaded !!!
    kernel: 4521952: TX unloaded !!!
    kernel: 4521952: WoneBalance unloaded !!!
    kernel: remote_vlynq_dev_reset_ctrl(0,  IN_RESET)
    kernel: Resetting the remote device.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: remote_vlynq_dev_reset_ctrl(0,  OUT_OF_RESET)
    kernel: Un-resetting the remote device.
    kernel: vlynq_config_dev_init: reset device perGPIO Pin
    kernel: vlynq_config_dev_init: setup Registers
    kernel: set local_mem.RxSize to 0x2000000
    kernel: About to re-init the VLYNQ.
    kernel: vlynq_config_dev_init: success
    kernel: vlynq init done
    kernel: Re-initialized the VLYNQ.
    kernel: Read the data. eafffffe.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: 4521953: Freed MSDUs count = 0
    kernel: 4521953: Freed MSDUs count = 0
    kernel: 4521953: DB unloaded !!!
    kernel: lan: port 3(tiwlan0) entering disabled state
    kernel: device tiwlan0 left promiscuous mode
    kernel: request_module(tiwlan0)
    kernel: request_module(tiwlan0)
    kernel: request_module(tiwlan0)
    cltmgr[261]: Now doing actions: ActionMask is 0x20
    kernel: request_module(tiwlan0)
    multid[552]: interface tiwlan0 new.
    kernel: 4522996: 802.11d is disabled
    kernel: 4522996: 802.11h is disabled
    kernel: 4522996: Configuration succeeded !!!
    kernel: 4522996: WLAN driver database is up
    kernel: remote_vlynq_dev_reset_ctrl(0,  IN_RESET)
    kernel: Resetting the remote device.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: remote_vlynq_dev_reset_ctrl(0,  OUT_OF_RESET)
    kernel: Un-resetting the remote device.
    kernel: vlynq_config_dev_init: reset device perGPIO Pin
    kernel: vlynq_config_dev_init: setup Registers
    kernel: set local_mem.RxSize to 0x2000000
    kernel: About to re-init the VLYNQ.
    kernel: vlynq_config_dev_init: success
    kernel: vlynq init done
    kernel: Re-initialized the VLYNQ.
    kernel: Read the data. eafffffe.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: 4522998:
    kernel:
    kernel: Hidden SSID is activated
    kernel: 4523007: ----------------------------------------------------------------
    kernel: 4523007:             ACX Firmaware Version = Rev 1.6.0.24
    kernel: 4523007: ----------------------------------------------------------------
    kernel: 4523010: WLAN HAL layer is up
    kernel: 4523010: BssBridge is up
    kernel: 4523010: Mgmt is up
    kernel: 4523011: Rx is up
    kernel: 4523011: Tx is up
    kernel: 4523011: MemMngr is up
    kernel: 4523011: main state machine is up
    kernel: 4523031: WDRV_MAINSM: WLAN Driver initialized successfully
    kernel:
    kernel: 4523031: WDRV_4X: 4x Disabled
    kernel: 4523031: WDRV_4X: Concatenation Disabled
    kernel: 4523031: WDRV_4X: Ack Emulation Disabled
    kernel: 4523031: whal_apiStartBss: Enable Tx, Rx and Start the Bss
    kernel: 4523032: ----------------------------------------------------------------
    kernel: 4523032: ----------------------------------------------------------------
    kernel: 4523032:   START BSS, SSID=Test, BSSID=00-04-0E-1E-xx-xx
    kernel: 4523032: ----------------------------------------------------------------
    kernel: 4523032: ----------------------------------------------------------------
    kernel: 4523033:  AP Power Level = 1
    kernel: 4523033:  Regulatory Domain = ETSI
    kernel: 4523033:           Net[0] : Channel=3
    kernel: 4523033: ----------------------------------------------------------------
    kernel: 4523034: FW Watchdog is Enabled
    kernel: dda: tiwlan0 in initializing Succeeded wireless extensions: ret = 0
    multid[552]: interface tiwlan0 up.
    kernel: tiwlan0 device is activated
    kernel: device tiwlan0 entered promiscuous mode
    kernel: lan: port 3(tiwlan0) entering learning state
    multid[552]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    multid[552]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    multid[552]: interface tiwlan0 down.
    kernel: tiwlan0 device is de-activated
    kernel: lan: port 3(tiwlan0) entering disabled state
    multid[552]: interface tiwlan0 gone.
    kernel: removing proc dir mgmt
    kernel: removing proc dir bit
    kernel: removing proc dir wlan
    kernel: dda proc: finish removing proc entries
    kernel: dda: cleanup finish succesfully ,good-bye.
    kernel: 4523083: mainSm unloaded !!!
    kernel: 4523083: WDRV_MGMT: mgmtSm unloaded !!!
    kernel: 4523083: RX unloaded !!!
    kernel: 4523083: TX unloaded !!!
    kernel: 4523083: WoneBalance unloaded !!!
    kernel: remote_vlynq_dev_reset_ctrl(0,  IN_RESET)
    kernel: Resetting the remote device.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: remote_vlynq_dev_reset_ctrl(0,  OUT_OF_RESET)
    kernel: Un-resetting the remote device.
    kernel: vlynq_config_dev_init: reset device perGPIO Pin
    kernel: vlynq_config_dev_init: setup Registers
    kernel: set local_mem.RxSize to 0x2000000
    kernel: About to re-init the VLYNQ.
    kernel: vlynq_config_dev_init: success
    kernel: vlynq init done
    kernel: Re-initialized the VLYNQ.
    kernel: Read the data. eafffffe.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: 4523085: Freed MSDUs count = 0
    kernel: 4523085: Freed MSDUs count = 0
    kernel: 4523085: DB unloaded !!!
    kernel: lan: port 3(tiwlan0) entering disabled state
    kernel: device tiwlan0 left promiscuous mode
    multid[552]: interface tiwlan0 new.
    kernel: 4523183: 802.11d is disabled
    kernel: 4523183: 802.11h is disabled
    kernel: 4523183: Configuration succeeded !!!
    kernel: 4523183: WLAN driver database is up
    kernel: remote_vlynq_dev_reset_ctrl(0,  IN_RESET)
    kernel: Resetting the remote device.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: remote_vlynq_dev_reset_ctrl(0,  OUT_OF_RESET)
    kernel: Un-resetting the remote device.
    kernel: vlynq_config_dev_init: reset device perGPIO Pin
    kernel: vlynq_config_dev_init: setup Registers
    kernel: set local_mem.RxSize to 0x2000000
    kernel: About to re-init the VLYNQ.
    kernel: vlynq_config_dev_init: success
    kernel: vlynq init done
    kernel: Re-initialized the VLYNQ.
    kernel: Read the data. eafffffe.
    kernel: remote_vlynq_dev_reset_ctrl: done
    kernel: 4523185:
    kernel:
    kernel: Hidden SSID is activated
    kernel: 4523194: ----------------------------------------------------------------
    kernel: 4523194:             ACX Firmaware Version = Rev 1.6.0.24
    kernel: 4523194: ----------------------------------------------------------------
    kernel: 4523197: WLAN HAL layer is up
    kernel: 4523197: BssBridge is up
    kernel: 4523197: Mgmt is up
    kernel: 4523197: Rx is up
    kernel: 4523198: Tx is up
    kernel: 4523198: MemMngr is up
    kernel: 4523198: main state machine is up
    kernel: 4523218: WDRV_MAINSM: WLAN Driver initialized successfully
    kernel:
    kernel: 4523218: WDRV_4X: 4x Disabled
    kernel: 4523218: WDRV_4X: Concatenation Disabled
    kernel: 4523218: WDRV_4X: Ack Emulation Disabled
    kernel: 4523218: whal_apiStartBss: Enable Tx, Rx and Start the Bss
    kernel: 4523218: ----------------------------------------------------------------
    kernel: 4523219: ----------------------------------------------------------------
    kernel: 4523219:   START BSS, SSID=Test, BSSID=00-04-0E-1E-xx-xx
    kernel: 4523219: ----------------------------------------------------------------
    kernel: 4523219: ----------------------------------------------------------------
    kernel: 4523219:  AP Power Level = 1
    kernel: 4523220:  Regulatory Domain = ETSI
    kernel: 4523220:           Net[0] : Channel=3
    kernel: 4523220: ----------------------------------------------------------------
    kernel: 4523221: FW Watchdog is Enabled
    kernel: dda: tiwlan0 in initializing Succeeded wireless extensions: ret = 0
    multid[552]: interface tiwlan0 up.
    kernel: tiwlan0 device is activated
    kernel: device tiwlan0 entered promiscuous mode
    kernel: lan: port 3(tiwlan0) entering learning state
    multid[552]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    multid[552]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    kernel: lan: port 3(tiwlan0) entering forwarding state
    kernel: lan: topology change detected, propagating
    
    MfG Oliver
     
  9. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Netstumbler habe ich nicht probiert - aber wie gesagt wird das Netz nach nem WLANStart generell angezeigt - nur IP und Konnektivität gibt's keine.

    Hier das Log:
    Code:
    # /etc/init.d/rc.net wlanstop
    Mar 23 15:08:35 multid[270]: interface tiwlan0 down.
    killing WLAN USERMODE 238
    Segmentation fault
    
    Code:
    # /etc/init.d/rc.net wlanstart
    MAC WLAN:       00:xx:xx:xx:xx:xx
    Using /lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/wlan/tiap.o
    Warning: loading tiap will taint the kernel: non-GPL license -
    (C) Copyright 2003, 2004, Texas Instruments, Inc
    (C) Copyright 2004, AVM
    
      See http://www.tux.org/lkml/#export-tainted for information about tainted modu
    les
    insmod: init_module: tiap: No such device
    socket /var/tmp/wpaauth successfully created, wpa module waits for configuration
    WSTART - version for the WLAN using tiap.o and wpa_authenticator
    wstart: config ok(1)
    wpa_wait_for_cfg: successfully received configuration
    cfg type.sec.type=1
    send hello:error -1 in 'ipc_connect_buf_write'. trying again...
    Wstart - made configure_wpa_authenticator
    USER MAC:00 04 0e 2d d4 c9
    mnet
    AVM - radius support removed!
    wlan started (OK)
    Wstart - made configure_and_start_ap_driver
    WSTART: done(0)
    WLAN is enabled
    SIOCSIFFLAGS: No such device
    # WPA MODULE:setting default key id for index = 2.
    
    Kannst damit jemand was anfangen?

    Vielen Dank im vorraus!

    Grüße, Alex
     
  10. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Na, das kommt mir doch sehr komsich vor:
    insmod: init_module: tiap: No such device

    Was sagt die Box denn bei:
    lsmod
    insmod tiap
    rmmod tiap

    MfG Oliver

    edit: Gibt es einen Grund warum du nicht die neueste Firmware drauf hast? (09.03.29)
     
  11. traxanos

    traxanos Mitglied

    Registriert seit:
    15 Juli 2004
    Beiträge:
    486
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    es scheint der tiap zu sein. da kein ram da war wurde der nicht gebootet

    insmod tiap und dann wlanrestop/start


    [EDIT]
    hab das fenster zulange aufgehabt bis ich geantwortet habe.
    da war einfach jemand schneller ;)
     
  12. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Alex,

    [s:e513f5928c]hat etwas gedauert. Ich musste meinem Linux erst per ndiswrapper den USB-Adapter erklären.
    Also bei mir geht das Wlan auch nach der Modifikation.

    Folgende Config habe ich genutzt:
    - SSID versteckt
    - Stationen dürfen untereinander kommunizieren
    - unter System => Netzwerkeinstellungen => IP-Adressen => aus: alle im selben Netzwerk
    - dhcpd an ( WLAN: 192.168.182.1 )

    Die Startmeldungen sehen wie unten aus. Da die SL wenig Speicher hat versuch mal:
    - killall dropbear
    - killall bftpd
    - killall websrv ( Sollte kurz ohne Webserver gehen...)
    - killall crond

    Und dann:
    /etc/init.d/rc.net wlanstop
    /etc/init.d/rc.net wlanstart

    => Dann ein "ping", ob das Netzwerk geht.
    => Evtl. "websrv" wieder starten und auf die WLAN-Startseite gehen.
    [/s:e513f5928c]
    @Traxanos, ich bin noch langsamer...

    Thema laden von dem Kernelmodul: das ist eine SL-WLAN
    Könnte sein: Dort ist evtl. die Startreihenfolge anders ( nicht für mod-0.53 geeignet ? )

    Ich schau noch mal tiefer in das original Image.


    Leider besitze ich keine SL-WLAN zum Testen

    Haveaniceday

     
  13. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Mein Notebook muckt leider gerade etwas rum, weshalb ich noch nicht fertig testen konnte..
    Vielen Dank auf alle Fälle schon mal für eure Tipps!
    Das tiap Modul scheint wirklich nicht geladen worden zu sein.
    Wie kann ich denn verhindern, dass telnetd, ftp und crond beim starten geladen werden? Diese Dienst Nutze ich sowieso nicht und der frei gewordene Speicher müsste ja dann für das tiap Modul ausreichen?

    Grüße, Alex
     
  14. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    aaaaalso:

    insmod tiap sieht schlecht aus:

    Code:
    # insmod tiap
    Using /lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/wlan/tiap.o
    Warning: loading tiap will taint the kernel: non-GPL license -
    (C) Copyright 2003, 2004, Texas Instruments, Inc
    (C) Copyright 2004, AVM
    
      See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    linsmod: init_module: tiap: No such device
    # insmod tiap
    Using /lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/wlan/tiap.o
    Warning: loading tiap will taint the kernel: non-GPL license -
    (C) Copyright 2003, 2004, Texas Instruments, Inc
    (C) Copyright 2004, AVM
    
      See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    insmod: init_module: tiap: No such device
    
    ein wlanstop/wlanstart bringt dann nochmal den gleichen Fehler :(

    Interessant fand ich auch die Consolenmeldung während ich versucht habe mich ins WLAN einzuklinken:

    # wpa_input : WPA is not ready yet!
    wpa_input : WPA is not ready yet!
    wpa_input : WPA is not ready yet!
    wpa_input : WPA is not ready yet!
    wpa_input : WPA is not ready yet!


    rmmod tiap

    dann kommt:

    Code:
    # lsmod
    Module                  Size  Used by    Tainted: P
    nfs                    87480   0 (unused)
    lockd                  59132   0 [nfs]
    sunrpc                 74128   0 [nfs lockd]
    tiatm                 110972   1
    avalanche_usb          39916   1
    avalanche_cpmac        74908   1
    avalanche_vlynq        12016   0 (unused)
    avm                    35088  13 [tiap tiatm avalanche_usb avalanche_cpmac]
    
    und nach insmod tiap exakt das selbe.

    Grüße, Alex
     
  15. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Mach mal das wlan im Webinterface aus.
    Dann Neustart. Jetzt sollte nix vom tiap zu sehen sein. (lsmod)
    Jetzt ein "insmod tiap". ???
    Was mir auffällt sind die nfs-module. Wenn du das Image selber bauen kannst, dann mach die mal raus. (nfs, lockd, sunrpc)
    Die werden im mod-52 in der rc.S geladen.

    MfG Oliver
     
  16. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Self,

    kannst mir mal ne emailadresse zusenden. Dann bereite ich mal etwas vor.

    Haveaniceday
     
  17. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kleiner Update zwischendurch. Das Ram auf der SL Wlan ist recht klein.
    mit gestartetem dropbear, crond telnetd, geladenem nfs,lock,sunrpc
    ist wahrscheinlich nicht genug Platz für wlan... Das Kernelmodul für
    WLAN benötigt > 700kB beim Laden.

    Ich bin mit Alex am Testen.

    => mod-0.5x startet zu viel für eine SL-WLAN

    Bis bald,

    haveaniceday
     
  18. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    noch ein Update:

    nach einigem Rumprobieren habe ich es geschafft das WLAN zum laufen zu bekommen, WENN websrv nicht läuft - ich hätte aber gerne WLAN & SSH & Weboberfläche .. man is ja anspruchsvoll :)

    Ich habe es geschafft den mini_httpd dazu zu bewegen die Weboberfläche anzuzeigen (in /var installiert):

    /var/mini_httpd-1.19 # ./mini_httpd -u root -c cgi-bin/* -d /usr/www

    Auf websrv kann man dann verzichten und da der mini_httpd viel weniger RAM als websrv braucht funktionierte sogar das WLAN!

    Dummerweise ist der mini_httpd natürlich nach dem Reboot weg - ich werde jetzt versuchen diesen in das Image direkt zu packen ...

    Drückt mir die Daumen ;)

    Grüße, Alex
     
  19. self

    self Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    bei der FritzBox SL WLAN wird's Speichertechnisch mit den ganzen Modifikationen ziemlich knapp...

    Was ich wollte: PC via Internet per etherwake aufwecken, dann VNC per SSH Tunnel nutzen

    Ich habe länger gebastelt. Dabei ist folgendes rausgekommen:

    - websrv durch mini_httpd ersetzt -> benötigt wesentlich weniger RAM
    - WLAN funktioniert trotzdem nicht wenn es beim Boot aktiviert ist -> deshalb: automatisches deaktivieren von WLAN beim booten -> WLAN muss nach Restart immer manuell über Webinterface aktiviert werden (ist bisher die praktikabelste Lösung die ich gefunden hab .. evtl. könnte man WLAN auch doch automatisch zu einem späteren Zeitpunkt beim Booten aktivieren)
    - ew Script

    Der ew Script akzeptiert einen Hostnamen statt der Macadresse - so ist es wesentlich einfacher einen bestimmten PC aufzuwecken (ist leider noch nicht ganz ausgereift)

    Falls jemand Interesse an dem Ergebnis hat, bitte das hier verkünden.

    Danke an alle die geholfen haben!

    Grüße, Alex
    www.self-soft.de