.titleBar { margin-bottom: 5px!important; }

mp3 Radiostream mit madplay geht plötzlich nicht mehr

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Golfballtaucher, 9 Feb. 2009.

  1. Golfballtaucher

    Golfballtaucher Neuer User

    Registriert seit:
    28 Jan. 2009
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich habe ein Problem mit moh, das mit noch den letzten Nerv raubt.

    Ich habe es erfolgreich geschafft, mit der Folgenden Konfiguration einen mp3 Radio Livestream als musiconhold einzuspielen:

    musiconhold.conf:
    Code:
    [radio]
    mode=custom
    application==/bin/sh  /etc/asterisk/radio.sh
    
    radio.sh:
    Code:
    #!/bin/bash
    wget -q -O - http://edge.live.mp3.mdn.newmedia.nacamar.net/swr3live/livestream.mp3  | /usr/bin/madplay -Q -z -o raw:- --mono -R 8000 -a -12 -
    
    Das hat alles auch wunderbar funktioniert. Allerdings jetzt plötzlich nicht mehr. Musiconhold wird nach dem starten sofort wieder gestoppt und zwar mit der Meldung "Request to schedule in the past".

    Hat jemand von Euch eine Idee. Mir scheint es so, als ob der mp3-Stream entweder endlos in eine Datei geschrieben wird, wobei ich keine Datei definiert habe, oder als ob in einen buffer geschrieben wird, der beim Reboot nicht geleert wird.

    Kann mir jemand von Euch weiterhelfen? Vielen Dank.
     
  2. Golfballtaucher

    Golfballtaucher Neuer User

    Registriert seit:
    28 Jan. 2009
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es hat sich etwas getan.

    Gestern ging der Radio Stream überraschenderweise wieder, allerdings nur für etwa 1 Minute. Dann wurde der Ton abgehackt übertragen bis er schließlich mit der folgenden Felgermeldung ganz stoppte:

    Code:
    [Feb  9 21:45:55] ERROR[5433] chan_capi_utils.c: CAPI error sending DATA_B3_REQ                ID=003 #0x3278 LEN=0022
      Controller/PLCI/NCCI            = 0x10101
      Data32                          = 0x823dbac
      DataLength                      = 0xa0
      DataHandle                      = 0x3261
      Flags                           = 0x0
      Data64                          = 0x0
     (NCCI=0x10101) (error=0x1103 The message could not be accepted because of a queue full condition !! The error code does not imply that CAPI cannot receive messages directed to another controller, PLCI or NCCI)
    
    Danach kam dann wieder die Meldung Request to schedule in the past.
    Kann einer von Euch damit etwas anfangen?