multid crash

bbock

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Hi,

ich habe folgendes Problem mit meiner FB 7390: Wenn ich einige Zeit im AVM GUI herumklicke, ist die Box nicht mehr erreichbar, kein Ping, nix. Hard Reset (Strom ziehen) hilft. Danach finde ich folgendes im /var/flash/crash.log:

Code:
[Segmentation fault] multid(12423) CRASHED at strcmp+0x4 (/lib/libc.so.0 at 00033a54) accessing 00000000 (?)
ze: 00000000 at: 7fb12fc0 v0: 2aab0200 v1: 0000006c
a0: 2aab3800 a1: 00000000 a2: 00000001 a3: 00000001
t0: 00000000 t1: 83ce7e60 t2: 00000000 t3: 00000001
t4: 00000001 t5: 86db11b4 t6: 000000f4 t7: 0040fcc8
s0: 2aab5500 s1: 00000000 s2: 2abb0000 s3: 004068c8
s4: 2aabb148 s5: 00000025 s6: 00438818 s7: 0044bfc0
t8: 00000000 t9: 2acd8a50 k0: 00000001 k1: 00000000
gp: 00453250 sp: 7fb14100 fp: 00438a7c ra: 0040614c
Code: 00000000  00000000  90830000 <90a20000> 24840001  14600003  24a50001  03e00008  00021023 
[bt] Number of functions: 5
[bt] (null)+0x406144 (multid at 00006144)
[bt] ((null)+0x406104)+0x40 (multid at 00006104)
[bt] ((null)+0x4068c8)+0x18 (multid at 000068c8)
[bt] routewatch_query+0x144 (/lib/libewnwlinux.so.2 at 0000e5ac)
[bt] main+0x2248 (multid at 0000da78)
Die Box läuft auf svn trunk r7728 / 84.05.05, das Problem habe ich aber auch schon mit älteren Revisions gehabt.

Meine .config: Anhang anzeigen config.txt

Bin für jeden Tipp dankbar.

Gruß,
Bernhard
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Sieht aus, als würde strcmp mit NULL als zweitem Parameter aufgerufen. Es stellt sich nur die Frage, warum. Leider sieht man nicht, wie die anderen Funktionen heißen, von denen der Aufruf kommt.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Mir fällt das dnsmasq Paket auf, das in der Vergangenheit schon öfter für Probleme mit dem multid gesorgt hat. Kannst du mal ein Image ohne dnsmasq testen bzw. dnsmasq anhalten und die Box neu starten.

Gruß
Oliver
 

bbock

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Beim Deaktivieren des dnsmasq ist die Box direkt gecrashed. Das spricht für Deine Vermutung. Mir ist die Box allerdings danach auch mit deaktiviertem dnsmasq in der AVM-GUI gecrashed, selbe Stelle im multid. Glaubst Du, es macht einen Unterschied wenn ich ein Image baue in dem der dnsmasq ganz ausgebaut ist im Gegensatz zu nur deaktivieren?

FREETZ_REPLACE_SSL_LIBS zu setzen hab ich übrigens auch schon probiert, gleiches Ergebnis. Daran scheint es nicht zu liegen...

Gruß
Bernhard
 

bbock

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Update: Ich habe jetzt ein Image ohne dnsmasq gebaut. Gleiches Problem. Die Ursache scheint also eine andere zu sein. Einen Crash im Freetz GUI konnte ich nicht reproduzieren.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
FREETZ_REPLACE_SSL_LIBS zu setzen hab ich übrigens auch schon probiert, gleiches Ergebnis. Daran scheint es nicht zu liegen...
Ich würde eher vermuten, dass ein Aktivieren der Option einen Crash verursacht. Die ist eigentlich für Boxen mit wenig Flash gedacht. Dass man überhaupt Pakete mit openssl nutzen kann.

Gruß
Oliver
 

bbock

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Verstehe. Irgendwelche anderen Ideen, was ich ausprobieren könnte?
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
235,892
Beiträge
2,067,345
Mitglieder
356,881
Neuestes Mitglied
LTH-doc