.titleBar { margin-bottom: 5px!important; }

MusicOnHold gibt keinen Laut von sich. [gelöst]

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Sheridan, 10 Okt. 2005.

  1. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hidiho an alle hier.

    Spiele mich gerade mit Asterisk in Form von Xorcom Rapid, also Debian Sarge und Asterisk 1.0.9 BRIstuffed-0.2.0-RC8h herrum. Soweit so gut, bisher lief das Ding auch ganz fein.
    Nuuuurrr... Jetzt wollte ich mal das MusicOnHold Feature von Asterisk ausprobieren. Ich hab schon alle erdenklichen Varianten versucht. Mit madplay mit mpg321, was bei Xorcom default ist, mit mpg123 und mit wav. Keine Chance. Sobald ich die Durchwahl wähle ...... kommt gar nichts. Auf dem Display meines Budgetone 102 läuft die Zeit und das wars. Stille.

    Die Config-Files sind eigentlich sehr unspektakulär:

    Code:
    extensions.conf:
    
    exten => 2002,1,Answer                                                 |;spanmap => 3,1,3
    ;exten => 2002,2,Playback(demo-thanks)                                 |;spanmap => 4,1,4
    exten => 2002,2,WaitMusicOnHold(30)                                    |
    exten => 2002,3,Hangup     
    
    Code:
    musiconhold.conf
    
    ;
    ; Music on hold class definitions
    ;
    [classes]
    ; for that to work you need the package asterisk-moh-wav:
    ;default => custom:/usr/share/asterisk/mohwav,/usr/bin/ast-cmd wav-player
    default => mp3:/usr/share/asterisk/mohmp3
    ;default => quietmp3:/usr/share/astehttp://www.signate.com/moh.phprisk/mohmp3
    ;loud => mp3:/usr/share/asterisk/mohmp3
    ;random => quietmp3:/usr/share/asterisk/mohmp3,-z
    ;unbuffered => mp3nb:/usr/share/asterisk/mohmp3
    ;quietunbuf => quietmp3nb:/usr/share/asterisk/mohmp3
    ; Note that the custom mode cannot handle escaped parameters (specifically embedded spaces)
    ;manual => custom:/usr/share/asterisk/mohmp
    greets & thanks
    Sheridan3,/usr/bin/mpg123 -q -r 8000 -f 8192 -b 2048 --mono -s
    
    Wollte das eigentlich mit einem kleinen Beispiel nur testen. Das verwendete MP3-File hab ich von diesem Link von voip-info.org: http://www.signate.com/moh.php


    Jetzt quäl und such ich mich schon den ganzen Tag und komme keinen Schritt weiter. Bei meinem Glück, hab ich sicher wieder irgend was wichtiges übersehen oder überlesen oder sonstwas.

    Vielen Dank auf jeden Fall schon mal für jeden Hilfe Versuch.

    greets & thanks
    Sheridan
     
  2. stefanmoench

    stefanmoench Guest

    sicher dass du mpg123 richtig installiert hast?! daran lags bei mir.
     
  3. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    was sagt denn die CLI bei einem ankommenden Anruf ?
     
  4. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Denke schon. Hab mir den Source der Version 059s runter geladen und dann mit make compiliert. make install hab ich allerdings nicht gemacht. Ist das unbedingt notwendig? Soweit ich festgestellt habe, erstellt der nur das binary mpg123. Hab unter /usr/bin den link auf das binary im src verzeichnis gesetzt.
    Möglicherweise ist das ein Fehler?

    Gibt's doch nicht das das aber auch mit dem madplay und so nicht funktioniert. Hab mich an die Anleitung auf Voip-info.org gehalten.

    Hast du deinen Asterisk selbst kompiliert?

    greets & thanks
    Sheridan
     
  5. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moment. Es wird gerade telefoniert. :)
    Ich poste das dann gleich herrein, sobald es möglich ist. Fehlermeldung war aber eigentlich keine dabei.

    greets & thanks
    Sheridan
     
  6. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AAAAAhhhhhhhhhhhhhhhh!!!
    Jetzt gehts. Hab Asterisk jetzt mit "/etc/init.d/asterisk restart" neu gestartet und jetzt haut es hin. Na toll. Und ich Depp komm nicht einmal auf die Idee, das Ding einfach neu zu starten. Hab immer nur die config mir reload neu geladen.

    Das ist mir jetzt aber richtiggehend peinlich. :oops:


    Super danke für die Hilfe soweit. :D
    Aber weil ich euch gerade an der Strippe habe:
    Wie installiert ihr bei euch den Asterisk Server hauptsächlich?
    Fertige packages oder vom Source Code?

    Hat jemand von euch die 1.2 Beta schon am laufen?

    greets & thanks
    Sheridan
     
  7. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Aus dem Source-Code.

    Ja. Läuft ziemlich unauffällig & problemlos. Einschließlich der Addons und der LDAP-Anbindung aus app_ldap
     
  8. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmmm..... Klingt ja schon mal nicht schlecht. Wenn ich meinen Wunsch-Dialplan dann endlich soweit fertig habe, werde ich der Beta vielleicht eine Chance geben. Zumindest eine Version mal aus dem Source erstellen.


    Weil ich gerade sehe, dass du als "Untertitel" Granstream-Profi hast, hätte ich gleich noch eine Frage. Wie kann ich eigentlich die Funktionen der "hold", "transfer" und "conference" einstellen bzw. deren Nummer?
    Die Dokus von Grandstream sind ja nicht gerade besonders toll.

    Vielen dank.

    Sheridan
     
  9. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Das mag sein - aber die "Call Features" sind in der Grandstream Doku alle beschrieben.
     
  10. Sheridan

    Sheridan Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Aha. Ok. Danke. Ich schau mir das nochmal an. Kann doch nicht sein, dass ich das übersehen habe.

    Wird wohl schön langsam wieder Zeit für Urlaub.

    Danke auf jeden Fall nochmal.


    greets
    Sheridan