.titleBar { margin-bottom: 5px!important; }

Nach konfiguration der Rufgruppen kein MoH mehr

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Routerman, 22 Sep. 2006.

  1. Routerman

    Routerman Neuer User

    Registriert seit:
    4 Sep. 2006
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Routerman, 22 Sep. 2006
    Zuletzt bearbeitet: 22 Sep. 2006
    Nachdem ich mein Rufgruppen definiert habe funkioniert leider mein music on hold nicht mehr. Asterisk gibt in der CLI zwar aus das MoH richtig gestartet wird und auch wieder beendet wenn man den Befehl gibt aber der Wartende hört keine Musik.

    Auszug aus der musiconhold.conf

    [moh_files]

    [default]
    mode=quietmp3
    directory=/usr/local/share/asterisk/mohmp3

    [manual]
    mode=custom
    directory=/usr/local/share/asterisk/mohmp3
    application=/usr/local/bin/mpg123 -q -r 8000 -f 8129 -b 2048 --mono -s

    #include musiconhold_additional.conf
    ; class definitions ForA2Billing
    acc_1 => /usr/local/share/asterisk/mohmp3
    acc_2 => /usr/local/share/asterisk/mohmp3
    acc_3 => /usr/local/share/asterisk/mohmp3
    acc_4 => /usr/local/share/asterisk/mohmp3
    acc_5 => /usr/local/share/asterisk/mohmp3
    acc_6 => /usr/local/share/asterisk/mohmp3
    acc_7 => /usr/local/share/asterisk/mohmp3
    acc_8 => /usr/local/share/asterisk/mohmp3
    acc_9 => /usr/local/share/asterisk/mohmp3
    acc_10 => /usr/local/share/asterisk/mohmp3


    so. ab #include blick ich nicht mehr ganz durch. mir erscheint alles ab diesem eintrag als nicht notwenig da erstens keine musiconhold_additional existiert und auch kein A2Billing verwendet wird.

    So nun meine frage wie bekomme ich das ding wieder zu laufen? und gibt es eine möglichkeit musik als klingelzeichenersatz abzuspielen?

    besten dank im vorraus.
    ^


    UPDATE:

    So . Habe nun auf den Madplayer umgestellt und die Sinnlosen zeilen verworfen. Dadurch funktioniert MoH wieder. Jedoch ist die Qualität der Musikausgabe miserabelst. Ständig abgehackt sehr leise und kaum zu verstehen. Getestet mit verschiedenen MP3s überall das selbe ergebniss. Wie kann ich die Qualität erhöhen?