.titleBar { margin-bottom: 5px!important; }

[Problem] NAS von FritzBox auf FritzBox mit Freetz mounten

Dieses Thema im Forum "Freetz" wurde erstellt von schumi20091, 7 Nov. 2018.

  1. schumi20091

    schumi20091 Neuer User

    Registriert seit:
    19 Mai 2009
    Beiträge:
    174
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    #1 schumi20091, 7 Nov. 2018
    Zuletzt bearbeitet: 7 Nov. 2018
    Hallo,
    ich möchte gerne einen NAS Server (NTFS) von einer "normalen" FritzBox 7590 an einer FritzBox 7590 mit Freetz mounten.
    Image habe ich installiert mit cifsmount, aber leider kommt beim Starten diese Meldung:
    Code:
    modprobe: module cifs not found in modules.dep
    mount error: cifs filesystem not supported by the system
    mount error(19): No such device
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Starting cifs ... mount //xxx.xxx.xxx.xxx ...
    failed.
    Liegt es an dem nicht vorhandenen Replace Kernel?

    Wenn ja, welche alternativen gibt es zum mounten? (Fritz OS 07.01)
    Würde es auch direkt über eine Datei gehen, die z.B. über crontab ausgeführt wird?

    PS.: Habe es mal mit einer Telnet line getestet:
    Code:
    mount -t -FSTYPE[cifs] -o loop //xxx.xxx.xxx.xxx/ /var/media/Test user=User pass=Pass
    Bekomme dann diese Ausgabe:
    Code:
    There are filesystem-specific -o flags.
    Ist es richtig, das es evtl. auch über davfs als FTP mount geht?
     
  2. Herbie_2005

    Herbie_2005 Mitglied

    Registriert seit:
    31 März 2007
    Beiträge:
    298
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Mich würde das auch interessieren ...
     
  3. FischersFreetz

    FischersFreetz Neuer User

    Registriert seit:
    22 Feb. 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #3 FischersFreetz, 28 Feb. 2019
    Zuletzt bearbeitet: 28 Feb. 2019
    Ich denke, 'cifsmount' benötigt ein ' [*] Replace kernel '. Sollte der Eintrag nicht sichtbar sein, musst du die Ansichtseinstellungen ändern (siehe Level of user competence (Beginner) ---> (X) Expert :cool:).
    Das Modul "cifs.ko" (siehe Kernelmodules ---> fs ---> [x] cifs.ko) muss in das Image übernommen und in die Datei 'modules.dep' eingetragen werden.

    Kontrolliere nach dem ' make menuconfig ' die Kerneleinstellungen bezüglich 'Cifs'.
    Dazu mal ' make kernel-menuconfig ' eingeben und dann unter
    File systems ---> [*] Network File systems --->
    <M> CIFS support (..)
    [*] CIFS statistics
    und eventuell
    [ ] Enable additional CIFS debugging routines
    auswählen.
    ...abschleßend ein 'make' und dann "Daumen drücken"... ;)
     
  4. Herbie_2005

    Herbie_2005 Mitglied

    Registriert seit:
    31 März 2007
    Beiträge:
    298
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Danke für Deinen Beitrag, FischersFreetz, aber leider läßt sich damit Cifsmount trotzdem nicht starten.

    Fehlermeldung:
    Code:
    modprobe: can't load module cifs (kernel/fs/cifs/cifs.ko): unknown symbol in module, or unknown parameter
    mount error: cifs filesystem not supported by the system
    mount error(19): No such device
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Starting cifs ... mount //192.168.178.x/Ordner ...
    failed.
     
  5. FischersFreetz

    FischersFreetz Neuer User

    Registriert seit:
    22 Feb. 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    (Hast du auch die Daumen gedrückt? ;))
    Schau mal, ob das Module "cifs.ko" den Weg (ins Image) zur Fritzbox gefunden hat, dazu in einer Shell:
    " find / -name cifs.ko "​
    eingeben. Bei mir ergibt sich dabei folgender Pfad " /lib/modules/3.10.73/kernel/fs/cifs/cifs.ko ".
     
  6. Herbie_2005

    Herbie_2005 Mitglied

    Registriert seit:
    31 März 2007
    Beiträge:
    298
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Daumen gedrückt ...

    Auf „find / -name cifs.ko“ wird gemeldet: „/lib/modules/3.10.104/kernel/fs/cifs/cifs.ko“.

    Und ein „insmod /lib/modules/3.10.104/kernel/fs/cifs/cifs.ko“ liefert „insmod: can't insert '/lib/modules/3.10.104/kernel/fs/cifs/cifs.ko': unknown symbol in module, or unknown parameter“.
     
  7. FischersFreetz

    FischersFreetz Neuer User

    Registriert seit:
    22 Feb. 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #7 FischersFreetz, 1 März 2019
    Zuletzt bearbeitet: 1 März 2019
    Welche Firmwareversion verwendest du beim Erstellen des Images?
    Ich würde es mal mit der 06.8x oder 06.9x versuchen.

    Und eine weitere Kontrolle per:
    " grep cifs /lib/modules/3.10.104/modules.dep "​
    müsste " kernel/fs/cifs/cifs.ko: " ergeben.
     
  8. Herbie_2005

    Herbie_2005 Mitglied

    Registriert seit:
    31 März 2007
    Beiträge:
    298
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Firmware: 154.07.08-66266
     
  9. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,779
    Zustimmungen:
    10
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ist das cifs.ko in deinem Image wirklich das aus dem Freetz-Build? (Zeitstempel)

    Schau mal nach der Meldung
    in dmesg welches Symbol hier fehlt. Evtl. führt das auf die Spur des Problems...

    Gruß,
    Oliver