.titleBar { margin-bottom: 5px!important; }

Neue version von BRI_STUFF und CHAN_CAPI

Dieses Thema im Forum "Asterisk ISDN Allgemein" wurde erstellt von thorsten.gehrig, 27 Juli 2004.

  1. thorsten.gehrig

    thorsten.gehrig Mitglied

    Registriert seit:
    14 Juni 2004
    Beiträge:
    490
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi
    es gibt einen neuen BRI-STUF 0.1.0-RC2g
    http://www.junghanns.net/asterisk/downloads/bri-stuff-0.1.0-RC2g.tar.gz
    (wobei die versionen RC2a bis RC2g alle gestern gekommen sind...)

    und (diesmal wirklich) einen neuen CHAN_CAPI 0.3.4b
    http://www.junghanns.net/asterisk/downloads/chan_capi.0.3.4b.tar.gz
    (vom 19 Juli).

    Der BRI_STUFF kompiliert gegen:
    cvs co -D 05/27/04 zaptel
    cvs co -D 07/26/04 libpri
    cvs co -D 07/26/04 asterisk

    Beim kompilieren hatte ich das Problem dass es die resource "res_parking.so" nicht mehr existiert. Diese wurde in meiner "/etc/modules.conf" geladen:
    load =>res_parking.so

    das habe ich disabled und dann war alles wieder okay :-D

    Ob das Call-parking jetzt noch funktioniert kann ich nicht sagen - da ich das alles remote erledigt habe... werde diese Info aber heute abend nachtragen.

    Mfg
    Thorsten Gehrig
     
  2. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe die aktuelle Version von zaphfc etwas modifiziert, mit der Folge, dass zumindest fuer mich die Audioqualitaet besser geworden ist. Die modifizierte Version gibts unter: http://voip.otaku42.de/asterisk/downloads/zaphfc-mr

    Runterladen, entpacken und die von bristuff-0.1.0RC2 verwendete Version von zaühfc einfach gehen "meine" austauschen, dann compilieren. Bei Fragen: hier oder per E-Mail melden.

    Ciao, Mike
     
  3. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Das gleiche Problem hatte ich auch. Ich dachte es läge an mir.

    Gibt es schon erkenntnisse, ob das Parking funzt bei dir ?
     
  4. obelix

    obelix Mitglied

    Registriert seit:
    6 Apr. 2004
    Beiträge:
    345
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    haste schon mal die readme gelesen ??? könnte sein das die Versionen nicht passen.
    OBELIX
     
  5. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habt ihr Profis mal nachgesehen was sich an chan_Capi geäntert hat? Lest Euch mal in der Readme-Datei die letzte Zeile durch, wo steht, was chan_capi neu hat:
    Code:
    - fixed for latest cvs (asterisk/parking.h -> asterisk/features.h)
    Das ist das einzige, was sich geändet hat.
    Hast Du die neueste Version von Asterisk?

    Oh, das ich das nicht vergesse. Ich verschiebs mal nach ISDN-Allgemein. Da passt es besser.
     
  6. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ach deswegen kam bei mir immer die Meldung, das er die features.h nicht finden kann.! Die gab´s bei meiner Version wohl noch nicht.

    @Hupe: Recht hast du: Readme sollte man lesen - sag ich auch immer (und mache es dann manchmal selber nicht ;))
     
  7. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Und schon wieder eine neue Version: RC2h. Jetzt gibt er aber richtig Gas :)

    Ciao, Mike
     
  8. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Und noch eine neue, jetzt ist es RC2i. Dort wurde laut kapejod unter anderem ein Bug in zaphfc behoben, durch den in den B-Kanal RX-Handling-Routinen die Anzahl wartender Bytes falsch berechnet wurde. Ausserdem gibts einen Modulparameter "debug" (ebenfalls fuer zaphfc), mit dem vollstaendige D-Kanal-Dumps (inkl. State Changes) aktiviert werden koennen.

    [edit]
    Erfahrungsbericht: die RC2i ohne Modifikation an zaphfc funktioniert einwandfrei. Bei ersten Testtelefonaten konnte ich keinerlei Aussetzer, Knackser oder aehnliches feststellen. Im Vergleich zu den vorherigen Versionen eine absolute Verbesserung. Wer bisher also Probleme hatte: unbedingt upgraden!

    [edit2]
    Mit der RC2i hat sich auch das Problem bezueglich der Meldung "rx fifo not enough bytes received" geloest. Sie erscheint nicht mehr. Dafuer bringt die Aktivierung des debug-Modus bei mir das Problem mit sich, dass das angeschlossene ISDN-Telefon nicht mehr richtig funktioniert. Den Debugmodus sollte man also vorerst meiden.

    Ciao, Mike
     
  9. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ist der Aufruf, um den Debug-Mode zu aktivieren mit "insmod zaphfc modes=1 debug" richtig ?? Ich hab es leider nirgends gefunden

    Habe gerade alles, was Asterisk heißt, von meiner Maschine entfernt, die neueste Bristuff-Version gezogen und inst. Lief alles prima durch ohne FM. Auch "insmod zaptel", "insmod zaphfc modes=1 debug", "ztcfg -vv" und "asterisk -vvvvc" bringen keinerlei FM.

    Allerdings ist danach wieder alles beim alten: nix paaiert, wenn ich den Hörer abnheme. Das Tel klingelt auch nicht, wenn ich es anrufe.

    Irgendwie bin ich wohl zu blöd :-(
    was mache ich nur falsch ???
    Wo kann ich die Debug-Ausgabe des zaphfc-Moduls sehen ? Im Syslog sowie im Asterisk-Log erscheint bisher nix.
     
  10. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nein, richtig waere "debug=1". "debug" alleine reicht nicht aus. Die Debugmeldungen kommen dann auf der Konsole und, je nach Konfiguration Deines Syslog-Daemons, auch im Syslog (kernel.log oder aehnliches).

    Dass das ISDN-Telefon keinen Mucks von sich gibt, wenn der Debugmodus aktiviert ist, habe ich hier auch. Das wird bei Dir nicht der Grund sein, denn wie oben geschrieben reicht es nicht aus, einfach nur "debug" anzugeben.

    Ciao, Mike
     
  11. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Na es gibt bei mir auch ohne Debug=1 keinen Mucks - deshalb wollte ich den Debug-Modus ja mal an machen, um evtl. mehr zu erfahren.
    Allerdings kommt bei "debug=1" das hier:
    Code:
    Warning: ignoring debug=1, no such parameter in this module
    
    Mir platzt hier bald der Kopf ;-)
     
  12. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bist Du auch sicher, dass Du das zaphfc-Modul (also das aus bri-stuff 0.1.0RC2i) laedst? Vorher gabs diesem Parameter noch nicht.
    Zur Sicherheit habe ich es bei mir auch gerade nochmal ueberprueft, hier wird debug=1 akzeptiert.

    Ciao, Mike
     
  13. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Wollte gerade per Edit meinen Fehler melden - aber du warst schneller.
    Es war eine alte Version.
    Mit der aktuellen nimmt er jetzt "debug=1" an.
    Im Log sieht es jetzt so aus:
    Code:
    Jul 28 13:59:45 linux-router kernel: PCI: Enabling device 01:09.0 (0000 -> 0003)
    Jul 28 13:59:45 linux-router kernel: zaphfc: CCD/Billion/Asuscom 2BD0 configured at mem 0xd088b000 fifo 0xcf9b8000(0xf9b8000) IRQ 5 HZ 1000
    Jul 28 13:59:45 linux-router kernel: zaphfc: Card 0 configured for NT mode
    Jul 28 13:59:45 linux-router kernel: zaphfc: 1 hfc-pci card(s) in this box.
    Jul 28 13:59:57 linux-router kernel: Registered tone zone 3 (Netherlands)
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xea 0x2d 0x6 0xff !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xbf 0xa1 0x6 0x81 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xd6 0xa 0x6 0x83 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xaa 0xe9 0x6 0x85 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x48 0xb9 0x6 0x87 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x93 0x3c 0x6 0x89 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xbc 0x7c 0x6 0x8b !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x83 0x69 0x6 0x8d !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xb7 0xef 0x6 0x8f !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x8d 0x7c 0x6 0x91 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x1e 0x13 0x6 0x93 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x68 0x1d 0x6 0x95 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x7b 0x75 0x6 0x97 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xbd 0x51 0x6 0x99 !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x5c 0xd7 0x6 0x9b !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0xa9 0xb1 0x6 0x9d !]
    Jul 28 14:00:04 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0xfe 0xff 0x3 0xf 0x8f 0xe3 0x6 0x9f !]
    Jul 28 14:00:10 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0x2 0xff 0x3 0x8 0x1 0x2 0x5 0x4 ...]
    Jul 28 14:00:10 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0x3 0x80 0x90 0xa3 0x18 0x1 0x89 0x6c ...]
    Jul 28 14:00:10 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0x4 0x21 0x81 0x34 0x32 0x70 0x8 0xc1 ...]
    Jul 28 14:00:10 linux-router kernel: zaphfc: card 0 TX 8 bytes [ 0x36 0x30 0x31 0x38 0x39 0x38 0x38 0xa1 !]
    
    Ich sehe irgendwie nur TX kein RX oder ist das normal ?
     
  14. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Keine Ahnung. Ich meine, ich haette auch nur TX bekommen. Wirklich testen konnte ich es ja nicht, weil wie gesagt mit eingeschaltetem debug-Modus hier nix mehr geht. Ist schon an kapejod gemeldet, btw.

    Ciao, Mike