.titleBar { margin-bottom: 5px!important; }

Newbie: Fehler beim build dsmod 0.2.9._26-13

Dieses Thema im Forum "Freetz" wurde erstellt von komar, 28 Jan. 2007.

  1. komar

    komar Neuer User

    Registriert seit:
    28 Jan. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich bin gerade dabei die ersten Gehversuche mit dem dsmod zu unternehmen und nen eigenen Kernel für meine FB7170 zu bauen.

    Hierzu habe ich mir FriboLi 0.4 und ds-0.2.9_26-13 besorgt.

    Der Build schlägt aber mit folgender Fehlermeldung fehl. Leider hab ich keine Ahnung, warum es hakt.
    Scheinbar versucht make auf ein .version File zuzugreifen. Dies ist auch im Root-Verzeichnis des mod vorhanden und enthält den String ds-0.2.9.
    Sehr strange, zumindest für mich als blutiger dsmod Newbie. Wer kann helfen und mich auf die richtige Fährte setzen?

    Danke und Grüße
    Komar
    -------------------------- make output -----------------------
    STEP 2: MODIFY
    applying patches
    applying patches (fon_wlan_7170-de)
    patching file etc/profile
    Hunk #1 succeeded at 1 with fuzz 2.
    patching file usr/bin/system_status
    patching file etc/init.d/rc.net
    patching file etc/init.d/rc.voip
    patching file etc/init.d/rc.S
    Hunk #1 succeeded at 263 with fuzz 1 (offset -86 lines).
    patching file etc/init.d/rc.S
    patching file etc/hotplug/run_mount
    patching file etc/hotplug/storage
    patching file etc/fstab
    patching file usr/www/all/html/de/fon/foncalls.js
    patching file usr/www/all/html/de/menus/menu2_fon.html
    patching file usr/www/all/html/de/menus/menu2_homehome.html
    patching file usr/www/all/html/de/menus/menu2_homekonfig.html
    patching file usr/www/all/html/de/menus/menu2.inc
    patching file usr/www/all/html/de/menus/menu2_internet.html
    patching file usr/www/all/html/de/menus/menu2_system.html
    patching file usr/www/all/html/de/menus/menu2_usb.html
    patching file usr/www/all/html/de/menus/menu2_wlan.html
    patching file usr/www/all/html/de/fon/sperre1.js
    creating symlink /tmp and /mod
    ERROR: cnnot determine kernel version
    make: *** [firmware] Fehler 1
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Du hast kein "make precompiled" gemacht, oder?

    MfG Oliver
     
  3. komar

    komar Neuer User

    Registriert seit:
    28 Jan. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Oliver,


    super schnelles Feedback, danke dafür. Ich hab mich an der Beschreibung im Wiki orientiert. Make precompiled war da nicht explizit aufgeführt (oder ich habs übersehen). Mittlerweile läufts.
    Muss ich sonst noch was beachten? Welche AVM FW Quellen sind denn in dem Image integriert?

    Grüße
    Komar
     
  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Für die 7170 neueste Firmware ist der Weg ein bißchen anders wie im Wiki beschrieben. Deshalb steht das in meinem Post was zu beachten ist.
    Wie meinst du das mit den FW-Quellen?

    MfG Oliver
     
  5. komar

    komar Neuer User

    Registriert seit:
    28 Jan. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Oliver,

    Auf den Thread bin ich mittlerweile auch schon gestoßen. In einem der letzten Beiträge gings auch schon um meinen initialen Fehler. Ich hätte also eigentlich gar nicht fragen brauchen.

    Ich hab mich gefragt, wie die AVM Sourcen der Firmware und das dsmod zusammenkommen. Jetzt ists aber schon klarer. Über menukonfig lege ich fest, welche Firmware verwendet werden soll. Die wird dann im precompiled Lauf von der avm website geladen und mit dem mod verheiratet.

    Grüße
    Komar