.titleBar { margin-bottom: 5px!important; }

Open VPN Webinterface fehler?

Dieses Thema im Forum "Freetz" wurde erstellt von mister-man, 5 Nov. 2008.

  1. mister-man

    mister-man Neuer User

    Registriert seit:
    18 Mai 2008
    Beiträge:
    68
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!
    Ich bin gerade dabei in meinem OpenVPn feste IP adressen über den Punkt "Erweiterte Clientkonfiguration" zu verteilen. Habe nun 4 angelegt, und alles ist bestens. Nun wollte ich heute mit der 5ten anfangen. Ich klicke auf Add Client und trage die Werte ein. Bis dahin ist alles in Ordnung. Doch dann speicher ich es ab und die Box Stürtzt dabei ab und startet neu.
    Einstellungen wurden nach dem Neustart nicht übernommen!

    Ist dies normal, gibt es eine Begrenzung auf 4 Teilnemer?
    Oder ist dies ein Fehler? Wenn ja kann ein relativer Frischlink Ihn beheben?

    MfG und Danke für eure Antworten
     
  2. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,919
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Nein, es gibt keine Begrenzung! Da läuft was anderes auf deiner Box schief! Was für eine Meldung kommt denn beim Speichern, da wo normalerweise sowas im Fenster steht?
    Code:
    Saving settings...done.
    Saving openvpn.cfg...done.
    Writing /var/flash/freetz...done.
    44544 bytes written.
    Selbst wenn ich da Müll eintrage, kann ich das zumindest abspeichern, wie du im Anhang siehst (natürlich läuft die Konfig so nicht ;-))

    Jörg
     

    Anhänge:

  3. mister-man

    mister-man Neuer User

    Registriert seit:
    18 Mai 2008
    Beiträge:
    68
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für den schnellen Test, dann werde ich mich nochmal umsehen, was ich falsch gemacht habe.
    Hatte es gerade sogar so weit, das er etwas übernommen hatte und danach konnte ich die Box nichtmal mehr vom Lan erreichen (noch nicht mal Ping).
    Nach neustart konnte ich die Box 10 sec erreichen und dann kam der gleiche Fehler wieder auf.
    Habe dann den VPN deaktiviert und die Clients wieder auf 4 Runtergestutzt. Und den VPN dienst gestartet. Alles Funktinierte.
    Nach neustart ging auch alles.
    Da muss bei mir dann ja einiges im Argen sein, ich denke ich werde das Image mal neu einspielen.
    Danke für die Schnelle Hilfe!
     
  4. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,919
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ich könnte mir zwei Sachen vorstellen:

    - Der letzte Client hat das Flash "überfüllt", daher hat das Speichern nicht geklappt, dann sollte aber in etwa sowas beim Speichern kommen:
    Code:
    Saving settings...done.
    Saving openvpn.cfg...done.
    size: 92160 limit: 61440
    ERROR: /var/flash/freetz too big
    
    - Irgendwas im letzten Eintrag war "so falsch", das es beim Starten der Config die Box zum Neustart gebracht hat. Dann wäre der fünfte Client-Eintrag da (und in der GUI sichtbar), aber das OpenVPN könnte nicht starten und würde beim automatischen Start natürlich immer wieder das gleiche Problem erzeugen...
    Wenn du die Box "nur nicht erreichen" konntest tippe ich mal darauf, dass du dein eigenes LAN als Netz beim Client eingetragen und dir damit dein Routing "zerlegt" hast...

    Jörg
     
  5. matze1985

    matze1985 Aktives Mitglied

    Registriert seit:
    17 Feb. 2007
    Beiträge:
    1,537
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    wie wärs denn, wenn du deine Config mal postest. :)