OpenNTP nach Reboot

astrapi

Mitglied
Mitglied seit
27 Mai 2005
Beiträge
341
Punkte für Reaktionen
0
Punkte
0
Hallo,

auf meiner FB 7390, freetz-devel-8306, startet der OpenNTP nach einem Reboot der Box nicht automatisch. Ein manuelles Starten funktioniert jedoch reibungslos.

Im Syslog steht nach dem Booten bei ntpd lediglich:

Code:
Jan  1 01:01:10 fritz daemon.info ntpd[3007]: listening on 172.16.1.254
Jan  1 01:01:10 fritz daemon.info ntpd[3007]: ntp engine ready
Jan  1 01:01:10 fritz daemon.crit ntpd[3007]: imsg_get: Cannot allocate memory
Jan  1 01:01:10 fritz daemon.info ntpd[3007]: ntp engine exiting
Jan  1 01:01:10 fritz user.notice FREETZMOD: Starting openntpd ... done.
Woran könnte es liegen?
 

Anhänge

astrapi

Mitglied
Mitglied seit
27 Mai 2005
Beiträge
341
Punkte für Reaktionen
0
Punkte
0
wenn du mir sagst, wie ich es angehen soll, und warum es mit dem trunk 8275 noch ging ....
 

astrapi

Mitglied
Mitglied seit
27 Mai 2005
Beiträge
341
Punkte für Reaktionen
0
Punkte
0
replace kernel ist nicht an
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Vielleicht gibt es eine Debug-Stufe, die mehr Infos bringt, oder Du kannst es mit strace aufrufen.
Ansonsten weißt Du ja, Trunk ...
 

astrapi

Mitglied
Mitglied seit
27 Mai 2005
Beiträge
341
Punkte für Reaktionen
0
Punkte
0
strace scheidet aus denk ich, da openntp ja nur beim booten nicht startet, ansonst startet es problemlos

wo stell ich die debugstufe ein?
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
7,853
Punkte für Reaktionen
14
Punkte
38
wo stell ich die debugstufe ein?
Evtl. bei den OPTIONS mit -d:
Code:
modlib_startdaemon $DAEMON_BIN -s -f /mod/etc/ntpd.conf [COLOR=red]$OPENNTPD_OPTIONS[/COLOR]
Code:
...
case '[COLOR=red]d[/COLOR]':
            [COLOR=red]conf.debug = 1[/COLOR];
            break;
...