OpenSwan

JPAdie

Neuer User
Mitglied seit
20 Sep 2006
Beiträge
74
Punkte für Reaktionen
0
Punkte
0
Hello

i've seen somethreads mentioning Openswan but can't follow them, as they are in german.

Has anyone tried installing OpenSwan on a 7050? seems there is a MIPS port so it should be possible. I have successfully installed the OpenVPN software but i would rather make use of the native clients that exist on XP and OS X than have to roll out an openssl client client and keys to every laptop.

thanks
Justin
 
F

foschi

Guest
Yes. Someone (Hehol, http://www.ip-phone-forum.de/showthread.php?t=99661) attempted to, but did not succeed, insofar that he got the kernel modules to load/unload, got the keying daemon pluto to start and load a configuration, and got an IPSec SA negotiated. But: no packets went through the ipsec0 interface. Packets got stuck somewhere, concerning both ways. Changing firewall settings fpr ESP to 0.0.0.0 and the policies for all interfaces to "permit" did not change anything.

As far as he figured one needs support from AVM to solve this, or a newer kernel than 2.4.17. There is some talk that AVM will present a firmware with IPSec included, but AFAIK AVM has not made any announcements so far.
 

JPAdie

Neuer User
Mitglied seit
20 Sep 2006
Beiträge
74
Punkte für Reaktionen
0
Punkte
0
interesting. and thanks for the response. I wonder whether a bridge (rather than routing) might solve the problem.

i'll give it a go and post back.
 
F

foschi

Guest
Have fun. AFAIK it took him two weeks, and this is not because he is slow or does not know the topic/what he's doing...
 

JPAdie

Neuer User
Mitglied seit
20 Sep 2006
Beiträge
74
Punkte für Reaktionen
0
Punkte
0
thanks for the warning!
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
236,511
Beiträge
2,077,865
Mitglieder
358,001
Neuestes Mitglied
mattha_123