.titleBar { margin-bottom: 5px!important; }

OpenVPN auf Bxo 5050

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Duff, 17 Nov. 2006.

  1. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo,

    ich habe bei mir in der debug.cfg schon verschiedene Einstellungen vorgenommen, damit auf der Box ein vpnserver laufen kann.

    Jedoch kann ich, wenn ich den Prozess z.B. händisch aufrufe, diesen nicht finden. Ein ps -ef findet keinen Prozess, der auf vpn schließen lässt.

    Wie startet ihr den denn?

    Ich habe es (bin mir nicht ganz sicher) so probiert:

    ./openvpn --config server.ovpn

    In der Datei server.ovpn stehen dann so Sachen wie ifconfig uws.
     
  2. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Also, ich habe jetzt noch mal nachgeschaut.

    Ich probieren folgendes:
    Code:
    # ./openvpn --config ./server.ovpn
    
    Es wird aber kein Prozess dazu gefunden:
    Code:
    # ps -ef
      PID  Uid     VmSize Stat Command
        1 root        296 S   init
        2 root            SW  [keventd]
        3 root            RWN [ksoftirqd_CPU0]
        4 root            SW  [kswapd]
        5 root            SW  [bdflush]
        6 root            SW  [kupdated]
        7 root            SW  [mtdblockd]
        8 root            SW  [tffsd_mtd3]
      263 root        204 S   ledcfg -c -d -f /etc/Fritz_Box_FON_2.led.conf
      315 root            SW  [ubik2_tx[8]]
      316 root            SW  [capitransp]
      347 root       1080 S N ctlmgr
      353 root        772 S N websrv
      359 root       1176 S   igdd
      363 root        772 S N websrv
      364 root        772 S N websrv
      367 root        948 S   multid
      368 root        772 S N websrv
      390 root       1348 S < dsld -i -n
      402 root        580 S   telefon a127.0.0.1
      407 root       1204 S < voipd
      409 root        184 S   /bin/run_clock -c /dev/tffs/mtd3 -d
      432 root       1176 S   igdd
      433 root       1176 S   igdd
      434 root       1176 S   igdd
      463 root        296 S   /var/tmp/dropbear -p 22 -r /var/tmp/dropbear_rsa_host_key -d /var/tmp/dropbear
      476 root        292 S   init
      620 root        528 R   /var/tmp/dropbear -p 22 -r /var/tmp/dropbear_rsa_host_key -d /var/tmp/dropbear
      621 root        432 S   -sh
      730 root        296 R   ps -ef
    
    Meine server.ovpn sieht so aus:
    Code:
    # cat server.ovpn
    ifconfig 10.0.0.2 10.0.0.1
    secret /var/tmp/secret.key
    proto tcp-server
    port 1194
    tun-mtu 1500
    float
    keepalive 10 60
    verb 4
    mssfix
    route 10.0.0.0 255.255.255.0
    push "route 10.0.0.0 255.255.255.0"
    daemon
    
    Mache ich irgendetwas falsch?
     
  3. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    So, habe den Fehler gefunden beim Starten. Habe nie das tun-device mit angegeben.

    Bekomme aber trotzdem folgende Fehlermeldung:

    Code:
    # ./openvpn --config server.ovpn --dev-node /dev/misc/net/tun
    Nov 19 15:45:12 multid[366]: interface tun0 new.
    Nov 19 15:45:12 multid[366]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    Nov 19 15:45:12 multid[366]: interface tun0 up.
    Nov 19 15:45:12 multid[366]: static routes: 0 deleted (0 failed), 0 added (0 failed)
    
    Kommt die Meldung, weil ich openvpn nur auf dem Server gestartet habe und noch keine Verbindung von einem Client aus zum Server aufgebaut habe?
     
  4. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #4 Duff, 19 Nov. 2006
    Zuletzt bearbeitet: 19 Nov. 2006
    So, openvpn läuft nun und ich kann auch gegenseitig pingen.

    Die Routing-Tabelle auf der Box sieht nun so aus:
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    10.0.0.1        *               255.255.255.255 UH    0      0        0 tun0
    192.168.180.1   *               255.255.255.255 UH    2      0        0 dsl
    192.168.180.2   *               255.255.255.255 UH    2      0        0 dsl
    192.168.178.0   *               255.255.255.0   U     0      0        0 lan
    192.168.178.0   *               255.255.255.0   U     0      0        0 eth0
    10.0.0.0        10.0.0.1        255.255.255.0   UG    0      0        0 tun0
    192.168.1.0     *               255.255.255.0   U     0      0        0 lan
    default         *               0.0.0.0         U     2      0        0 dsl
    
    Ich habe allerdings noch ein paar Fragen, die wohl eher in die Kategorie "Versändnis" zuzuordnen sind.

    Woher weiß ich jetzt, ob die Verbindung verschlüsselt ist?
    Gehe ich jetzt vom Client über den vpn-tunnel zur Fritzbox und dann ins Internet oder geht der Client direkt über die Fritzbox ins Internet?

    Schonmal Danke.

    [edit]
    Eine Frage kann ich schonmal selber beantworten, weil es sieht so aus, als ob ich über die vpn-Verbindung auf die Box gehe:
    Code:
    traceroute: Warning: www.google.de has multiple addresses; using 72.14.221.99
    traceroute to www.l.google.com (72.14.221.99), 30 hops max, 40 byte packets
     1  10.0.0.2 (10.0.0.2)  110.172 ms  109.761 ms  109.582 ms
     2  * * *
     3  217.0.74.38 (217.0.74.38)  160.459 ms  157.950 ms  157.448 ms
     4  f-ea2.F.DE.net.DTAG.DE (61.152.17.50)  162.557 ms  164.547 ms  164.925 ms
     5  62.156.139.62 (62.156.139.62)  230.372 ms  171.641 ms  274.465 ms
     6  217.147.96.228 (217.147.96.228)  164.538 ms  166.406 ms  166.528 ms
     7  217.147.109.150 (217.147.109.150)  183.512 ms  183.213 ms  180.516 ms
     8  66.249.94.136 (66.249.94.136)  181.149 ms  187.352 ms *
     9  72.14.232.201 (72.14.232.201)  185.091 ms 72.14.232.203 (72.14.232.203)  183.719 ms 72.14.232.205 (72.14.232.205)  178.225 ms
    10  72.14.232.190 (72.14.232.190)  180.999 ms  187.860 ms 72.14.232.194 (72.14.232.194)  193.467 ms
    11  72.14.221.99 (72.14.221.99)  174.739 ms  179.816 ms  180.030 ms