[OpenVPN] shaper Option drückt Upstream auf 1KB/s

mrjingle

Neuer User
Mitglied seit
11 Nov 2006
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich setze OpenVPN auf meiner Fritz!Box ein und möchte den ausgehenden Traffic auf 50 KByte/s begrenzen. Dazu wollte ich die shaper-Option des VPN Servers nutzen. Starte ich die Software mit der unten geposteten Konfiguration, bricht der Upstream allerdings auf ca. 1 KByte/s zusammen (http/ftp/ssh getestet). Gleiches gilt, wenn ich den Wert des shapings auf 512000 verzehnfache.

Folgende Umgebung:
Server
- Fritz!Box 7170 (FW 29.04.57)
- OpenVPN 2.1_rc1 Build 05.01.2007 (3 MByte static binary von the-construct.com)

Client
- Debian Testing
- OpenVPN 2.1_rc11 Build 18.09.2008



Konfiguration des Servers
Code:
daemon
port 12345 # or any other port you want to use
proto udp 
dev tun
dev-node /var/tmp/tun
tls-server
ca /var/tmp/usb/etc/openvpn/ca.crt
cert /var/tmp/usb/etc/openvpn/fritzbox.crt
dh /var/tmp/usb/etc/openvpn/dh1024.pem
crl-verify /var/tmp/usb/etc/openvpn/crl.pem

key /var/tmp/usb/etc/openvpn/fritzbox.key
tls-auth /var/tmp/usb/etc/openvpn/ta.key 0

mute-replay-warnings
writepid /var/run/ovpn.pid

ifconfig 10.1.0.1 10.1.0.2
shaper 51200

mute-replay-warnings
fragment 1300
mssfix

log /var/tmp/usb/log/openvpn
verb 3 
persist-key

Setzt hier jemand die shaper-Option erfolgreich ein und kann mir nützliche Tipps geben?

Nachtrag:
Ich habe mittlerweile noch ein wenig mit anderen Systemen getestet und bin zu dem Schluss gekommen, dass es kein Problem der FritzBox-Variante von OpenVPN oder der FritzBox an sich ist. Wer an dem Thema interessiert ist, oder sich dazu äußern möchte, kann meinen Thread im OpenVPN-Forum besuchen.

Danke schonmal,
Robert
 
Zuletzt bearbeitet:
3CX

Statistik des Forums

Themen
235,935
Beiträge
2,068,031
Mitglieder
356,997
Neuestes Mitglied
Gotcha2112