[Problem] OpenWRT 19.07.0 / Fritzbox 7530: OpenVPN Verbindung an Lan-Ports nutzen

rennstrecke

Neuer User
Mitglied seit
10 Mrz 2006
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Hallo zusammen,

ich habe die aktuelle OpenWRT Version 19.07.0 erfolgreich auf meine Fritzbox 7530 geflashed und im Anschluss die OpenVPN Packages installiert.
Die OpenWRT-7530 nutzt WLAN als WAN (bereitgestellt über eine 7590), geht also darüber ins Internet und stellt auch problemlos über den nachinstallierten OpenVPN Client eine Verbindung zum OpenVPN-Server her.

Ich würde es nun gerne so haben, das alle Clients, die ich mit den LAN-Buchsen der 7530 verbinde, diese OpenVPN Verbindung nutzen um ins Internet zu kommen, das Gateway also quasi der entfernte OpenVPN Server ist. Wenn ich jedoch einen Client per LAN connecte, erhält er einfach per DHCP eine Adresse aus dem WLAN der 7590. Was muss ich konfigurieren, damit ich auf den LAN-Ports die OpenWRT-7530 samt dem verbundenen OpenVPN als Gateway nutzen kann. Mit manueller IP- und Gateway-Vergabe habe ich es natürlich schon versucht, dann hat man an den Clients einfach gar kein Internet mehr.

Hoffe ihr habt eine Idee. Besten Dank im Voraus.
 

NDiIPP

Aktives Mitglied
Mitglied seit
13 Apr 2017
Beiträge
2,453
Punkte für Reaktionen
407
Punkte
83
Wenn ich jedoch einen Client per LAN connecte, erhält er einfach per DHCP eine Adresse aus dem WLAN der 7590.
Das widerspricht dann aber folgender Aussage:
Die OpenWRT-7530 nutzt WLAN als WAN (bereitgestellt über eine 7590),

D.h., dass das WLAN der 7530 derzeit keine (W)WAN-Verbindung ist sondern (nur) eine (W)LAN-Verbindung. Wenn das korrigiert ist, muss noch das Routing geändert werden, anstatt zum WAN-Interface zum VPN-Interface. Und ein DHCP-Server auf der 7530 wäre wohl auch nicht schlecht.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,954
Beiträge
2,040,598
Mitglieder
353,153
Neuestes Mitglied
Unify_User