[Gelöst] Outbound CallerID

JohnnyXP

Neuer User
Mitglied seit
2 Mrz 2010
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo liebe Forengemeinde,

ich hoffe Ihr könnt mir bei meinem kleinen Problem helfen, doch ersteinmal hier die Konfiguration wie es bei mir aussieht:

InternetRouter: FirtzBox 7390 (OS 05.20)
AsteriskServer: AsteriskNow 1.7 upgegraded auf Asterisk 10.2.0
OS: CentOS 5.8 (Final)
FreePBX: FreePBX 2.10.1
C&S IP: Telekom Call & Surf IP VDSL50 analog mit 3 Rufnummern

Im Asterisk, der hinter der FritzBox auf einem VMWare ESXi-Server läuft, sind 3 Trunks eingerichtet die sich einwandfrei mit der Telekom verbinden und dort auch registrieren.
In der FritzBox sind die 3 Rufnummern eingerichtet die den Asterisk als Registrar verwenden. Ein Telefon ist am "FON 1" Anschluss, ein integrierter FAX-Empfang zwei SIP-Telefone und ein DECT Telefon. Jedes Gerät bis auf die SIP-Telefone und das DECT (diese sind einer Rufnummer/Trunk/Route) sind im Asterisk einem Trunk, einer Inbound- sowie OutboundRoute zugewiesen.

Das Problem welches ich nun habe ist folgendes:

Egal von welchem Telefon aus ich outbound Calls mache, wird immer der "Trunk 01" genommen. Bedeutet, ich hab auf "Trunk 01" die Rufnummernübermittlung abgeschaltet und bei "Trunk 02/03" eingeschaltet aber diese wird nicht übermittelt. Die Rufnummernübermittlung ist auch bei der Telekom so eingerichtet, dass Nr. 01 nicht übermittelt aber Nr.2/3 übermittelt.

Frage nun an euch:

Was muss ich machen, damit bei Nr.2/3 die Rufnummer übermittelt wird?

Ich hoffe ihr könnt mir weiterhelfen.

Danke und Grüße,

Johnny

Edit: Also ich hab nun auch das Modul "Custom Context" installiert und versucht es darüber zu regeln, indem ich die Contexte angelegt habe. Für jede Rufnummer einen Context und diesen habe ich dann der jeweiligen Extention zugeordnet. Ebenso habe ich pro Context auch die "deny" Rule gesetzt, so dass immer nur ein Trunk pro Context verwendet wird. Ende vom Lied: Es geht trotzdem noch nicht ... please help ...
 
Zuletzt bearbeitet:

JohnnyXP

Neuer User
Mitglied seit
2 Mrz 2010
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Back again ...

surprise surprise meinereiner hats geschafft ...

Problem bzw Fehlkonfiguration war, dass ich in den Outbound Routes die CID's nicht richtig hinterlegt hatte. Bei der Route die den Trunk 01 nehmen soll und die Rufnummern unterdrücken soll, darf keine CID hinterlegt sein. Sowohl bei Route CID als auch bei den Dial Patterns. Dort wo die Nummer angezeigt werden soll, muss die CID als Route CID eingetragen als auch das "Override Extention" aktiviert sein. Bei den Dial Patterns wird auch hier keine CallerID hinterlegt.

Vielleicht hilft es ja dem ein oder anderen der ein ähnliches Problem hat ...

LG,
Johnny