.titleBar { margin-bottom: 5px!important; }

pap2 <-> SPA3000 tcpdump messages

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von tkmbe, 10 Okt. 2006.

  1. tkmbe

    tkmbe Neuer User

    Registriert seit:
    5 Juni 2006
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    Ich bin weiter am Kaempfen. Habe mal einen tcpdump gemacht und folgendes gesehen, wenn ich mit meiner pap2 eine Nummer waehle

    SIP/SDP Request: INVITE sip:15680868@192.168.190.190:5061, with seesion description
    SIP Status: 410 Gone
    Request: ACK sip:15680868@192.168.190.190:5061

    Wobei Sip Status Mesage Header folgendes hat:

    Make Call Without Reg:
    To: <sip:15680868@192.168.190.190:5061>;tag=xxx
    From: Beat Meier <sip:855@192.168.190.190:5061>;tag hhhh
    SIP Display info: Beat Meier
    SIP from address; sip:855@192.168.190.190:5061
    SIP tag: hhhh
    Call-ID: 86...@192.168.99.240

    Mein Grundsaetzliche fragen nun;
    Die Daten unter Proxy Registration werden genommen auf pap2 wenn ich einen
    call machen will. Bsp: Line1 hat Proxy: 192.168.190.190:5061, Register: no
    Use Outbound Proxy: no, Use OB Proxy In Dialog: no
    (BTW: Was ist die Differenz zwischen Outbound Proxy und Proxy?)
    Nun geht ein Sip INVITE ueber meine router zur spa3000 soweit so gut.
    Nun aber die Antwort der spa3000: Die SPA3000 kennt doch nun den Sender und die
    Antwort sollte zu diesem zurueck gehen OHNE irgendwelche Konfigdaten der SPA3000 oder wird da doch noch was genommen?
    Und was bedeutet der Status 410: Gone ?
    Ich waehle die Nummer 15680868 und dann kommt das besetzt Zeichen ...
    Der syslog der pap2 enthaelt nichts ausser ein Periodsiche Medlung (all 10sec)
    Oct 10 10:12:04 192.168.190.190 [1]?Notify Event
    Oct 10 10:12:14 192.168.190.190 [1]?Notify Event

    BTW: Ich habe 2 ap (i.e. eine wireless Strecke) zwischen dem pap2 un der spa3000.
    Beide machen nat. Dies sollte doch weder die sp3000 noch der pap2 stoeren, oder?
    Die bekommen das ja gar nicht mit.
    Habe jedenfalls auch mal probiert das Nat Zeugs von pap2 und spa3000 zu
    enablen, ging auch nicht ...

    Dial Plan:
    auf der SPA3000 PSTNLine habe ich:
    SIP Port: 5061
    Proxy and Reg. Nothing
    Sub. Info: Display name: set
    Userid: 855

    User Auth id: no
    Dial Plan 1 habe ich: (xxxxxxxx)
    VoIP-To-PSTN Gateway Enable: yes
    VoIP Caller Auth Method: none
    One Stage Dialing: yes
    VoIP Access List: 192.168.99.101

    Wie sieht es aus mit dem pap2 Dialplan unter Line1? Kommt der zum tragen?
    Dort habe ich auch mal (xxxxxxxx) eingetragen und Enable IP Dialing: yes...

    Langsam bin ich am Ende mit meinen Ideen ....
    Wer kann mir da ein paar gute Tips geben??

    Und zu guter letzt wenn ich nun meine SPA3000 anrufe von einem "normalen"
    Telefon d.h. die PST line klingelt, dann sehe ich
    PSTN State: Ringing
    aber der call geht nicht weiter. Wie muss ich den PSTN User setzen
    damit dieser den call "fowarded" zu meinem pap2?
    Habe @gw, @gw0 und @192.168.190.240 (pap2 ip) probiert...
    Das einzige wenn es laeutet nun ist ein
    SIP Request: NOTIFY: sip:192.168.190.190:5061
    und ein
    SIP Status: 200 OK
    sonst nichts ...

    Beat
     
  2. tkmbe

    tkmbe Neuer User

    Registriert seit:
    5 Juni 2006
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    Ich weiss zwar nicht was geandert hat in meiner config
    (ausser ein power on/power off) aber jetzt kann ich wenigstens mal outgoing calls
    taetigen.
    Sobald ich eine funktionierende config fuer beide seite habe, werde ich die infos
    posten ...
    Hier mal was ich schon geteste habe:

    Das sind alles PAP2 config values:
    NAT Mapping Enable & NAT Keep Alive Enable hat keinen Einfluss, wenn andere
    router nat mapping machen

    Dial Plan
    Enable IP Dialing: no oder yes: Keinen Einfluss damit mit Telefon an
    pap2 telefoniert werden kann!
    Dial Plan muss angegeben werden. Ohne einen Dialplan kommt das Besetzt Zeichen!!

    Beat