.titleBar { margin-bottom: 5px!important; }

Passwort trouble

Dieses Thema im Forum "Freetz" wurde erstellt von Bozo, 3 Feb. 2007.

  1. Bozo

    Bozo Mitglied

    Registriert seit:
    24 Apr. 2005
    Beiträge:
    272
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    Ich habe mir in die debug.cfg folgende Zeile eingetragen, die eigentlich einen permanenten ftp-User anlegen sollte:

    echo User:Userhash:1:1:ftp:/:/bin/sh >> /var/tmp/passwd

    Leider sieht meine passwd jetzt so aus:

    [noparse]root:x:0:0:root:/mod/root:/bin/sh
    samba:x:1:1:samba:/mod/home/samba:/bin/sh
    ftp:x:2:1:ftp:/mod/home/ftp:/bin/sh
    ftp:x:3:1:ftp:/mod/home/ftp:/bin/sh
    ftp:x:4:1:ftp:/mod/home/ftp:/bin/sh
    ftp:x:5:1:ftp:/mod/home/ftp:/bin/sh[/noparse]

    Der eingetragene User ist nicht vorhanden, zudem ist der "ftpuser" , wie in der firitzbox für den USB-Massenspeicher konfiguriert, verschwunden.

    Ich komme somit nicht mehr per ftp auf die Box. Telnet geht logischerweise, DS-Mod webinterface auch.

    Wenn ich die User von Hand eintrage komm ich auch wieder per ftp drauf , nach dem nächsten Reboot sind die User wieder weg.

    Wo liegt der (Denk-)fehler? Was hab ich übersehn bzw. falsch gemacht?
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Sieht eigentlich richtig aus. Eventuell wird dein User aber von den Änderungen des ftpuser überschrieben. Vielleicht solltest du ein sleep vor den Befehl setzen...

    MfG Oliver
     
  3. Bozo

    Bozo Mitglied

    Registriert seit:
    24 Apr. 2005
    Beiträge:
    272
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bin leider gar nicht linux fit.

    Sleep einfach so ohne Parameter?
    Oder muss da noch was dazu?

    Aber wenn der permanente Eintrag von dem Eintrag des ftpusers überschrieben würde, dann müsste doch zumindest der ftpuser drin sein.

    Hat vielleicht jemand ne original passwd Datei noch ohne ftpuser und feste User für mich und kann ich die einfach tauschen?
     
  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ich dachte an sowas:
    (sleep 30;echo User:Userhash:1:1:ftp:/:/bin/sh >> /var/tmp/passwd)&

    Du kannst natürlich auch mal testweise:
    "cat /var/tmp/passwd > /var/tmp/passwd.backup" in die debug.cfg schreiben und nach dem Reboot die passwd.backup-Datei anschauen. Dann solltest du sehen was zum Zeitpunkt deines Eintrag-Versuches da drin steht.

    MfG Oliver
     
  5. Bozo

    Bozo Mitglied

    Registriert seit:
    24 Apr. 2005
    Beiträge:
    272
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, hab das mal alles versucht.

    Fazit: Der Standard FTP User für die USB Platte schiesst mir die passwd ab.

    Habe jetzt den ftpuser auch per Hand in die debug > passwd geschrieben und den ftp Port auf nen virtuellen Port der Fritz geleitet (auf die Fritzbox selbst gehen ja die Freigaben nicht direkt) und so gehts jetzt.

    Seltsam ist das ganze irgendwie schon. Wenn der ftpuser alleine aktiv ist, gehts.
    Wenn der zusätzliche User alleine aktiv ist gehts auch.
    Sind beide aktiv, schmeissen sie sich anscheinend gegenseitig aus der Fritz.

    Egal, hintenrum läufts ja jetzt, Danke für die Hilfe!