[Problem] Patches für Speed2Fritz (W503)

racker_db

Neuer User
Mitglied seit
12 Feb 2009
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
Hallo,

nach dem ich hier bereits mein Problem gepostet habe,
bin ich auf folgende Lösung gekommen:

Im Script Speedport503 wird die Variable "FORCE_TCOM_DSL" nicht ausgewertet
und demzufolge wird auch der DSL-Treiber nicht kopiert.
Kaum wird der Treiber kopiert ist die Box spätestens nach dem 3. Reboot betriebsbereit.
Meine Änderungen stehen im Diff im Anhang.

Ich wünsche noch ein gutes neues Jahr.

Gruß
 
Zuletzt bearbeitet:

Jpascher

IPPF-Promi
Mitglied seit
31 Mrz 2007
Beiträge
6,120
Punkte für Reaktionen
0
Punkte
36
Habe das mit Revision 1445 ins Skript übernommen.
 

racker_db

Neuer User
Mitglied seit
12 Feb 2009
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
noch 3 diffs

Hallo,

danke für die Rückmeldung.
Ich habe da noch 3 diffs für Korrekturen. ;)
Sind mit -p1 anzuwenden.
Bei dem add_multi_settings.sh.diff bin ich mir nicht sicher ob das der richtige Parameter ist.
Im aufgerufenen Script add_multicountry.sh wird nur einmal auf "$1" referenziert.

Btw ist die Veröffentlichung hier korrekt oder soll ich die Diffs dir oder jemand anderem schicken?

Gruß

PS: noch etwas gefunden...
 
Zuletzt bearbeitet:

Jpascher

IPPF-Promi
Mitglied seit
31 Mrz 2007
Beiträge
6,120
Punkte für Reaktionen
0
Punkte
36
Danke! Ich hab das nun auch übernommen.

Diese Korrekturen müssten eigentlich irgendwann mal irrtümlich passiert sein, man müsste die Revisionen durchsuchen, wann diese Fehler passiert sind, irgendwann war das auf jeden Fall in Ordnung.

Wo soll man Fehler oder Korrekturen berichten?
Egal wo Hautsache es wird gepostet. Sicherer ist es derzeit direkt an mich da ich kaum mehr im Forum vorbei-schaue.

Sollte jemand vorhaben aktiver am Skript Verbesserungen vorzunehmen, kann ich auch direkt Schreibrechte im SVN vergeben.
 

racker_db

Neuer User
Mitglied seit
12 Feb 2009
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
Patch für Rev. 1450

Hallo,

ich habe den zwar schon gemailt, aber wer es schon mal vorab testen möchte....

Dieser Patch beseitigt das Reboot-Problem, das ich hier gepostet hatte.
Außerdem zeigt der Reset-Taster wieder eine Reaktion.

Patch im Trunk-Verzeichnis entpacken und mit patch -p1 < *.diff ausführen.

Als nächstes ist die Kindersicherung dran :)

Gruß


PS: @jpascher: Mail bekommen?
 
Zuletzt bearbeitet:

Jpascher

IPPF-Promi
Mitglied seit
31 Mrz 2007
Beiträge
6,120
Punkte für Reaktionen
0
Punkte
36
Mail ist leider nicht angekommen, aber ich hab es jetzt etwas angepasst eingeplant.

Anmerkung: Einige der von dir verbesserten Zeilen waren eindeutig Fehler im Skript.
Zum 503:
Nicht alle Zeilen im Bereich piglet sind in Verwendung, manches könnte noch rausgepatcht werden ist aber auch nicht störend.
Bitfilecount ist nicht in Verwendung, da es sowieso nur eine File gibt.
 
3CX

Neueste Beiträge

Statistik des Forums

Themen
235,870
Beiträge
2,066,981
Mitglieder
356,841
Neuestes Mitglied
Baddy26