.titleBar { margin-bottom: 5px!important; }

Postfix Mailproblem

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Beebob007, 28 Jan. 2009.

  1. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi,
    habe ein problem mit mails.faxe kommen prima per email an und auch die voicemailnachrichten. nun hat unser mailserver folgende email wieder und wieder geschickt:

    The original message was received at Wed, 28 Jan 2009 04:02:06 +0100
    from [80.XXX.XXX.XXX]

    ----- Transcript of session follows -----
    <root@localhost.de>... Deferred: Connection refused by localhost.de.
    Warning: message still undelivered after 10 hours
    Will keep trying until message is 5 days old


    ==============================================


    Reporting-MTA: dns; db01.XXX.de
    Arrival-Date: Wed, 28 Jan 2009 04:02:06 +0100

    Original-Recipient: rfc822;root@localhost
    Final-Recipient: RFC822; root@localhost.de
    Action: delayed
    Status: 4.4.1
    Remote-MTA: DNS; localhost.de
    Last-Attempt-Date: Wed, 28 Jan 2009 14:03:14 +0100
    Will-Retry-Until: Mon, 2 Feb 2009 04:02:06 +0100

    De Fehler erkenne ich ja: Nachricht wird vom Mailserver an root@localhost.de geschickt und kommt verständlicherweise nicht an. aber wie kann ich das ändern?das ganze ist passiert als eine logdatei gesendet wurde. wie kann ich den versand von logdateien oder fehlermeldungen abstellen?

    gruß
    Beebob007
     
  2. Clemens

    Clemens Aktives Mitglied

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,496
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Da ist was falsch configuriert - root@localhost.de gibt es nicht, wenn dann root@localhost

    Was ich mal überprüfen würde:
    /etc/aliases
    /etc/hostname
    /etc/postfix/main.cf

    Oder suche ob irgendwo localhost.de eingetragen ist.

    Bei mir ist das so eingestellt dass Mails an root immer an meinen Useraccount weitergeleitet werden. (Das System schreibt ja mal gerne Mails, z.B. der Cronjob.)
     
  3. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,280
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    alternativ die /etc/hosts entsprechend ergänzen

    Code:
    127.0.0.1       localhost localhost.de
    Ist aber der schlechtere Weg. Besser ist es rauszufinden warum er es an localhost.de schicken will und an der Stelle abzustellen.

    jo
     
  4. kritter

    kritter Neuer User

    Registriert seit:
    20 Dez. 2008
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Erfurt
    @Beebob: Gehts Dir jetzt also um das Löschen der aktuell rotierenden Mail??

    Schau Dir mit "mailq" die mail queue an und kopier Dir die ID der aktuell wartenden Mail raus. Dann mit "postsuper -d [ID]" löschen. Gemeint ists natürlch ohne die eckigen Klammern.
     
  5. kritter

    kritter Neuer User

    Registriert seit:
    20 Dez. 2008
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Erfurt
    Jepp. Kommen mehrere Stellen in Frage. Aber als erstes in der /etc/resolv.conf nachschauen, ob dort defaultmässig ein "de" als Superdomain drangehängt wird.
     
  6. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    guten morge,
    danke erstmal für die tolle hilfehab jetzt folgendes gemacht:
    mailq: sagt mir das keine mail mehr zum senden da ist(die mail liegt auf dem mailsserver der nicht bei uns ist.
    /etc/aliases: da steht fast alles auf root
    /etc/hostname: hab ich nicht.....?
    /etc/postfix/main.cf: folgendes aufgefallen
    mydestination = $myhostname, localhost.$mydomain, localhost
    und dann hab ich nochmal:
    mydestination = localhost

    ist das der fehler,oder ist das egal?muß ich in der main.cf bei mydomain was eintragen?
    Warum schickt Asterisk überhaupt eine log-file?und warum funktioniert fax2mail und voicemail und nur das nicht?kann man das schicken nicht ausstellen?
    ich hab auch noch ne etc/hosts.deny. kann ich da nicht localhost.de eintragen notfalls?

    gruß
    Beebob007
     
  7. kritter

    kritter Neuer User

    Registriert seit:
    20 Dez. 2008
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Erfurt
    Okay, jetzt scheint es ein wenig durcheinander zu gehen... ;)

    Also nacheinander:
    Am Hostname rumzuschrauben wäre auch nicht gut. Die Stelle in der main.cf hingegen ist goldrichtig. Hier nämlich sagst Du, für welche Domains sich Dein Mailserver selbst zuständig fühlen soll, _ohne_ den Versuch zu machen, die Mail an andere Mailserver weiterzuschicken. Genau hier solltest Du also nicht den Eintrag auf "mydestination = localhost" verkürzen, denn dann fühlt er sich für noch weniger zuständig. Im Gegenteil: Nimm den alten Inhalt und hänge doch einfach mal spaßenshalber noch "localhost.de" als Eintrag dran!!

    An der /etc/hosts.deny machst Du bitte goar nix. :) Die hat was mit Shell-Logins u.ä. zu tun, aber sicherlich nichts mit Postfix und/oder Asterisk. ;)

    Deinen letzten Fragen kannst Du nur in der Asterisk-Konfiguration auf den Grund gehen. Vom Asterisk generierte Absenderadressen findest Du eben hauptsächlich in der sip.conf und der voicemail.conf. Über die sip.conf wird ja noch eingestellt, für welche Domains sich der Asterisk domaintechnisch zuständig fühlt. Es kann sein, dass er für bestimmte Internetzwecke auch mal Domainnamenteile aus diesen Einstellungen ableitet.

    Der übliche Trick an dieser Stelle ist, wie schon zuvor beschrieben, in der /etc/hosts mal einen Rechnernamen zu vergeben "127.0.0.1 localhost aberhallo". Der erste Test: ein "ping aberhallo" sollte auf jeden Fall ab sofort etwas mit dem Namen anzufangen wissen und pingen, statt eine Fehlermeldung "Host not found" o.ä. zu bringen.

    Dann änderst Du nach und nach (einzeln!) Einstellungen in Postfix- und/oder Asterisk-Konfiguration und schaust, was das für Auswirkungen hat. Wenn Du nämlich erst im Postfix sagst, dass er auch noch "aberhallo" als lokal erkennen soll (Du weißt schon, mydestination und so), dann nimmst Du danach Änderungen im Asterisk vor und testest jeweils, wie es sich auswirkt. Was geht dann unter dem Namen "aberhallo" rein und raus, was noch als "localhost" oder "localhost.de".

    So, mehr Tipps hoab i ned. :)

    Viel Spaß am Gerät!
     
  8. FrankIT

    FrankIT Mitglied

    Registriert seit:
    4 Feb. 2006
    Beiträge:
    735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich würde mal prüfen, ob logrotate die Log-Dateien versendet. Gibt es vielleicht eine Datei /etc/logrotate.d/asterisk, in der die Option mail gesetzt ist?
     
  9. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    unter /etc/logrotate.de/asterisk steht folgendes:

    Code:
    /var/log/asterisk/messages /var/log/asterisk/*log /var/log/asterisk/debug /var/log/asterisk/console /var/log/asterisk/full {
        create 0640 asterisk asterisk
        daily
        extension .txt
        mail root@localhost
        missingok
        nocompress
    #    notifempty
        rotate 32
        sharedscripts
    #    size 10M
        postrotate
        /usr/sbin/asterisk -rx 'logger reload' >/dev/null 2>/dev/null || true
        endscript
    }
    
    /var/log/asterisk/cdr-csv/*csv /var/log/asterisk/cdr-custom/*csv {
        create 0640 asterisk asterisk
        monthly
        extension .txt
        mail root@localhost
        missingok
        nocompress
    #    notifempty
        rotate 2
        sharedscripts
    #    size 10M
        postrotate
        /usr/sbin/asterisk -rx 'logger reload' >/dev/null 2>/dev/null || true
        endscript
    }
    
    das erklärt aber ja immer noch nicht warum dann an root@localhost.de gesendet wird,oder? wenn ich jetzt einfach root@localhost lösche werden keine logs mehr gesendet?

    gruß
    Beebob007

    Edit Guard-X: Code-Tags eingefügt!
     
  10. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    also postfix sendet nur was der "Mensch" vor dem pc einstellt.
    Wie lautet den der name deines rechners inc. domainbezeichnung. wenn du das nicht genau weisst gibt mal folgendes ein:

    hostname --fqdn
     
  11. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    der befehl lieferte:

    trixbox1.main.XXX.local
     
  12. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mit "XXX" ist eigentlich unmöglich .. oder willst du die vollständige uns nicht sagen?
     
  13. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    trixbox1.main.bc-software.local
     
  14. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ok .. das scheint ja mal ok.

    schau mal in folgende datein ob dort irgendwas auf .de umgeschrieben ist:
    /etc/alias
    /etc/postfix/canonical
    /etc/postfix/virtual

    und dann gibt es in der main.cf von postfix den eintrag
    realyhost. Setzte dort den eintrag mal auf =smtp damit wird der gesamte postausgang erstmal festgehalten. auf der konsole kannst du dann mit mailq nachschauen was beim versenden der email so alles passiert.
     
  15. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sorry :
    muss natürlich sein:
    "defer_transport=smtp"
     
  16. Beebob007

    Beebob007 Neuer User

    Registriert seit:
    26 Mai 2008
    Beiträge:
    80
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    guten morgen,
    der tipp mit /etc/logrotate.de/asterisk war goldrichtig. ich hab mal unter mail meine emailadresse angegeben und nun bekomme ich die logfiles.allerdings sind das ganz schön viele und meist immer mit endung 33(also die 33ste datei).
    wenn ich unter mail jetzt nichts mehr angebe, werden auch keine mails mehr verschickt,oder? ist das standart das mails verschickt werden mit logfiles? wie macht ihr das?

    zu meinem localhost.de problem:
    das liegt an unserem ausgelagerten mailserver.der macht aus root@localhost ein root@localhost.de.und da der mailserver sich nicht bei uns befindet ist das natürlich ein problem.aber jetzt auch egal, da ich dank eurer hilfe ja den fehler gefunden habe! :)

    gruß
    Beebob007