privoxy config bearbeiten

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
Hi,

ich habe privoxy auf freetzs laufen und habe damit ein Problem:

Übers Webinterface http://p.p kann ich nichts bearbeiten, weil "enable-edit-actions" standardmäßig auf null gesetzt ist (was ja auch Sinn macht). Daher habe ich die config von privoxy im Verzeichnis /var/mod/etc/privoxy per telnet bearbeitet und dort auch paar andere sachen geändert. (log file auf usb ausgelagert, debug geändert etc.)

Nun stellt privoxy aber nach jedem Neustart die original config wieder her. Wie kann ich das unterbinden? Denn so haben meine Änderungen ja gar keinen Effekt.

Ich muss dazu sagen, dass ich sowohl in freetz als auch in Linux Sachen sehr unerfahren bin... daher bitte nicht hauen wenn es ne saublöde Frage ist ;)
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
7,782
Punkte für Reaktionen
12
Punkte
38
Siehe Konfiguration im Link.
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
falls du das security level meinst. das steht schon auf 0 bei mir.
 

Beetlejuice

Mitglied
Mitglied seit
2 Feb 2007
Beiträge
251
Punkte für Reaktionen
0
Punkte
0
Warum bearbeitest Du die Privoxy-Einstellungen nicht über das Freetz-Webif?
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
Wo geht das denn? Unter Pakete - Privoxy kann ich nur allgemeine Sachen einstellen.

Und Befehle unter Einstellungen - User Actions/Filter nimmt er nicht an.
 

Beetlejuice

Mitglied
Mitglied seit
2 Feb 2007
Beiträge
251
Punkte für Reaktionen
0
Punkte
0
Ich meinte letzteres. Was heißt "nimmt er nicht an"?
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
Wenn ich z.B. diese Befehle hier in die Actions oder die Filter Datei einsetze
enable-edit-actions 1
debug 1
logdir /var/media/ftp/uStor01

ändert sich (auch nach einem restart) gar nichts.

Im Log erscheint so etwas:
Dec 05 09:01:52.701 Privoxy(00000400) Error: Ignoring job enable-edit-actions 1
outside filter block in /tmp/flash/user.filter, line 1
Dec 05 09:01:52.702 Privoxy(00000400) Error: Ignoring job debug 1 outside filter
block in /tmp/flash/user.filter, line 2
Dec 05 09:02:02.361 Privoxy(00000400) Error: Ignoring job enable-edit-actions 1
outside filter block in /tmp/flash/user.filter, line 1
Dec 05 09:02:02.363 Privoxy(00000400) Error: Ignoring job debug 1 outside filter
block in /tmp/flash/user.filter, line 2
Dec 05 09:02:02.364 Privoxy(00000400) Error: Ignoring job logdir /var/media/ftp/
uStor01 outside filter block in /tmp/flash/user.filter, line 3
 

Beetlejuice

Mitglied
Mitglied seit
2 Feb 2007
Beiträge
251
Punkte für Reaktionen
0
Punkte
0
Wenn ich das auf die schnelle richtig gegooglet habe, dann gehören diese Befehle auch bestenfalls in die config Datei. Diese Befehle gehören weder in die User Actions noch in die User Filter.
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
Richtig.

Das wollte ich von Anfang an ja machen. Nur bestand da wie gesagt dieses Problem, dass die config bei jedem Restart von Privoxy wieder auf den Standard gesetzt wird. :(

Gibts denn keine Möglichkeit die config irgendwie anders zu bearbeiten? Es muss doch schon mal jemand die config von privoxy verändert haben. :confused:
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
ich benutze kein Privoxy, aber wie bei jedem Paket wird die config beim aufruf von
Code:
/etc/init.d/rc.paket start
neu generiert.
Warum machst du es nicht wie im Startscript von Privoxy und änderst erst die config und startest es dann von hand mit
Code:
privoxy --pidfile /var/run/privoxy.pid /mod/etc/privoxy/config > /dev/null 2>&1
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
das klappt wunderbar. Vielen Dank :)
 

qqq2001

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
So nachdem ich festgestellt habe, dass Privoxy die CPU der Fritzbox doch relativ gut belastet, habe ich privoxy deaktiviert und werde es nur bei Bedarf deaktivieren (wenn ich eben von außerhalb den Proxy brauche). Damit ich dafür nicht immer Telnet aktivieren muss um darüber den --pidfile Befehl auszuführen, wollte ich die "/root/etc/init.d/rc.privoxy" bearbeiten.
Damit eben beim Klick auf Start nur der Startbefehl ausgeführt wird, aber nicht die config resetet wird.

Leider musste ich dann feststellen, dass der Bereich "read-only" ist (vermutlich aus guten Grund ;)) ... kann ich diesen irgendwie temporär mit Schreibzugriff mounten oder so?

Denn ich nehme nicht an, dass man "mal so eben" einen weiteren Button bei freetz einfügen kann mit dem man NUR diesen Befehl ausführt?!
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
mach es doch über die rudi-shell.

Sonst kannst du das cgi-file kopieren, editieren und mit mount -o bind ... überschrieben.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,997
Beiträge
2,041,185
Mitglieder
353,255
Neuestes Mitglied
dssfdfds