.titleBar { margin-bottom: 5px!important; }

Problem beim Installieren der Datenbank

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von der_kilian, 15 Sep. 2006.

  1. der_kilian

    der_kilian Neuer User

    Registriert seit:
    13 Juli 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    Hallo,
    ich versuche gerade freepbx 2.1.2 auf meinem * zum laufen zu bringen.
    Halte mich ziemlich an die Anleitung von
    http://www.pug.org/index.php/Asterisk,_FreePBX_und_mISDN_unter_Debian#FreePBX_Grundeinrichtung

    Beim installieren der Datenbannk bekomme ich immer

    mysql --user root -p asterisk < /usr/src/freepbx-2.1.2/SQL/newinstall.sql
    Enter password:
    ERROR 1064 at line 21: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 17

    Kann mir jemand helfen?

    Schon mal vielen Dank!
     
  2. beckmann

    beckmann Guest

    Na was steht denn zwischen Zeile 17 - 21? Da musst du uns hier schon mitteilen ;)
     
  3. der_kilian

    der_kilian Neuer User

    Registriert seit:
    13 Juli 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    #3 der_kilian, 15 Sep. 2006
    Zuletzt bearbeitet: 15 Sep. 2006
    ab Zeile 13

    --
    -- Table structure for table `Backup`
    --

    DROP TABLE IF EXISTS `Backup`;
    CREATE TABLE `Backup` (
    `Name` varchar(50) default NULL,
    `Voicemail` varchar(50) default NULL,
    `Recordings` varchar(50) default NULL,
    `Configurations` varchar(50) default NULL,
    `CDR` varchar(55) default NULL,
    `FOP` varchar(50) default NULL,
    `Minutes` varchar(50) default NULL,
    `Hours` varchar(50) default NULL,
    `Days` varchar(50) default NULL,
    `Months` varchar(50) default NULL,
    `Weekdays` varchar(50) default NULL,
    `Command` varchar(200) default NULL,
    `Method` varchar(50) default NULL,
    `ID` int(11) NOT NULL auto_increment,
    PRIMARY KEY (`ID`)
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1;

    --
    -- Dumping data for table 'Backup'
    --

    /*!40000 ALTER TABLE `Backup` DISABLE KEYS */;
    LOCK TABLES `Backup` WRITE;
    UNLOCK TABLES
    /*!40000 ALTER TABLE `Backup` ENABLE KEYS */;


    Soweit ich das richtig verstehe versucht er eine Tabelle "Backup" zu erzeugen.
    Aber was stört ihn an dem Zeichensatz??

    anbei noch meine my.conf da alle Threads die ich gefunden habe irgendwie dahin führen:

    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0

    [mysqld]
    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    language = /usr/share/mysql/english
    skip-external-locking
    bind-address = 127.0.0.1
    key_buffer = 16M
    max_allowed_packet = 16M
    thread_stack = 128K
    query_cache_limit = 1048576
    query_cache_size = 16777216
    query_cache_type = 1
    log-bin = /var/log/mysql/mysql-bin.log
    max_binlog_size = 104857600
    skip-bdb

    [mysqldump]
    quick
    quote-names
    max_allowed_packet = 16M

    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition

    [isamchk]
    key_buffer = 16M

    Ich hoffe es kann jemand was damit anfangen. :)